Drivers requests for DSM 5.2


Recommended Posts

Volume containing drives attached to SCSI/SAS controller is "broken" on each reboot, you must click repair.

 

Test to load module in rc instead of ramdrive but no luck.

We must test and figure out what append when we press this fuck*ng repair button.

 

EDIT:

This shit is definitively link to something in the ramdrive, because if we try to install DSM directly on a sas/scsi controller disk system keep rebooting with configuration lost.

Both issues seems to be related

Link to post
Share on other sites

Installed the update on barebones with M1015 SAS controller, but it is only recognizing 2 of 8 HD, all HDs were clean with Gparted btw.

 

What I did was to load the latest .img to USB the unzipt the rd.gz and copy the .ko on the folder named modules on the latest beta gzip back and copy rd.gz back to usb.

 

is that the right thing whne you say to copy .ko to /lib/modules?

 

I tried both installing with all HD attached and then just installing to one mall SSD and then re-attaching HDs after install was complete, no matter what it only recognizes 2 og the HDs attached to the SAS controller

 

Ok, did a fdisk -l via ssh and all the HD are listed, why will the webui only show 2?

also looked dmesg and when mpt2sas loads it detects all HDs

 

I know is a beta, just wanted to share my experience

 

 

 

thanks for all the hard work

Link to post
Share on other sites
hi

For information,I install the update with LSI9211-8i and only 4/6 HD recognized.

Thank's for all.

on a M1015 flashed to IT (basically LSI) 2 of 8

 

can you do a fdsik -l and see if at least all HDs are recocnized, have to ssh inti diskstation to do it unles you have a monitor attached to it

Link to post
Share on other sites
This is an updated synoobot file which include several fixes.

Copy *.ko files to /lib/modules

 

Link : http://xpenology.trantor.be/beta/synobo ... re-v1.1.7z

 

Known issues:

- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot)

- Volume containing drives attached to SCSI/SAS controller is "broken" on each reboot, you must click repair.

 

Changelog:


- Update synobios.ko (by k3dt ; fix "buzzer stop button pressed" warning)


SCSI
----

Highpoint Rocketraid 2720SGL
LSI mpt2sas v17
Adaptec aacraid
Intel C600 Series Chipset SAS


NETWORK
-------

3Com 3c590/3c900, 3cr990
Alteon AceNIC/3Com 3C985/NetGear GA620
QLogic QLA3XXX
SiS 900/7016 SiS190/SiS191


USB
---

USB to serial / Prolific 2303 driver


PATA
----

ATI PATA (PATA_ATIIXP)
AMD/NVidia PATA (PATA_AMD)
CMD64x PATA (PATA_CMD64X)
JMicron PATA (PATA_JMICRON)
Marvell PATA (PATA_MARVELL)
Promise PATA 2027x (PATA_PDC2027X)
Intel SCH PATA (PATA_SCH)
CMD / Silicon Image 680 PATA (PATA_SIL680)
SiS PATA (PATA_SIS)
VIA PATA (PATA_VIA)
Winbond SL82C105 PATA (PATA_WINBOND)
Legacy PATA support (PATA_LEGACY)

Thanks !

Upgrading a ESXI VM with converting this IMG file to VMDK is sufficient ? Or do I need to wait for adapted version ?

Link to post
Share on other sites
Can you add the Promise SuperTrack EX12350 Raid Controller Driver?

My Promise SuperTrak Raid Controller doesnt work.

 

Your controller is handle by stex driver. It's included in 4.3 build (driver version 4.6.0000.4).

Can you test with ubuntu livecd and look if it work and then give informations about module/version.

Link to post
Share on other sites

This is an updated synoobot file which include several updates/fixes.

(For the AX88179 Gigabit Ethernet USB 3.0, you have to manually insmod usbnet.ko BEFORE insmod ax88179_178a.ko)

 

Link : viewtopic.php?f=2&t=1361&p=9464#p9464

 

Known issues:

- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot)

- Volume containing drives attached to SCSI/SAS controller is "broken" on each reboot, you must click repair.

 

Changelog:

v2

- AX88179 Gigabit Ethernet USB 3.0
- Latest driver version for RocketRAID 3xxx/4xxx Controller
- Latest (aacraid) driver version for Adaptec
- Support XFS filesystem (no idea if DSM will automount this)


v1

- Update synobios.ko (by k3dt ; fix "buzzer stop button pressed" warning)


SCSI
----

Highpoint Rocketraid 2720SGL
LSI mpt2sas v17
Adaptec aacraid
Intel C600 Series Chipset SAS


NETWORK
-------

3Com 3c590/3c900, 3cr990
Alteon AceNIC/3Com 3C985/NetGear GA620
QLogic QLA3XXX
SiS 900/7016 SiS190/SiS191


USB
---

USB to serial / Prolific 2303 driver


PATA
----

ATI PATA (PATA_ATIIXP)
AMD/NVidia PATA (PATA_AMD)
CMD64x PATA (PATA_CMD64X)
JMicron PATA (PATA_JMICRON)
Marvell PATA (PATA_MARVELL)
Promise PATA 2027x (PATA_PDC2027X)
Intel SCH PATA (PATA_SCH)
CMD / Silicon Image 680 PATA (PATA_SIL680)
SiS PATA (PATA_SIS)
VIA PATA (PATA_VIA)
Winbond SL82C105 PATA (PATA_WINBOND)
Legacy PATA support (PATA_LEGACY)

Link to post
Share on other sites

Trantor first I want to say that you're the best! The work you put in this project keeps it alive and running smooth.

I run XPEnology in a KVM virtual machine managed through virt-manager, but I noticed that some things are not working.

Firstly I can only mount the synoboot image as a virtio drive, my HDD's can only be IDE drives otherwise the won't be recognized.

Secondly I cannot use any other network adapter then the e1000. When I use the virtio driver my Diskstation isn't found anymore.

 

When I was looking for a fix I came across a post an page 2 of this thread and used the image some pages later but it has not made a difference for me. It is weird because a while back a was experimenting with XPEnology and I think back then I was able to use the virtio network adapter.

It would be so awesome if there is a way to fix this. A HDD as a virtio drive is a lot faster and the virtio network adapter is also faster then the e1000.

Can you shine you're light over this problem?

 

Edit:

Also the XPEnology installation recognizes only one core in system information when I assigned two cores, is this normal?

Link to post
Share on other sites
This is an updated synoobot file which include several updates/fixes.

(For the AX88179 Gigabit Ethernet USB 3.0, you have to manually insmod usbnet.ko BEFORE insmod ax88179_178a.ko)

 

Link : http://xpenology.trantor.be/beta/synobo ... v1.1_v2.7z

 

Known issues:

- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot)

- Volume containing drives attached to SCSI/SAS controller is "broken" on each reboot, you must click repair.

 

Changelog:

v2

- AX88179 Gigabit Ethernet USB 3.0
- Latest driver version for RocketRAID 3xxx/4xxx Controller
- Latest (aacraid) driver version for Adaptec
- Support XFS filesystem (no idea if DSM will automount this)


v1

- Update synobios.ko (by k3dt ; fix "buzzer stop button pressed" warning)


SCSI
----

Highpoint Rocketraid 2720SGL
LSI mpt2sas v17
Adaptec aacraid
Intel C600 Series Chipset SAS


NETWORK
-------

3Com 3c590/3c900, 3cr990
Alteon AceNIC/3Com 3C985/NetGear GA620
QLogic QLA3XXX
SiS 900/7016 SiS190/SiS191


USB
---

USB to serial / Prolific 2303 driver


PATA
----

ATI PATA (PATA_ATIIXP)
AMD/NVidia PATA (PATA_AMD)
CMD64x PATA (PATA_CMD64X)
JMicron PATA (PATA_JMICRON)
Marvell PATA (PATA_MARVELL)
Promise PATA 2027x (PATA_PDC2027X)
Intel SCH PATA (PATA_SCH)
CMD / Silicon Image 680 PATA (PATA_SIL680)
SiS PATA (PATA_SIS)
VIA PATA (PATA_VIA)
Winbond SL82C105 PATA (PATA_WINBOND)
Legacy PATA support (PATA_LEGACY)

 

 

 

Thanks for adding the HighPoint RocketRaid 2720SGL driver. I'm not sure if you are working on the SAS issue for the next build, if so thank you! I was hoping you could assist me as I get the following upon boot:

 

mpt2sas loaded

rr272x_1x module license 'Proprietary' taints kernel

Disabling lock debugging due to kernel taint

rr272x_1x:RocketRaid 272x_1x controller driver v1.5....

 

It then just sits with trying to recover...but failes with error. Also, I cannot see any hard drives to install to.

 

Many thanks!

CogiSphere

Link to post
Share on other sites
is the fix for the scsi/hba near?

 

Not my priority for now. We must investigate further to find out why DSM do not detect drives attached to scsi/sas controller at boot and prevent us to install DSM on them

 

Please help. in 4.3 don't work my lan card TP-LINK TG-3269, 4.2 yes. Y?

I need driver for wifi TP-LINK TL-WDN4800.

 

For your network card based on a realtek chip, I modified the embedded r8169 driver (remove r8168 support from it to prevent conflict with the included r8168) : http://xpenology.trantor.be/beta/r8169.ko

Copy it to modules folder, insmod it, and type : ifconfig ethX up (where X is the network card number, ie ; eth0, eth1 ...)

 

I run XPEnology in a KVM virtual machine managed through virt-manager, but I noticed that some things are not working.

 

I will add more drivers for KVM / virtio / virtualization support

Link to post
Share on other sites
This is an updated synoobot file which include several fixes.

Copy *.ko files to /lib/modules

 

New version available : viewtopic.php?f=2&t=1361&p=8887#p8887

 

Known issues:

- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot)

- Volume containing drives attached to SCSI/SAS controller is "broken" on each reboot, you must click repair.

 

Changelog:


- Update synobios.ko (by k3dt ; fix "buzzer stop button pressed" warning)


SCSI
----

Highpoint Rocketraid 2720SGL
LSI mpt2sas v17
Adaptec aacraid
Intel C600 Series Chipset SAS


NETWORK
-------

3Com 3c590/3c900, 3cr990
Alteon AceNIC/3Com 3C985/NetGear GA620
QLogic QLA3XXX
SiS 900/7016 SiS190/SiS191


USB
---

USB to serial / Prolific 2303 driver


PATA
----

ATI PATA (PATA_ATIIXP)
AMD/NVidia PATA (PATA_AMD)
CMD64x PATA (PATA_CMD64X)
JMicron PATA (PATA_JMICRON)
Marvell PATA (PATA_MARVELL)
Promise PATA 2027x (PATA_PDC2027X)
Intel SCH PATA (PATA_SCH)
CMD / Silicon Image 680 PATA (PATA_SIL680)
SiS PATA (PATA_SIS)
VIA PATA (PATA_VIA)
Winbond SL82C105 PATA (PATA_WINBOND)


Legacy PATA support (PATA_LEGACY)

 

Hi I , I have the buzzer problem, but I don't know how to make the to copy of synobios.ko files to /lib/modules

 

Many thanks for your help.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.