Drivers requests for DSM 5.2


Recommended Posts

Hi!

 

Could you please add support for the onboard eSATA port multiplier of the HP Microserver Gen7?

That is N36L, N40L and N54L. Until now it worked only in the way that only the first drive was visible.

 

The Microserver doesn't support the port multiplier, but it works well after the BIOS Mod under:

Windows, Linux Ubuntu, Open Media Vault and other OSs.

I was struggeling to get it working with XPEnology 6.0.1, 5.2 for two whole weeks with no success. Switched to other NAS OSs but always missed the DSM in some way.

 

As far as I read many users are running XPEnology on the Gen7 Microserver and would find the port multiplier support terrific to connect multiple bay enclosures over eSATA.

 

Is this a realistic task?

 

Any answer is appreciated!

Edited by Zver
Link to post
Share on other sites

Hi,

 

it is possible to add Broadcom NetExtreme II to the drivers?

I am not able at the moment to access the DiskStation...

Ubuntu tells me that this are "Broadcom Limited NetExtreme II BCM5716" NICs.

 

Thank you!

Edited by IceBoosteR
Link to post
Share on other sites

is it possible to blacklist R8169 to make R8168 driver load on the loader 1.02 from jun. 

 

This seems to be my issue with a headless unit HP EX495 mediasmart box. I have two of these boxes that required loading this same driver direct from realtek to fix this issue. 

 

Issue: File starts blazing fast, 3 to 4 seconds later drops to 0 and crashes nic until a reboot is performed. 

 

I am almost positive this is the exact same issue with 5.2.5466. 

 

This is the only thing holding me up from a 6.1.2 install on a headless EX495. 

 

Any assistance appreciated. 

 

 

Link to post
Share on other sites
22 hours ago, IceBoosteR said:

Hi,

 

it is possible to add Broadcom NetExtreme II to the drivers?

I am not able at the moment to access the DiskStation...

Ubuntu tells me that this are "Broadcom Limited NetExtreme II BCM5716" NICs.

 

Thank you!

Hello out there.

I have started to compile it on my own, but I got stucked :(

Can some please be so kind and provide the drivers for me for the actual Broadwell based DS3617xs? drivers posted above.

I think its done when you use "Broadcom NetExtreme II" in the kernel list. But this is the pont whre I got stucked with an unsolved bug on GCC.

I have tried in with a clean Debian (makes that more easy as in a vm wiht chroot) and got the same error.

Any help would be appriciated, as I now want to use my server :smile:

 

Edit: I woudl like to use latest loader 1.02b

 

Regards

Ice

Edited by IceBoosteR
Link to post
Share on other sites
On 30.7.2017 at 1:53 AM, nc88keyz said:

is it possible to blacklist R8169 to make R8168 driver load on the loader 1.02 from jun.

 

yes, there may be other ways but it can be done by changing the extra.lzma

asuming its about a fresh install starting from usb stick and pat file

the modules loaded at boot are named in rc.modules in the extra.lzma the files liker8169.ko are olso in the extra.lzma

the problem is to edit the rc.modules or delete the r8169.ko you will have to unpack und repack the extra.lzma (i described thi in my howto in building and injecting drivers) in jun's 1,02b there are both entrys in rc.modules, r8168 first so i expected it to load r8168 before r8169

 

in my extra.lzma ("driver extension") the rc.modules only contains the r8168 entry so it should do what you want, but as i wrote above i'm not so certain tthat it will solve your problem, maybe its the other way around, but you could test this by using jun's original 1.02a, it only contains r8169 (r8168 was introduced with 1.02b)

 

Link to post
Share on other sites

This topic was setup by @Trantor at the time of DSM 5.x. That is long ago (~4 years) and we are now at DSM 6.x. Unfortunately Trantor has not maintained this thread for some time. I will keep it open as a reference for other developers who wish to see what drivers have been/are requested but I urge everyone posting here to post according to the guidelines that were provided in the OP, which I will recall here below for the sake of clarity. Please also add the DSM version you want the driver for. Note that there is absolutely no guarantee that any of these requests will be taken into consideration in view of what I said above.

 

On 10/8/2013 at 5:16 AM, Trantor said:

This thread is for requesting drivers for hardware (net, storage) which are not supported by XPEnology yet.

 

The purpose of this it to regroup drivers request in order to improve XPEnology in the next repack.

 

Please test with the latest build and check HARDWARE SUPPORTED LIST before asking for driver !

Please do not request WIFI drivers

 

Please give most informations as you can (brand, chip, revision...).

If you can test your hardware with ubuntu livecd to get modules infos and/or give manufacturer download link.

 

Be concise in your post and strictly stick to topic or I will delete posts without any warning.

 

Thank you.

Link to post
Share on other sites
7 hours ago, joanaral said:

I have a home NAS with an Asrock K10N78D motherboard, I am trying to migrate to DSM 6.0, but after following the tutorial, both find.synologic.com and the Synology assistant do not recognize the NAS, which is true of DSM 5.2.
The web of the drivers is http://www.asrock.com/MB/NVIDIA/K10N78D/index.asp#osAll
Thank you very much.

 

in theory the driver would alredy be availible as what you need will be "forcedeth.ko" and thats part of the extra.lzma ramdisk polanskiman is providing in his tutorial

https://mega.nz/#!HERm2ITI!0-eZDuY9pJzSeesON1O9N49QXat8EhvH1b9JtE5KdJo

 

 

 

Link to post
Share on other sites

I can usually figure these things out, but I have been slamming my head against a wall trying to compile a driver for 1.02b broadwell(DS3617xs).

 

I have a highpoint 644L for esata and I cannot seem to make it work. Would someone be able to assist me in compiling this?

 

http://www.highpoint-tech.com/USA_new/series_rr600-download.htm

 

Let me know if you need anything else!

 

Thank you very much.

Link to post
Share on other sites

Hi IG-88:

im testing DSM 6.0.2 (Jun's loader) and replace two versions of extra.lzma but nothing .

Could you please add the driver for Lan: Atheros PCI-E Gigabit Ethernet AR8131?

https://askubuntu.com/questions/105607/how-do-i-get-an-atheros-ar8131-ethernet-card-working/114672#114672

https://askubuntu.com/questions/105607/how-do-i-get-an-atheros-ar8131-ethernet-card-working

 

Thanks

Link to post
Share on other sites
  • 2 weeks later...
Hello I currently have my NAS under 6.1.3 update 3 with Jun's Loader 1.02b whose configuration is as follows:

Motherboard GA-H270N-WIFI

CPU Intel i5 7400T

Memory DDR4 8Go

SSD NVME 250Go Samsung 960 M2 PCI-E Gen3 x4

4 HDD 4To WD RED

And the SSD is not detected by the system, however I do not know what drivers manages this port

Could you please add the driver for this device ?

 

Thanks !

 

Link to post
Share on other sites

in the manual of Motherboard GA-H270N-WIFI  on page 16:

 

Installation Notices for the M.2 and SATA Connectors:
Due to the limited number of lanes provided by the Chipset, the availability of the SATA connectors may be affected by the type of device installed in the M.2 connector. The M.2 connector shares bandwidth with the SATA3 0 connector. Refer to the following table for details.

 

verify on that table(cant copy to where), the type of instalation you have to do, maybe thats the problem.if usins ssd and one 4tb wd red on same shared lane, the system only detects one of them.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.