Jump to content
XPEnology Community

DSM v7.xx - Virtual Machine Manager - auf


ooooooh

Recommended Posts

hi

 

ich nutze mein xpenology überwiegend als host für meine VM's, mein system wie folgt:

 

i5 10500 - 64gb ram - msi b460m - 4platten -> 2x raid1

 

das ganze seit neustem mit dem Automated RedPill Loader beta3.

 

soweit läuft auch alles ohne Auffälligkeiten, jedoch gibt es ein Performance Problem:

 

die win7 und win8.1 VM's laufen sehr performant auf dem system, aber die Windows 10/11

Installationen sind extrem langsam, nicht wirlich nutzbar.

das beginnt schon bei der installation die super träge ist. kein vergleich zu den win7/8.1 installationen.

 

was mich wundert das es mit jun's loader hierbei keine probleme gab...

 

woran könnte das liegen ?

 

 

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Synology VMM Guest Tool installiert?

https://kb.synology.com/de-de/DSM/tutorial/How_to_install_Synology_Guest_Agent_for_VMM_on_your_virtual_machine

 

https://global.download.synology.com/download/Utility/WinVirtioDriver/1.5.3-0015/Windows/Synology_VMM_Guest_Tool_1.5.3-0015.iso?model=DS920%2B&bays=4&dsm_version=7.1.1&build_number=42962

 

bei den vielen spielereien in win10 ..., versuch mal ob die gui besser wird wenn du einige effekte abschaltest

image.png.39d2e93a34b16d792bc84c44e2cc2dc6.png

 

wenn mir das mit dem windows wichtig wäre würde ich eher einen hypervisor wie esxi oder proxmox auf der hardware laufen lassen und dsm als vm laufen lassen, das gibt sicher die bessere leistung, syno's vmm ist keine gute lösung wenn es vor allem um vm's geht, da würde man lieber zu docker greifen

und meist (bei dir ja nicht ist die nas hardware eher schmal ausgelegt (vor allem syno's consumer hardware) so das so schon problematisch wird, be dem was man so ließt arbeiten programme aber im hintergrund eines windows ganz ok, ist nur nicht so als ersetz für einen desktop geeignet

ich würde vermuten das einen ssd auch etwas hilf das es sich schneller anfühlt  (aber bei der gui an sich wird das sicher nicht helfen)

 

  • Like 1
Link to comment
Share on other sites

On 12/9/2022 at 7:58 PM, IG-88 said:

Synology VMM Guest Tool installiert?

https://kb.synology.com/de-de/DSM/tutorial/How_to_install_Synology_Guest_Agent_for_VMM_on_your_virtual_machine

 

https://global.download.synology.com/download/Utility/WinVirtioDriver/1.5.3-0015/Windows/Synology_VMM_Guest_Tool_1.5.3-0015.iso?model=DS920%2B&bays=4&dsm_version=7.1.1&build_number=42962

 

bei den vielen spielereien in win10 ..., versuch mal ob die gui besser wird wenn du einige effekte abschaltest

 

wenn mir das mit dem windows wichtig wäre würde ich eher einen hypervisor wie esxi oder proxmox auf der hardware laufen lassen und dsm als vm laufen lassen, das gibt sicher die bessere leistung, syno's vmm ist keine gute lösung wenn es vor allem um vm's geht, da würde man lieber zu docker greifen

und meist (bei dir ja nicht ist die nas hardware eher schmal ausgelegt (vor allem syno's consumer hardware) so das so schon problematisch wird, be dem was man so ließt arbeiten programme aber im hintergrund eines windows ganz ok, ist nur nicht so als ersetz für einen desktop geeignet

ich würde vermuten das einen ssd auch etwas hilf das es sich schneller anfühlt  (aber bei der gui an sich wird das sicher nicht helfen)

 

 

@ig-88 danke dir für den response!

 

nun windows ist abgespeckt und lief ja vorher auch super perfomant, es ist die selbe konfig.

die vm's laufen auf SSD's und die guest tools sind installiert, auch mit verschiedenen vers. probiert.

 

das mit proxmox und co. ist mir zu unbekannt, so war es eigntl. gut nur seit DSM v7 will es nicht mehr so richtig mit Win10/11

 

bin da wirklich mit dem Latein am ende...

 

Link to comment
Share on other sites

7 hours ago, ooooooh said:

nun windows ist abgespeckt und lief ja vorher auch super perfomant, es ist die selbe konfig.

die vm's laufen auf SSD's und die guest tools sind installiert.

 

Ich kann dieses Problem voll nachvollziehen. Mit DSM 6.xxx lief Windows 10 einigermaßen gut. Mit DSM 7.1.1-42962 Update 2 ist Windows nicht mehr nutzbar.

Link to comment
Share on other sites

6 hours ago, ooooooh said:

DSM v7 will es nicht mehr so richtig mit Win10/11

und die gleiche vm (mitgleichem win10 build) lief mit dsm 6.2 besser?

du könntest noch versichen neuere virtio treiber von hier zu installieren

https://github.com/virtio-win/virtio-win-pkg-scripts/blob/master/README.md

man könnte auch versichen du qemu konfig der alten version in dsm 6.2 mit der von dsm 7 zu vergleichen, das ist aber dann doch etwas arbeit da man sich dann auch intensiver mit qemu beschäfiten muss

 

 

 

Link to comment
Share on other sites

12 minutes ago, IG-88 said:

und die gleiche vm (mitgleichem win10 build) lief mit dsm 6.2 besser?

du könntest noch versichen neuere virtio treiber von hier zu installieren

 

man könnte auch versichen du qemu konfig der alten version in dsm 6.2 mit der von dsm 7 zu vergleichen, das ist aber dann doch etwas arbeit da man sich dann auch intensiver mit qemu beschäfiten muss

 

 

 

 

ja, die selbe VM lief unter 6.2 um *welten besser, gar kein vergleich !

es ist so als ob alles in zeitlupe ablaufen würde. irgendetwas beisst sich, nur was !?

 

ich hatte die neusten virtio drv's ausprobiert, dev, stable, nightly ... keine änderung.

sage ja, selbst das installieren ist quasi nicht machbar 🤨 , da alles in zeitlupe bei:

 

i5 10500 4.50 GHz - 64gb ddr4 2666mhz ram - ssd . . . , das kann nicht sein.

 

Edited by ooooooh
Link to comment
Share on other sites

10 hours ago, tdse13 said:

Eine Frage: Wie kann ich eine ältere Version von vmm installieren?

mit "theoretisch" meinte ich das VMM paket zu deinstalliere und aus dem link eine ältere zu benutzen

ob und wie weit man rückwärts kann käme auf einen versuch an, deine wunschversion wäre vermutlich 2.5.3 die auch noch unter dsm 6.2 lief, wenn die nicht geht dann 2.5.4 oder neuer

Link to comment
Share on other sites

On 12/12/2022 at 9:59 PM, IG-88 said:

du kannst ja mal ein älteres win10 iso versuchen, 20H2 oder älter

 

theoretisch könnest du auch eine älzere vmm version versuchen

https://archive.synology.com/download/Package/Virtualization

 

wenn du die configs älterer und neurer versionen vergleichn willst dann gibts *.conf unter /etc/libvirt/

 

kann ich testen.

 

ich sehe grade das es ein neuen loader gibt: TinnyCore RedPill (TCRP) beta v.0.9

hat das einen einfluß auf den VM Manager ? (denke nicht)

 

Link to comment
Share on other sites

1 hour ago, ooooooh said:

ich sehe grade das es ein neuen loader gibt: TinnyCore RedPill (TCRP) beta v.0.9

hat das einen einfluß auf den VM Manager ? (denke nicht)

sollte keinen einfloss haben und wenn wäre das ein fetter bug

 

du kannst auch mal versuchen ob im bios vt-d abschalten etwas bringt und das gleiche für die iGPU bzw. deren virtualisierungs support

aber es sind auch andere ursachen/lösungen denkbar (anpassungen in windows oder qemu)

https://serverfault.com/questions/1092404/windows-vm-suddenly-run-very-slow-in-kvm-qemu

https://www.reddit.com/r/ChromeOSFlex/comments/ucno4b/qemukvm_virtmanager_windows_vm_very_slow/

aber sich da einzulesen und alles mögliche ausprobieren wird dich einige zeit kosten

 

 

 

Edited by IG-88
Link to comment
Share on other sites

  • 1 month later...

Bei mir habe ich den Grund für das extreme zähe Verhalten von einer Windows 10 VM gefunden, nachdem ich alles andere inkl. einer älteren Version von VMM vorher ausprobiert hatte. Es lag am TCRP Loader. Nachdem ich den Stick neu aufgesetzt hatte, ist das  zähe Verhalten weg und Windows wieder halbwegs vernünftig nutzbar.

Link to comment
Share on other sites

On 1/21/2023 at 12:25 AM, tdse13 said:

Nachdem ich den Stick neu aufgesetzt hatte, ist das  zähe Verhalten weg und Windows wieder halbwegs vernünftig nutzbar.

mit einer neueren version des loaders? (also dann auch einer neueren version des redpill treibers)

 

Link to comment
Share on other sites

29 minutes ago, IG-88 said:

mit einer neueren version des loaders? (also dann auch einer neueren version des redpill treibers)

 

 

Ja. Mit der vorhanden Version ging es -trotz update- nicht. Ich habe dann den Stick neu mit einer anderen, neueren Version befüllt 

Link to comment
Share on other sites

  • 1 year later...

Ich habe XPEnology DSM 7.2.1-69057

Und dort habe ich schon seit einem Jahr mein Home assistent als VM laufen unter dem VM Manager. Jetzt habe ich aus Gründen die CPU getauscht (fals es wichtig ist 5600G) damit ich die Nas nicht immer uasseinanderbauen muss 10GB Netzwerkkarte rein Grafikkarte rein Problem fixen beide Karten tauschen

Seit dem bekomme ich alle meine VM´s nicht mehr gestartet. Es steht nicht mal wirklich ein Grund da. Dann soll ich mir Recorsen ausssuchen wo alles an resorcen im überfluss ist.
Trotzdem Startet er nicht

Habe inzwischen Schon alles neu instaliert ohne Erfolg (Stick update, Vm Mannager, jede einzelne VM) Ich habe im VM Mannager alle funktionen ausprobiert alles ohne erfolg!

Ich hoffe Jemand von euch kann mir Weiterhelfen    

 

Fragen warum ich irgendwas gewechselt haben oder das man selber es ganz anders gemacht hätte helfen nich darum bitte ich Euch mit sollechen Textden hier nichts zuzuspammen

 

Danke an alle die Helfen wollen oder können

Link to comment
Share on other sites

On 5/27/2024 at 7:53 PM, Hoppe said:

VM Manager. Jetzt habe ich aus Gründen die CPU getauscht (fals es wichtig ist 5600G)

da fehlen ein paar sachen, welches dsm modell und welche cpu vorher drin war

aber ich würde vermuten das es ein dsm modell was das im grinial eine intel cpu hat und du hattest vorher eine intel cpu?

der dsm kernel ist jeweils für die cpu "optimiert", sieht man am jeweiligen namen von "Package Arch" in diesem link (in den meisten fällen sieht man das auch in den *.pat dateien

https://kb.synology.com/en-global/DSM/tutorial/What_kind_of_CPU_does_my_NAS_have

 

sol lange man kein intel qsv oder vmm nutzt kann man in der regel ein dsm modell das für intel gedacht ist auch mit amd nutzen

sollte man vmm nutzen wollen ist ein modell wechsel (in loader) nötig, dann instaliert man ein cross update bei dem die dsm einstellungen übernommen werden

r1000,v1000 und Epyc7002 sind amd, letztere hat sogar einen 5er kernel (ob man das dann in der performance merkt ist mir nicht bekannt, kann aber in sachen ootb treiber vorteile bringenm wobei es in den aktuellen loadern wir arc jede menge zusätzliche treiber gibt, selbst der igc 2.5G intel treiber wurde auf kernel 4.x  als backport gebaut obwohl das intel nicht liefert/unterstützt)

 

 

Link to comment
Share on other sites

  • 2 weeks later...
On 5/31/2024 at 8:32 PM, IG-88 said:

da fehlen ein paar sachen, welches dsm modell und welche cpu vorher drin war

aber ich würde vermuten das es ein dsm modell was das im grinial eine intel cpu hat und du hattest vorher eine intel cpu?

der dsm kernel ist jeweils für die cpu "optimiert", sieht man am jeweiligen namen von "Package Arch" in diesem link (in den meisten fällen sieht man das auch in den *.pat dateien

https://kb.synology.com/en-global/DSM/tutorial/What_kind_of_CPU_does_my_NAS_have

 

sol lange man kein intel qsv oder vmm nutzt kann man in der regel ein dsm modell das für intel gedacht ist auch mit amd nutzen

sollte man vmm nutzen wollen ist ein modell wechsel (in loader) nötig, dann instaliert man ein cross update bei dem die dsm einstellungen übernommen werden

r1000,v1000 und Epyc7002 sind amd, letztere hat sogar einen 5er kernel (ob man das dann in der performance merkt ist mir nicht bekannt, kann aber in sachen ootb treiber vorteile bringenm wobei es in den aktuellen loadern wir arc jede menge zusätzliche treiber gibt, selbst der igc 2.5G intel treiber wurde auf kernel 4.x  als backport gebaut obwohl das intel nicht liefert/unterstützt)

 

 

Ich  habe von einem Rayzen 2600x auf einen 5600G gewechselt ich habe dannach auch eine Anpassung Und Update im Arc Loder versucht ohne Erfolg Model SA6400 da stand im Arc Loder das das mit AMD und Grafikeinheit laufen soll.

Darum weis ich nicht wo das Problem ist

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...