Aigor

[SOLVED] Strange Bahavior wit Intel dual 10Gb sfp card

Recommended Posts

Hi friends, i have one Gen8 box with dsm 6.02 with last Jun bootloader, i add a 10 Gb SFP intel network card and try to configure iSCSI to host a datastore for my esxi box.

Everything seems ok, but despite card have static ip and webinterface showme connect at 10 Gb FD i can't ping vmware host and from vmware i can't ping synology box, i'm still crazy , i'm not able to target the problem, everything seems work fine but i can't add iSCSI target.

Many thanks

Edited by Guest

Share this post


Link to post
Share on other sites

I am not using VM, I am on baremetal, but I remember I had some issues in the past when I tried to ping the NAS. I solved it by adding an ICMP rule in DSM firewall which explicitly allowed DSM to respond to ping requests. Try that and let me know if it works for you.

Share this post


Link to post
Share on other sites
I am not using VM, I am on baremetal, but I remember I had some issues in the past when I tried to ping the NAS. I solved it by adding an ICMP rule in DSM firewall which explicitly allowed DSM to respond to ping requests. Try that and let me know if it works for you.

 

Hi, i'm using baremetal too, i have one esxi host and one gen8 box with xpenology installed, all works fine.

So i decide to play with 10Gb nic card to use iSCSI as storage for esxi host, i bought 3 cards, one dual port to install on xpenology, and other two for my desktop pc and my esxi host.

I don't have any switches, i connect esxi 10Gb card directly with one port on dual port card in xpenology, defined iSCSI lun and target, assigned ip on same class on both hosts ( xpenology and esxi) try to ping frome one to each other, no ping response, both webinterface show me card connected, so i assume both are working, tcpdump on xpenology on 10Gb card, show me no packet comes from somewhere :shock: when ping from esxi to xpenology, networking are up and running.

I suspect there is some trick on synology because i have the same problem if i connect my desktop pc with xpenology via 10gb card.

As far you know there is some bond beetwein number of physical cards and boot argument if_number=(number of card ) ?

After my regular work i will try to figure what's wrong, but i suspect is boot arg if_number

Many thanks for the answer.

Share this post


Link to post
Share on other sites

Aigor, did you manage to get to the bottom of this?

 

I think I'm experiencing exactly the same issue with HP NC365T card I added to my HP Microserver running DSM 6.0.2.

Share this post


Link to post
Share on other sites
Aigor, did you manage to get to the bottom of this?

 

I think I'm experiencing exactly the same issue with HP NC365T card I added to my HP Microserver running DSM 6.0.2.

yes and not.

Digging into boot log i catch this errors

[   15.985894] ixgbe 0000:07:00.0: SR-IOV: bus number out of range
[   15.988036] ixgbe 0000:07:00.0 (unregistered net_device): Failed to enable PCI sriov: -12
[   16.162859] ixgbe 0000:07:00.1: SR-IOV: bus number out of range
[   16.164981] ixgbe 0000:07:00.1 (unregistered net_device): Failed to enable PCI sriov: -12
[   21.064691] BTRFS: has skinny extents

It seems it's' a SR-IOV probolem.

Looking for error in google, i found a trick, i have to load ixgbe module with max_vfs=8 param, but this param it's already present in /etc/modules_conf.

Unload ixgbe and load without any param, did trick, but evene if commented out param in modules_conf, it seems that module still loading at boot time with param, the only way to work with intel dual 10Gb card, it's' unload module, reload whitout any params, and restart networking,after this trick 10Gb card start to working well.

I would like to avoid any param to be passed to module, but i don'know where looking for, using modules_conf like in any other distro, don't do the magic

If you have some idea :grin:

Share this post


Link to post
Share on other sites

Solved :grin: i had to edited /etc.defaults/modules.conf , deleted max_vfs param my card it's working

Share this post


Link to post
Share on other sites
Solved :grin: i had to edited /etc.defaults/modules.conf , deleted max_vfs param my card it's working

 

Can you tell me what exactly you have got in /etc.defaults/modules.conf?

 

Or is it /etc/modules.conf that needs to be updated?

 

I've just installed Intel x520 card and cannot ping its IP address despite the link being up.

 

Many thanks.

Share this post


Link to post
Share on other sites

I just installed an Intel x540-T2 and after assigning manual IP addresses (separate networks for each port going to two different computers) I have the same issue. Link is up and recognized as 10G but no communication is happening. I don't know the first thing about editing or compiling kernel stuff. Is there anything I can do?

 

6.0.2-8451 update 8. Bare metal.

 

Edit: damn it I'm the FNG replying to a solved thread.

Share this post


Link to post
Share on other sites