amir

N54L - Power off from buttom on DSM 6.0

Recommended Posts

Hi, I successfully upgraded my N54L last night from DSM 5.2 to DSM 6.02 Update 5.

The upgrade went smooth and without problems... the only thing is, that the power button

scripts stopped working...again, as always after an upgrade.

 

Normally I would copy the files via WinSCP but since DSM 6 you can't login with root.

Unfortunately you can't sudo with WinSCP...

 

OK for short ... has anyone gotten power button back to work?

If yes, what files were you using? There are different "tutorials" here:

1) viewtopic.php?f=2&t=889&p=77528&hilit=power+button#p77528

2) viewtopic.php?f=2&t=20216&start=610#p75390

Share this post


Link to post
Share on other sites

It works for me on Gen8 and Gen7 N40L so there should be no reason for it not to work on your machine that I know of.

 

This is a bit old but may be of some use viewtopic.php?f=2&t=20216&start=420#p74492 things have changed since then, but I haven't tried the new loader so I can't tell you what to expect. I'm not sure if Arcao's power button fix is included in the current release or not?

Share this post


Link to post
Share on other sites

Normally I would copy the files via WinSCP but since DSM 6 you can't login with root.

Unfortunately you can't sudo with WinSCP...

With DSM 6.x you need to login via SSH as admin and sudo as needed.

Share this post


Link to post
Share on other sites

I've just set this up on a friends clean baremetal install on a gen8 but it should be the same for gen7's.

 

You need Arcao's power button package here > viewtopic.php?f=2&p=75406#p75404

 

Then you need to ssh/winSCP on to your box and copy the files into the appropriate folders and set scripts to executable.

 

You can extract the package in the root or do each upload individually. The later maybe a little slower but the chances of an error is reduced...plus you get to understand more about what's going on.

 

I didn't upload the files in etc/acpi from the package as they were present. I tested without including them and it worked fine.

 

Reboot and test the power button shutdown - job done.

 

Edit: For anyone reading this after installing on an HP gen7/8 the following maybe on your check list:

WOL works otb. Just make sure you use the mac address defined in the grub.

PowerSave Governor works otb. Defaults is "powersave".

Share this post


Link to post
Share on other sites