Jump to content
XPEnology Community

Automated RedPill Loader (ARPL)


fbelavenuto

Recommended Posts

Anyone know how i can remove these 2 drives??

 

I have tried everything. The board is an Asus Z9PA-U8.

 

I have disabled everything i can possibly disable in the bios, i have set max disks to 12 in the synoinfo.conf but these 2 drives still come up every reboot.

 

I have an identical box with the same board drives etc running on the same bios and these drives do not appear.

 

Thanks in advance.

 

image.thumb.png.9c19f0d9b966809730ca6b28c9e060e0.png

Link to comment
Share on other sites

14 hours ago, Orphée said:

The files provided in the flat archive work as is.

There is absolutly nothing to convert.

You put the 2 files from it in your datastore and voilà.

 

I have tried the 2 files in the flat archive without a convert. Esxi just fails to read them as valid files. it reads no size and im unable to save the config until i remove the hard disk.

Its ESXI 8.0 running on a R720XD and i have the virtual machine setup as a linux 5.0 64bit.

 

image.png.00b66c2ba978da3c0cb8e56315beb97d.png image.thumb.png.903d68223359668a5034a839fa675e18.png

Edited by Andy Miller
Link to comment
Share on other sites

On 11/17/2022 at 1:11 PM, fbelavenuto said:

 

Sorry @fbelavenuto ! I didn't mean to quote you but i now have DIRE question!!! And  i cannot find a reply to this mans below post in this thread!!!!

 

I have same problem as this guy in below image, what is fix for all USB showing up as INTERNAL??? I need EXTERNAL USB like right away PLEASE!

 

image.thumb.png.cd987cab6121fea5643e9ddb75e71dca.png

 

Link to comment
Share on other sites

Is it possible to get working network adapter Mellanox MCX4121A-ACAT on ARPL v1.0-beta3 ?

Here is lspci -vv output from xpenology ssh:

0000:65:00.0 Class 0200: Device 15b3:1015
	Subsystem: Device 15b3:0003
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 42
	Region 0: Memory at 38bffe000000 (64-bit, prefetchable) [size=32M]
	Expansion ROM at e0e00000 [disabled] [size=1M]
	Capabilities: <access denied>

0000:65:00.1 Class 0200: Device 15b3:1015
	Subsystem: Device 15b3:0003
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin B routed to IRQ 42
	Region 0: Memory at 38bffc000000 (64-bit, prefetchable) [size=32M]
	Expansion ROM at e0d00000 [disabled] [size=1M]
	Capabilities: <access denied>

 

 

here is lspci -vv output from arpl ssh: 

65:00.0 Ethernet controller: Mellanox Technologies MT27710 Family [ConnectX-4 Lx]
	Subsystem: Mellanox Technologies Stand-up ConnectX-4 Lx EN, 25GbE dual-port SFP28, PCIe3.0 x8, MCX4121A-ACAT
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 25
	NUMA node: 0
	Region 0: Memory at 38bffe000000 (64-bit, prefetchable) [size=32M]
	Expansion ROM at e0e00000 [disabled] [size=1M]
	Capabilities: [60] Express (v2) Endpoint, MSI 00
		DevCap:	MaxPayload 512 bytes, PhantFunc 0, Latency L0s unlimited, L1 unlimited
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset+ SlotPowerLimit 25.000W
		DevCtl:	CorrErr- NonFatalErr- FatalErr+ UnsupReq-
			RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+ FLReset-
			MaxPayload 256 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 8GT/s, Width x8, ASPM L1, Exit Latency L1 <4us
			ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp+
		LnkCtl:	ASPM Disabled; RCB 64 bytes, Disabled- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 8GT/s (ok), Width x8 (ok)
			TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Range ABC, TimeoutDis+ NROPrPrP- LTR-
			 10BitTagComp- 10BitTagReq- OBFF Not Supported, ExtFmt- EETLPPrefix-
			 EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
			 FRS- TPHComp- ExtTPHComp-
			 AtomicOpsCap: 32bit- 64bit- 128bitCAS-
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR- OBFF Disabled,
			 AtomicOpsCtl: ReqEn-
		LnkCap2: Supported Link Speeds: 2.5-8GT/s, Crosslink- Retimer- 2Retimers- DRS-
		LnkCtl2: Target Link Speed: 8GT/s, EnterCompliance- SpeedDis-
			 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
			 Compliance De-emphasis: -6dB
		LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete+ EqualizationPhase1+
			 EqualizationPhase2+ EqualizationPhase3+ LinkEqualizationRequest-
			 Retimer- 2Retimers- CrosslinkRes: unsupported
	Capabilities: [48] Vital Product Data
		Product Name: CX4121A - ConnectX-4 LX SFP28
		Read-only fields:
			[PN] Part number: MCX4121A-ACAT        
			[EC] Engineering changes: AV
			[SN] Serial number: MT2221K13592            
			[V0] Vendor specific: PCIeGen3 x8        
			[RV] Reserved: checksum good, 0 byte(s) reserved
		End
	Capabilities: [9c] MSI-X: Enable- Count=64 Masked-
		Vector table: BAR=0 offset=00002000
		PBA: BAR=0 offset=00003000
	Capabilities: [c0] Vendor Specific Information: Len=18 <?>
	Capabilities: [40] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold+)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [100 v1] Advanced Error Reporting
		UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
		UESvrt:	DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
		CESta:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
		CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
		AERCap:	First Error Pointer: 04, ECRCGenCap+ ECRCGenEn- ECRCChkCap+ ECRCChkEn-
			MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
		HeaderLog: 00000000 00000000 00000000 00000000
	Capabilities: [150 v1] Alternative Routing-ID Interpretation (ARI)
		ARICap:	MFVC- ACS-, Next Function: 1
		ARICtl:	MFVC- ACS-, Function Group: 0
	Capabilities: [180 v1] Single Root I/O Virtualization (SR-IOV)
		IOVCap:	Migration-, Interrupt Message Number: 000
		IOVCtl:	Enable- Migration- Interrupt- MSE- ARIHierarchy-
		IOVSta:	Migration-
		Initial VFs: 8, Total VFs: 8, Number of VFs: 0, Function Dependency Link: 00
		VF offset: 2, stride: 1, Device ID: 1016
		Supported Page Size: 000007ff, System Page Size: 00000001
		Region 0: Memory at 0000000000000000 (64-bit, prefetchable)
		VF Migration: offset: 00000000, BIR: 0
	Capabilities: [1c0 v1] Secondary PCI Express
		LnkCtl3: LnkEquIntrruptEn- PerformEqu-
		LaneErrStat: 0
	Capabilities: [230 v1] Access Control Services
		ACSCap:	SrcValid- TransBlk- ReqRedir- CmpltRedir- UpstreamFwd- EgressCtrl- DirectTrans-
		ACSCtl:	SrcValid- TransBlk- ReqRedir- CmpltRedir- UpstreamFwd- EgressCtrl- DirectTrans-

65:00.1 Ethernet controller: Mellanox Technologies MT27710 Family [ConnectX-4 Lx]
	Subsystem: Mellanox Technologies Stand-up ConnectX-4 Lx EN, 25GbE dual-port SFP28, PCIe3.0 x8, MCX4121A-ACAT
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin B routed to IRQ 25
	NUMA node: 0
	Region 0: Memory at 38bffc000000 (64-bit, prefetchable) [size=32M]
	Expansion ROM at e0d00000 [disabled] [size=1M]
	Capabilities: [60] Express (v2) Endpoint, MSI 00
		DevCap:	MaxPayload 512 bytes, PhantFunc 0, Latency L0s unlimited, L1 unlimited
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset+ SlotPowerLimit 25.000W
		DevCtl:	CorrErr- NonFatalErr- FatalErr+ UnsupReq-
			RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+ FLReset-
			MaxPayload 256 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 8GT/s, Width x8, ASPM L1, Exit Latency L1 <4us
			ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp+
		LnkCtl:	ASPM Disabled; RCB 64 bytes, Disabled- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 8GT/s (ok), Width x8 (ok)
			TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Range ABC, TimeoutDis+ NROPrPrP- LTR-
			 10BitTagComp- 10BitTagReq- OBFF Not Supported, ExtFmt- EETLPPrefix-
			 EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
			 FRS- TPHComp- ExtTPHComp-
			 AtomicOpsCap: 32bit- 64bit- 128bitCAS-
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR- OBFF Disabled,
			 AtomicOpsCtl: ReqEn-
		LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete- EqualizationPhase1-
			 EqualizationPhase2- EqualizationPhase3- LinkEqualizationRequest-
			 Retimer- 2Retimers- CrosslinkRes: unsupported
	Capabilities: [48] Vital Product Data
		Product Name: CX4121A - ConnectX-4 LX SFP28
		Read-only fields:
			[PN] Part number: MCX4121A-ACAT        
			[EC] Engineering changes: AV
			[SN] Serial number: MT2221K13592            
			[V0] Vendor specific: PCIeGen3 x8        
			[RV] Reserved: checksum good, 0 byte(s) reserved
		End
	Capabilities: [9c] MSI-X: Enable- Count=64 Masked-
		Vector table: BAR=0 offset=00002000
		PBA: BAR=0 offset=00003000
	Capabilities: [c0] Vendor Specific Information: Len=18 <?>
	Capabilities: [40] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold+)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [100 v1] Advanced Error Reporting
		UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
		UESvrt:	DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
		CESta:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
		CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
		AERCap:	First Error Pointer: 04, ECRCGenCap+ ECRCGenEn- ECRCChkCap+ ECRCChkEn-
			MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
		HeaderLog: 00000000 00000000 00000000 00000000
	Capabilities: [150 v1] Alternative Routing-ID Interpretation (ARI)
		ARICap:	MFVC- ACS-, Next Function: 0
		ARICtl:	MFVC- ACS-, Function Group: 0
	Capabilities: [180 v1] Single Root I/O Virtualization (SR-IOV)
		IOVCap:	Migration-, Interrupt Message Number: 000
		IOVCtl:	Enable- Migration- Interrupt- MSE- ARIHierarchy-
		IOVSta:	Migration-
		Initial VFs: 8, Total VFs: 8, Number of VFs: 0, Function Dependency Link: 01
		VF offset: 9, stride: 1, Device ID: 1016
		Supported Page Size: 000007ff, System Page Size: 00000001
		Region 0: Memory at 0000000000000000 (64-bit, prefetchable)
		VF Migration: offset: 00000000, BIR: 0
	Capabilities: [230 v1] Access Control Services
		ACSCap:	SrcValid- TransBlk- ReqRedir- CmpltRedir- UpstreamFwd- EgressCtrl- DirectTrans-
		ACSCtl:	SrcValid- TransBlk- ReqRedir- CmpltRedir- UpstreamFwd- EgressCtrl- DirectTrans-

 

All mlx4* and mlx5* modules are included

image.png.ec025e77a5e7d57f3ce36787457d3322.png

 

And here is ps -A | grep mlx output from xpenology:

$ ps -A | grep mlx
 7823 ?        00:00:00 mlx4

 

Don't see any 'mlx5' processes. 

 

What should I do to make the adapter work?

Edited by pyramidd
adding 'ps' output
Link to comment
Share on other sites

5 hours ago, Orphée said:

@Andy Miller It works on ESXi 7.0, why do you choose Linux 5.x ? You should know depending on the loader choosen, it will be Linux 3.x or Linux 4.x

But I don't think it really matters for your issue.

 

After many hours looking at it ive determined it just doesnt work on esxi v8. I attempted ARPL and the TCRP and even juns loader. None will let you add that small vmdk as a valid hard disk. And trying to get it to boot from a USB flash drive just causes the system to hang in between reboots.

 

Ill either need to downgrade to v7 or wait for someone with more knowledge than i do of the loader to come up with a fix.

Link to comment
Share on other sites

I have had very quick success with DSM711 via ARPL (while couldn't ever make TCRP work on bare/VM). ARPL flat and dynamic VMDK work same tho i still didn't figure out the difference. Important is drivers are all SATA, especially the first partition. I ran it on PC VirtualBox and QNAP VirtualizationStation.

Performance notes:

On PC I noticed performance degradation more cores I've added. Boot got very slow, looking at \\.\pipe.

CPU performance is the same as full barebone, e.g. openvpn benchmark or openssl benchmark.

Virtual disk performance isn't top notch. PCI4 NVME will hardly beat 10Gbit on 50.000 passmark host, and top up 5Gbit on a 5.000 passmark host. Sad as I don't want to use RawDisk because NVMEs don't have SED, while DSM doesn't have FDE. Maybe ZFS dataset would work faster.

 

 

Link to comment
Share on other sites

On 11/20/2022 at 10:52 AM, smilenkovski said:

@fbelavenuto

I saw on your github that You added i915 addons two days ago. Does that mean that are drivers for enabling hw transcoding on newer gen of cpu's? I have 10th gen i3.

I've getted from this thread: 

I not have an intel 9th or 10th to tests, then please test. The module is only compiled for apollolake and geminilake (10th up) and only apollolake for 9th or less

 

  • Like 3
  • Thanks 1
Link to comment
Share on other sites

On 11/22/2022 at 9:15 PM, Captainfingerbang said:

 

Sorry @fbelavenuto ! I didn't mean to quote you but i now have DIRE question!!! And  i cannot find a reply to this mans below post in this thread!!!!

 

I have same problem as this guy in below image, what is fix for all USB showing up as INTERNAL??? I need EXTERNAL USB like right away PLEASE!

 

image.thumb.png.cd987cab6121fea5643e9ddb75e71dca.png

 

Hi!

Please go to loader, choose "cmdline menu" then choose "Show SATA(s) # ports and drives". Post a screenshot here

  • Like 1
Link to comment
Share on other sites

Hi, ive problem right at the beginning.

I did my flash-disc with command:

192.168.1.150:7681

sudo dd if=/Users/studio/Downloads/arpl.img of=/dev/disk4 bs=512



After initial POST there are only three lines, last says: "Booting...", then flashing cursor and then blank screen, no loader with its IP written on screen. I cannot find that computer in LAN either.

Anyone?

Link to comment
Share on other sites

1 minute ago, saretar said:

Hi, ive problem right at the beginning.

I did my flash-disc with command:

192.168.1.150:7681

sudo dd if=/Users/studio/Downloads/arpl.img of=/dev/disk4 bs=512



After initial POST there are only three lines, last says: "Booting...", then flashing cursor and then blank screen, no loader with its IP written on screen. I cannot find that computer in LAN either.

Anyone?

Please give us even less details on your configuration, it will of course help us to know nothing about your setup, loader, hardware...

  • Like 1
Link to comment
Share on other sites

 

10 minutes ago, Orphée said:

Please give us even less details on your configuration, it will of course help us to know nothing about your setup, loader, hardware...


OMG, you are right ;) Just fought, that this first step is almost specwise free.
Its ryzen 2700x on some b450 with 4x8tb discs, nvme and some small sata ssd, 10gbit NIC and graphic card rx580.
The ARPL loader was download today, its 1.0 beta3

Ive loaded into that system TCRP with choosed ds3622xs+ on newest DSM with almost success. I cannot sleep the system, cause DSM cant turn on WOL on network card. I was suggested to try ARPL, wich i did with no success ;)

Edited by saretar
Link to comment
Share on other sites

9 minutes ago, saretar said:

 


OMG, you are right ;) Just fought, that this first step is almost specwise free.
Its ryzen 2700x on some b450 with 4x8tb discs, nvme and some small sata ssd, 10gbit NIC and graphic card rx580.
The ARPL loader was download today, its 1.0 beta3

Ive loaded into that system TCRP with choosed ds3622xs+ on newest DSM with almost success. I cannot sleep the system, cause DSM cant turn on WOL on network card. I was suggested to try ARPL, wich i did with no success ;)

Your 10gbit NIC is probably not loaded once ARPL reboot to DSM...

Under ARPL give us the result of this command :

 

lspci -kkvq

 

It will maybe help to catch the missing module...

 

But the way, with this hardware, you'd better go for ProxmoxVE/ESXi ...

your nvme won't be available with DS3622xs+, and AMD cpus are quite tricky with DSM...

Link to comment
Share on other sites

1 hour ago, Orphée said:

Your 10gbit NIC is probably not loaded once ARPL reboot to DSM...

Under ARPL give us the result of this command :

 

lspci -kkvq

 

It will maybe help to catch the missing module...

 

But the way, with this hardware, you'd better go for ProxmoxVE/ESXi ...

your nvme won't be available with DS3622xs+, and AMD cpus are quite tricky with DSM...

 Thats the problem, i cannot give you a lspci, cause system didnt boot of that ARPL boot flash.
Its blank screen.
10gbit is secondary, its sfp+, works great on both jun's 6.2 and tcrp 7.1, but i have normal intel 1gbit connection to router as main ethernet so this should work.

Proxmox/esxi is a little bit out of my league. I need real NAS, not server. Its my file nas - turn it on through WOL, do my work through day, let it power down when not needed.
I have 2 NASes with xpenology jun's 6.2 on my attic (server and backup), wanted to upgrade to newer system and hardware, but for now to no avail.

Link to comment
Share on other sites

OK after downgrading from 8 to 7 i finally got arpl running on esxi.

 

I just have one thing where the first storage disk appears as disk 2 not disk 1. i assume as the system disk is disk 1 even though its hidden.

 

Does anyone know how i can make my disks line up?? i have 12x 6tb drives going in and i would like them to line up correctly.

 

Thanks.

 

 

image.png

Link to comment
Share on other sites

19 hours ago, saretar said:

Proxmox/esxi is a little bit out of my league. I need real NAS, not server. Its my file nas - turn it on through WOL, do my work through day, let it power down when not needed.

Ok, but WOL can be done with Proxmox too.

When Proxmox host start, it auto starts the DSM VM.

 

And you can shutdown Proxmox host manually, or planned with some crontab. It will properly shutdown DSM VM guest, then shutdown.

 

Even better with Proxmox, you can have a real Synology SN/MAC and still having WOL working on Proxmox host side.

Correct me if i'm wrong, but you can't have WOL without setting the true hardware MAC address inside Synology on Baremetal. But if you do so, you can't have real SN/MAC address features.

 

Link to comment
Share on other sites

Hi, 

currently running DS920+ with DSM 7.1.1-42962 Update 2 and ARPL 1.0beta3. What is the best way to update loader to beta 4? Via IMG or update.zip?

 

Haven't found much on updating loaders except for fresh install everytime, but seems a lot of work for simple update :)

 

Thanks in advance!

Link to comment
Share on other sites

A question. While I'm running the regular TCRP and not ARPL. I think the question would apply to ARPL also.

 

Any way of changing serial and MAC of my baremetal unit remotely i.e im not physically at the location where the unit is located but i do have GUI and SSH access to it.

Its running the latest stable release of TCRP and DSM 7.1.x.

Like, could i mount the /dev/synoboot  (which looks to be the usb flash drive) via ssh and update a config or grub file etc? THank you.

Edited by alirz1
Link to comment
Share on other sites

Hi all just got myself Rivo PCIe SATA Card, 8 Port with 8 SATA Cable, SATA Controller Expansion Card with Low Profile Bracket, Marvell 9215 Non-Raid, Boot as System Disk, Support 8 SATA 3.0 Devices(SA3014).

tried to add to mainboard but system wont boot when connected is there drivers for this card or have i brought the wrong card many thanks

Link to comment
Share on other sites

48 minutes ago, edy00116 said:

Hello!

 

I'm in alpha version using the image for vmware. What is the best way to update to the beta version?

Is your DSM up-to-date ?


If so, don't mess with something that currently works, keep it like that until you need to update DSM.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...