Jump to content
XPEnology Community

N40L DSM6.2 with 2.5GBe


Cyber50
 Share

Recommended Posts

I actually bought a DS1512+ while I was taking the N40L offline, originally, I planned to get that at 2.5GBe but it doesn't work.  The N40L does though:

 

N40L

Jun's loader for DS3617xs (6.2-23739)

DSM 6.2-23739 from Synology Website

R8152 2.15.0 Broadwell Drivers

Silverstone ECU03 USB Card - sadly PCI-E Gen2.0 x2, I need a x1 so then I can try some faster RAID cards too

Sabrent USB 2.5GBe ethernet adapter

 

With a single 250GB SSD installed, I can read from the N40L at average 282MBytes/s, at this moment in time (just got it running) the write speed averages to 65MBytes/s.  So I am losing 1/3 in write speed for 2.5x the read speed.  More testing to come

Link to comment
Share on other sites

So took a chance and migrated from DSM5.2 to the 6.2 (above).  That went just fine.

The system has 6x 4TB drives: writing to N40L averaged 175 MBytes/s and reading 253 MBytes/s - single 60GB ISO file (see images)

For a $50 (AUD) adapter that's a nice upgrade

Write, N40L, 6x4TB.JPG

Read, N40L, 6x4TB.JPG

Link to comment
Share on other sites

So long term stability might be an issue, needs investigating (1GBe vs 2.5GBe over several hours).  I have ordered a PCI-E 2.5GBe (RTL8125B) card, see how that goes.  If all good I could then try the Adaptec 6805t, P410 and/or LSI 9260.  Perhaps the write speed will increase.

Ideal outcome is stability with 2.5GBe and USB3 support, if that comes off I'll sell the DS1512+

Edited by Cyber50
Link to comment
Share on other sites

  • 4 weeks later...

So the system was up and remained stable for over 20 days, this was with only the 1GBe LAN plugged in - the 2.5GBe still showed as available though.  I created the auto task as per instructions online to get the USB 2.5GBe working after boot, worked fine when I ran script after booting and on 1GBe.  It did NOT work when booting with only 2.5GBe connected to LAN.  As I am running a PCI USB3 card, I thought maybe the script ran too early - trying to enable the 2.5GBe before the UBS3 card is even loaded.  As such, I set a delay in the script, now works.

 

sleep 1m
ifconfig eth3 up
synonet –dhcp eth3

 

Please note I am eth3 as I also have a dual 1GBe adapter installed, not being used.  It was still working after 24h, only went down as power company works meant I had no power all day today.  So I am thinking, when I booted with 1GBe on the LAN, then enabled the 2.5GBe and unplugged the 1GBe cable - the 2.5GBe then fails after some time.  Is it trying to default back to the LAN it started on?  So now that I have the 2.5GBe from startup all is good.

 

I will see how it goes over the next few days.  The Edimax PCI 2.5GBe has arrived, the chip says RTL8125AG -so fingers crossed it works.  Unfortunately I just sold my spare Microserver and I am hesitant to make changes (for testing) if this USB 2.5GBe stays working

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...