Jump to content
XPEnology Community

Issue: Serial USB > VM (ESXi) DS3622xs + DSM 7.1-42661 [HP MS Gen8]+ Zigbee KEY [Sonoff ZigBee 3.0 USB Dongle Plus ]


Recommended Posts

hi all,

I have a system as follows:
1) Xeon 4core / 8th
2) 16gb ram PC12800e
3) Bootloader DS3622xs + Redpill TinyCore
4) DSM 7.1-42661 

Based on: Proliant MS Gen8


I can't get DSM to recognize the usb dongle. I tried to:

Sonoff Zigbee 3.0 usb dongle plus


1) install the drivers from the store: SynoKernel USB Serial drivers, but the key is detected with "lsusb" but not identified as ttyU * or ttyS *


2) start the commands:

/sbin/modprobe usbserial

/sbin/modprobe ftdi_sio

/sbin/modprobe cdc-acm chmod 777 / dev / ttyUSB0 chmod 777 / dev / ttyACM0

but that didn't work


3)I wanted to try this method: https://mariushosting.com/synology-how-to-add-usb-support-on-dsm-7/ but i can't download the ftiver compiled for architecture: broadwellnk but the site: www.jadahl.com has been offline for some time. could someone pass me drivers? link



or tell me how it solved? thank you


Link to comment
Share on other sites

  • 2 months later...


I close the topic as solved. I solved by manually installing the drivers for broadwellnk architecture [DSM 7.1]:



Admin@G-Server:~$ lsusb
|__usb1          1d6b:0002:0404 09  2.00  480MBit/s 0mA 1IF  (ehci_hcd 0000:02:01.0) hub
|__usb2          1d6b:0002:0404 09  2.00  480MBit/s 0mA 1IF  (Linux 4.4.180+ xhci-hcd xHCI Host Controller 0000:0b:00.0) hub
  |__2-1         10c4:ea60:0100 00  2.00   12MBit/s 100mA 1IF  (ITead Sonoff Zigbee 3.0 USB Dongle Plus c02fdef00160ec11843c345f25bfaa52)
|__usb3          1d6b:0003:0404 09  3.00 5000MBit/s 0mA 1IF  (Linux 4.4.180+ xhci-hcd xHCI Host Controller 0000:0b:00.0) hub

Admin@G-Server:~$ ls /dev/ttyU*

The dongleUSB is correctly recognized as ttyUSB0 and used in a Zigbee2Mqtt container


Link to comment
Share on other sites

Glad it works, but in my opinion, if you are already running DSM under ESXi VM, you should consider a dedicated VM for your domotics


It will be safer, and no outage when you have to manage/update Synology/DSM


I did the same as you, then I created a dedicated VM, and finally I choosed to run it on a raspberry pi with low power consumption behind a UPS battery.

As the rasberry pi is really low power, even a little UPS battery will last at least 1h30/2h ...

Depending on your needs (alarm system ?) It would be a wiser choice.

Link to comment
Share on other sites

  • 11 months later...

Hi @Gianvito, how do you manage to install the driver ? You just copy the ko file to /lib/modules and reboot ?

I have the same problem (i suppose) because i didn't see anything in lsusb


SO perhaps not the same problem after all. But if I insert a usb key, i can see it.

But not the dongle.

Thanks a lot

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...