Sign in to follow this  
Inx192

Volume status - Crashed

Recommended Posts

Can anyone possibly help me with my problem.

 

My server was working fine yesterday morning and while I was copying photos across the network to store on the server, it popped up a message saying that my volume has crashedimage.jpg.

It states that four drives have crashes and that I have to remove the volume image.jpg.

 

When I look at the disk group it only shows two drives that have crashed but says four have crashed, also sometimes after a reboot it states only three have crashed image.jpg.

 

I can still access the data on the server but when copying my photos across to a laptop it says i don't have permission for some of them.

I am running in SHR with two drives fault tolerance.

 

I just don't have enough spare drives to backup everything, is there anyway to fix this without losing any data?

Share this post


Link to post
Share on other sites

Backup your data before removing the volume. You NEED to get as much data out of those drives ASAP. There is no tweaking that will help.

If needed use ssh as root to copy everything out of those drive before it's too late. When done you can try to rebuild the volume and check what the real problem is. Most probably the drives have defective sectors.

Share this post


Link to post
Share on other sites

Backing up that amount for me is not possible but I have the non replaceable items but the rest will be a right ball ache to replace.

I am completely puzzled as to what caused this to happen, the drives all show as healthy but at any one time between 3 & 5 drives show as crashed.

Could you possibly explain what might have caused this to happen because at present even with redundancy I cannot see how I can stop this from happening again in the future?

Share this post


Link to post
Share on other sites
Backing up that amount for me is not possible but I have the non replaceable items but the rest will be a right ball ache to replace.

I am completely puzzled as to what caused this to happen, the drives all show as healthy but at any one time between 3 & 5 drives show as crashed.

Could you possibly explain what might have caused this to happen because at present even with redundancy I cannot see how I can stop this from happening again in the future?

 

Could be anything really. File system corruption, failed disk... who knows. I found this. It might help >>> https://forum.synology.com/enu/viewtopic.php?t=102148

Share this post


Link to post
Share on other sites

Update:

I have partially backed my server up and today most my stuff started disappearing so I thought it best to remove the volume and start again. At only about 0.2% of rebuilding a new volume, drives started crashing (notification also says 'I/O error occurred to hard disk 1 on Server1').

Is there a way to see what is causing this?

The drives are all showing as healthy, could it be hardware related or even my Xpenology build?

Share this post


Link to post
Share on other sites
Sign in to follow this