Dadudeondacouch

HP N54L Microserver - Getting Everything Working

Recommended Posts

 

...

Removed the USB stick and rebooted the server and went into BIOS.

Configured the BIOS according to this:

 

From the main screen go to ‘Chipset > Southbridge Configuration > SB SATA Configuration’ and make sure your settings are the same as below:

OnChip SATA Channel = Enabled

SATA PORTS 4/5 IDE mode = Disabled

SATA EPS on all PORT = Enabled

SATA Power on all PORT = Enabled

Return to the main screen then go to ‘Advanced > IDE Configuration’ and again, make sure your settings are the same as below.

Embedded SATA Link Rate = 3.0Gbps MAX

 

Zarocq: How did you manage to not have your bios settings being reseted upon reboot?

Share this post


Link to post
Share on other sites

Zarocq: How did you manage to not have your bios settings being reseted upon reboot?

 

I haven't done anything to prevent it. I didn't know it was a problem. :?:

Share this post


Link to post
Share on other sites

Zarocq: How did you manage to not have your bios settings being reseted upon reboot?

 

I haven't done anything to prevent it. I didn't know it was a problem. :?:

 

 

Just reboot and check your bios and ... *boom*

Share this post


Link to post
Share on other sites

I have rebooted my N54L several times after installing XPEnology - even had a powerbreak while copying files to it.

I have had it shut down complete.

Until now I haven't lost the configuration in BIOS.

 

Last night a friend and I installed his N54L with XPEnology. Using TheBay BIOS. The same - rebooted several times, power off/on. No problems with a reset BIOS.

Share this post


Link to post
Share on other sites

Pretty sure thats to do with different board revisions or something, if the board has dual bios and the first gets corrupted it uses the 2nd bios to boot and repairs the first, if the board has a single bios then it corrupts and goes to default settings. I've never had an issue with it on mine (not very old).

Share this post


Link to post
Share on other sites

mine gets reseted to default values (and others viewtopic.php?f=2&t=1373&p=6626&hilit=bios+reset#p6626) - no fixes so far...

 

Edit: Just read viewtopic.php?f=2&t=1082&p=6459&hilit=bios+reset#p6459

 

"Could you look at one old problem in Xpenology - BIOS goes to reset state

(there are several reports for different hardware configurations) when power-off shedule is enabled?"

 

I have scheduled power-off, what about you?

Share this post


Link to post
Share on other sites

I have scheduled power-off, what about you?

I have no power-off schedule and I'm not using wake on lan as my unit is powered on 24/7.

Share this post


Link to post
Share on other sites

Hi,

 

I have a proliant 54L with xpenology, everything works fine except one thing:

i want to stream a TNT with a usb key, i have a 835 compatible key and it works not so well : i got some freeze with the stream and if i record.

I tested the usb key directly with windows and another usb key and no problem.

Someone got the same problem ?

Share this post


Link to post
Share on other sites
can anyone help with a strange issue with my 4-2 3211 build on my N54L my internal network card is showing as only 10/100 how do to make it 10/100/1000?

http://i.imgur.com/mtPIWH8.png

 

Does your router support Gigabit? I used my N54L with a 100Mbit router before and that caused such limitations.

It appears even when you use an incorrect networkcabel, use min. Cat5e

Share this post


Link to post
Share on other sites
can anyone help with a strange issue with my 4-2 3211 build on my N54L my internal network card is showing as only 10/100 how do to make it 10/100/1000?

http://i.imgur.com/mtPIWH8.png

 

Does your router support Gigabit? I used my N54L with a 100Mbit router before and that caused such limitations.

It appears even when you use an incorrect networkcabel, use min. Cat5e

 

Correct,

 

I tried everything with mine.... tried 2 different cables, 4 different ports on patch panel

 

Skipped the patch panel, and used a 3rd cable direct from N40L to switch........

 

BOOM 1000, Full Duplex, MTU 1500 :roll:

 

Guess I better check my patch panel cabling job........as somethings dicky with it :oops:

 

.

Share this post


Link to post
Share on other sites

Great info here. Thanks everyone.

 

I have a N54L running trantor's 4.3 now. Just wanted to edit the vender file with the real MAC address but got stuck. How did you guys find out the physical MAC address? Do I need a monitor attached to the N54L and get into the BIOS? Any info is welcome!

 

 

====

Update:

 

Real address can be found by doing:

 

dmesg | grep "eth"

 

from a terminal

Edited by Guest

Share this post


Link to post
Share on other sites

Has anyone managed to find a fix for the issue with the bios getting reset for the N54L yet?

Share this post


Link to post
Share on other sites
Disable scheduled power-off and WOL. :wink:

I have no problems with the BIOS - but I don't use WOL or scheduled power-off.

I use both WOL and scheduled power off/on and have no problems with restart, shutdown nor with BIOS resets.

Share this post


Link to post
Share on other sites
Are you using a modified bios? and if so which one?

I user before bays(?) BIOS 41 and it worked, recently I have updated to the latest one from German site and it still works.

Share this post


Link to post
Share on other sites
Are you using a modified bios? and if so which one?

I user before bays(?) BIOS 41 and it worked, recently I have updated to the latest one from German site and it still works.

 

Do you perform any bios setting modifications? (virtual ram size to 32, sata mode to 3.0gb/s or etc.)

Even with default bios settings xpenology works fine!

Bios reset is annoying thing by itself.

Share this post


Link to post
Share on other sites

Video memory to minimum, SATA mode to auto or 3GB ( the same result), other settings as recommended on forums for modified BIOS. I don't use disks 5 and 6, so either settings for me are not a necessity, but rather curiosity. It all worked as expected in very predictable manner.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.