colrojo

Actualizar hardware hp prolliant microserver

Recommended Posts

Debido a que parece que mucha gente tiene problemas con el WoL y con las actualizaciones del hardware de este tipo de equipos. He decidido hacer este pequeño tutorial.

 

Para actualizar el hardware de estos equipos tenemos varias opciones.

 

La más obvia sería pincharle un cd. Descargar el último spp. Que son 7 gigas. Quemarlo en un disco y arrancar desde hay.

También se puede quemar en un pendrive y arrancar desde hay.

 

O también se puede montar el iso por iLO y arrancar desde hay.

 

Opciones de arranque F11 durante el POST.

 

El fichero:

https://h20566.www2.hpe.com/hpsc/swd/pu ... a9451c4ab9

 

Después de aceptar el eula. De las 3 opciones que da es la de la izquierda.

Le decimos que haga el inventario y luego que remedie.

 

Como seguramente no tendréis cuenta para poder descargar el iso... La cosa se complica:

Cuando hp era hp y no hpe el ftp solia esta abierto:

ftp://ftp.hp.com

Por hay podemos navegar y buscar...

O podemos averiguar el nombre del fichero y buscarlo para descarga por la red.

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Editado:

Acabo de ver que el soporte a los g7 es una Braga y solo están los firms en el spp o para rh5.

Habría que montar un livecd de redhat 5 (o instalárselo en un disco temporal) y cargar los ficheros que pone firmware del siguiente enlace. Menos la BIOS que como pone va en un pen.

http://h20564.www2.hpe.com/hpsc/swd/pub ... nvOid=4004

 

Hay otra opción pero la contaré más adelante...

_-----_------_--_-------

 

Si ninguna de las opciones del primer post te es posible y tienes un g8 entonces hay que hacerlo manualmente.

Antes de nada hay que explicar que es la iLO:

(Se puede googlear)

La iLO es una interface que permite gestionar equipos remotos como si estuvieran delante. Es decir. Por red simulan teclado, ratón y pantalla. También puedes simular cd y montar isos.

Utiliza el protocolo BMC (también se puede googlear) que es estándar y esta en todos los servidores profesionales.

 

Como se accede:

Los hp traen un cartoncillo con un cordel o últimamente un plástico negro donde viene el número de serie y la contraseña de la iLO.(el usuario es administrator)

¿Que hago si no lo encuentro?

Tranquilo. Enchufamos un teclado y Un monitor. Y arrancamos el equipó. Durante la secuencia de arranque y entre todas las frases que va poniendo en pantalla. Pondra. Ilo x estándar Press f8 to configure..

Aquí Pego un tutorial. (Es de ilo1 pero para ilustrarnos sirve) lo que tenemos que hacer es crear un usuario con permiso de administrador. Y si nos sentimos con fuerzas una dirección IP estática.

http://systemadmin.es/2009/12/configura ... la-ilo-hp#

 

Una vez que tenemos el usuario y la contraseña. Le conectamos un cable de red de la toma que tiene atrás rotulada como iLO. Lo enchufamos a nuestra red y desde otro ordenador. Con el Chrome o el que sea ponemos https://laipdenuestrailo

Nos dirá que el certificado no es bueno. Lo obviamos y nos logamos.

Después de dar una vuelta por todas las opciones y ver lo que se puede hacer vemos . En administración creo recordar, una pestaña que pone firmware update.

Vamos a actualizarlo:

Primero hay que ver que versión tenemos. Porque si es anterior a la 2.20 yo recomiendo hacer un salto intermedio en ella.

Ilo4 (gen8+) 2.50

http://h20564.www2.hpe.com/hpsc/swd/pub ... b5a86b3c86

 

Debajo del botón verde de descargar. Donde pone historial de versiones. Tenemos los enlaces a los números de versión anteriores.

 

El sistema operativo da igual. Porque el ejecutable que se descarga esta comprimido. Y lo que hay que hacer es descomprimirlo con WinRAR o izarc o ...

Y solo nos interesa el fichero *.Bin

 

Como decía. En la iLO . Management. firmware update. Hay un botón en todo el centro donde navegando le ponemos la ruta al fichero *.bin y pulsamos en update.

Después de un rato y si no falla el "upload" lo graba y cuando acaba nos hecha durante un minuto. Mientras se resetea. Puede ser que al volver a logarnos no responda o nisiquiera nos de la opción. Se arregla quitando completamente la corriente y volviéndola a poner. También puede ser que falle el upload del fichero. En ese caso usar Firefox. También puede ser que no haya hecho nada. Repetir.

 

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Una vez que tenemos la iLO actualizada. Si es un g8 podemos hacer el mismo procedimiento para la BIOS. Descargar descomprimir subir el binario.

Pero nos dejaría sin actualizar la controladora de disco, las tarjetas de red y demás.

 

Así que la opción más viable sigue siendo montarse un livecd. Incluirle los ficheros de hp y lanzarlos. En este caso vale rh o Windows

http://h20564.www2.hpe.com/hpsc/swd/pub ... nvOid=4103

 

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Hay una opción bastante buena y que vale tanto para g7 como para g8:

 

Descargamos los firmwares de g7 o de g8 para redhat 5.

Buscamos a descarga por la web algún spp de 2011 o 2012. (Los hay)

Editamos el iso. Borramos casi todos los parches (los *.scexe) ponemos los descargados.

Arrancamos con el iso y cuando salte el eula marcamos el aceptar y pulsamos: ctrl+alt+d soltamos ctrl+alt+b soltamos ctrl+alt+x

descenderá una Shell.

Navegamos a donde pusimos los ficheros descargados y uno a uno vamos escribiendo "sh ./fichero.scexe

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Edited by Guest

Share this post


Link to post
Share on other sites

 

Qué es? he intentado entrar pero el enlace ya no vale, dice que ha superado el límite de intentos.

 

Yo me he registrado en HP y he registrado el numero de mi servidor para adjuntar la garantía del aparato a mi cuenta.

Después me ha dejado bajarme la iso del "Service Pack for ProLiant 2016.10.0"

 

He arrancado esa ISO desde la unidad virtual de la iLO y he mandado actualización automática el caso es que sólo aprecio que ha actualizado la iLO, el resto no veo que haya cambiado de versión, pero el firmware de las tarjetas de red no se verlo solo veo lo que muestra la iLO en la sección "Information > System Information > Firmware" y allí sólo veo que cambie la iLO a la 2.50 lo demás está igual que antes de actualizar.

 

Como el proceso lo he hecho desde la iLO y dicen que si lo haces desde ahí uses el método automático, pues no se lo que ha actualizado a parte de la iLO.

 

Despues del proceso el WOL me sigue sin funcionar correctamente, he abierto un hilo en el foro de hp a ver si dicen algo: https://community.hpe.com/t5/ProLiant-S ... -p/6919064

Share this post


Link to post
Share on other sites

La versión de la red la ves en system information network, los discos en storage. Etc ..

 

Vuelve a lanzarlo pero el proceso manual. El report previo a instalar te dice lo que detecta. Que versión tienes y si tiene actualización.

De todas formas en el spp hay lo mismo que en la pág de descarga uno a uno para rh. Y si no lo hay... El spp es un livecd de rh. Lo del eula y la Shell sigue valiendote

 

Si el WoL te sigue matando. Puedes crearle un usuario de iLO con permiso para encender. Y lo que harías sería conectarle a la iLO por ssh y darle un poweron.

Se puede hacer desde el móvil. Con juicessh y desde cualquier Windows mediante un putty o te puedes hacer un mini script de powershell con el cmdlet de hpilo.

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Me he bajado el SP 2016.10.0 desde la web de HPE, (previamente habia obtenido user y pass).

 

De todas las opciones que comentais, la que me parece mas facil, es montar la iso en un pen con el win32diskimager, y arrancar desde allí para que se actualice solo (ya me arranca habitualmente desde el usb para el loader).

 

¿Es asi de facil o debo tener algo mas en cuenta?

Share this post


Link to post
Share on other sites
Me he bajado el SP 2016.10.0 desde la web de HPE, (previamente habia obtenido user y pass).

 

De todas las opciones que comentais, la que me parece mas facil, es montar la iso en un pen con el win32diskimager, y arrancar desde allí para que se actualice solo (ya me arranca habitualmente desde el usb para el loader).

 

¿Es asi de facil o debo tener algo mas en cuenta?

Pones el archivo *.ISO en el Pen. (Ni win32 ni nada). El ISO a pelo

Lo pinchas. Le dices a la iLO que lo monte y que arranque desde ahí.

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

No veo la opcion de montar la iso el ILO (mi licencia es estandar, no se si influye)

 

He mirado en virtual media y me dice lo de la licencia....

Share this post


Link to post
Share on other sites

Open remote console.

Y desde la consola montas el ISO . Sin Pen. te pide una ruta

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Hecho, pero tuve que activar la licencia del ILO advanced en modo demo por 60 dias, ya que la consola para montar la iso se me cerraba al poco de abrirla.

 

Lo que he hecho:

- Montar la iso con la consola del ILO.

- Poner como primer medio de arranque la red (en ILO).

- Reiniciar sin el usb con el loader.

- Dejar que la iso se cargue y actualice todo lo que quiera en automático. (La verdad, salvo la versión del ILO, no detecto mas cambios).

- Cuando, termina, cambiar la secuencia de arranque, pero sin poner el usb.

- Reiniciar y comprobar que el chequeo es correcto, y cuando llega al final, apagar.

- Ahora ya, con el usb loader puesto, y la secuencia correcta de arranque, dejar que arranque normalmente.

 

Todo funciona bien. ¿Hay que hacer algo mas? La bios es antigua y no la ha actualizado, pero al encontrar el fichero de la bios en la pagina de HP, que no es una muestra de claridad precisamente, aparece con un candado y no me deja descargarla....

Share this post


Link to post
Share on other sites
Hecho, pero tuve que activar la licencia del ILO advanced en modo demo por 60 dias, ya que la consola para montar la iso se me cerraba al poco de abrirla.

 

Lo que he hecho:

- Montar la iso con la consola del ILO.

- Poner como primer medio de arranque la red (en ILO).

- Reiniciar sin el usb con el loader.

- Dejar que la iso se cargue y actualice todo lo que quiera en automático. (La verdad, salvo la versión del ILO, no detecto mas cambios).

- Cuando, termina, cambiar la secuencia de arranque, pero sin poner el usb.

- Reiniciar y comprobar que el chequeo es correcto, y cuando llega al final, apagar.

- Ahora ya, con el usb loader puesto, y la secuencia correcta de arranque, dejar que arranque normalmente.

 

Todo funciona bien. ¿Hay que hacer algo mas? La bios es antigua y no la ha actualizado, pero al encontrar el fichero de la bios en la pagina de HP, que no es una muestra de claridad precisamente, aparece con un candado y no me deja descargarla....

La última BIOS es 2015.11.05

Si no es la que tienes y la necesitas.

Las mismas credenciales que para el spp.

La descomprimes y el .Bin se lo cargas por iLO.

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites
Hecho, pero tuve que activar la licencia del ILO advanced en modo demo por 60 dias, ya que la consola para montar la iso se me cerraba al poco de abrirla.

 

Lo que he hecho:

- Montar la iso con la consola del ILO.

- Poner como primer medio de arranque la red (en ILO).

- Reiniciar sin el usb con el loader.

- Dejar que la iso se cargue y actualice todo lo que quiera en automático. (La verdad, salvo la versión del ILO, no detecto mas cambios).

- Cuando, termina, cambiar la secuencia de arranque, pero sin poner el usb.

- Reiniciar y comprobar que el chequeo es correcto, y cuando llega al final, apagar.

- Ahora ya, con el usb loader puesto, y la secuencia correcta de arranque, dejar que arranque normalmente.

 

Todo funciona bien. ¿Hay que hacer algo mas? La bios es antigua y no la ha actualizado, pero al encontrar el fichero de la bios en la pagina de HP, que no es una muestra de claridad precisamente, aparece con un candado y no me deja descargarla....

La última BIOS es 2015.11.05

Si no es la que tienes y la necesitas.

Las mismas credenciales que para el spp.

La descomprimes y el .Bin se lo cargas por iLO.

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

 

Cual es la ultima bios de estas???

 

kUmUhpm.png

 

http://h20564.www2.hpe.com/hpsc/swd/pub ... nvOid=4168

 

A mi me ha llegado asi, con la J06 11/02/2015, no se si hay alguna mas moderna

 

tsydzsW.png

Share this post


Link to post
Share on other sites
Hecho, pero tuve que activar la licencia del ILO advanced en modo demo por 60 dias, ya que la consola para montar la iso se me cerraba al poco de abrirla.

 

Lo que he hecho:

- Montar la iso con la consola del ILO.

- Poner como primer medio de arranque la red (en ILO).

- Reiniciar sin el usb con el loader.

- Dejar que la iso se cargue y actualice todo lo que quiera en automático. (La verdad, salvo la versión del ILO, no detecto mas cambios).

- Cuando, termina, cambiar la secuencia de arranque, pero sin poner el usb.

- Reiniciar y comprobar que el chequeo es correcto, y cuando llega al final, apagar.

- Ahora ya, con el usb loader puesto, y la secuencia correcta de arranque, dejar que arranque normalmente.

 

Todo funciona bien. ¿Hay que hacer algo mas? La bios es antigua y no la ha actualizado, pero al encontrar el fichero de la bios en la pagina de HP, que no es una muestra de claridad precisamente, aparece con un candado y no me deja descargarla....

La última BIOS es 2015.11.05

Si no es la que tienes y la necesitas.

Las mismas credenciales que para el spp.

La descomprimes y el .Bin se lo cargas por iLO.

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

 

Cual es la ultima bios de estas???

 

kUmUhpm.png

 

http://h20564.www2.hpe.com/hpsc/swd/pub ... nvOid=4168

 

A mi me ha llegado asi, con la J06 11/02/2015, no se si hay alguna mas moderna

 

tsydzsW.png

La que tienes es la última: (system ROM)

 

De las 3 que muestras, que son la misma, una es para flashearla desde un pendrive de arranque y las otras dos son para ejecutarlas desde el SO Windows de 32 y de 64 respectivamente.

 

La letra del final no cuenta. Son revisiones del instalador pero no del binario que se instala

 

Puedes actualizar el inteligent provisioning a la 1.63 que es la última para g8

 

http://h20564.www2.hpe.com/hpsc/swd/pub ... 0b34e#tab2

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Tengo la ultima, J06. Me había liado con las fechas, entre el 2015/11/02 que pone en la bios y el 24-=ct-2016 de la web.

 

Cuando me caduque la licencia del ILO Advanced dentro de dos meses, ¿donde se pueden comprar a precio aceptable? He visto algunas en ebay a 24 Euros, pero no se yo si.....

Share this post


Link to post
Share on other sites

Aquí abajo pongo un enlace a mega con la ISO del nuevo Service Pack for Proliant (SPP) 2016.10.0 (24 de octubre de 2016)

 

Soporte oficial para:

 

Microsoft Windows Server 2016

 

Red Hat Enterprise 6.8

 

VMware vSphere 6.0 U2

 

Support for new options

 

HP Smart Update Manager v7.6.0

 

 

Como actualizar (iLo, USB ó CD): 

 

http://www.pantallazos.es/2016/09/actua ... liant.html

 

 

Enlace con la ISO:

 

https://mega.nz/#!bRZViDBK!tus7_X3B43qX ... gPPbEUg4KI

Share this post


Link to post
Share on other sites
Tengo la ultima, J06. Me había liado con las fechas, entre el 2015/11/02 que pone en la bios y el 24-=ct-2016 de la web.

 

Cuando me caduque la licencia del ILO Advanced dentro de dos meses, ¿donde se pueden comprar a precio aceptable? He visto algunas en ebay a 24 Euros, pero no se yo si.....

Para que usas iLo Advanced?

Share this post


Link to post
Share on other sites

Para que usas iLo Advanced?

 

Consola remota.

Montar isos.

Ilo federation.

Distribución de firmware.

(Estas 2 si solo tienes 1 no sirve de nada)

Agentes HP. (Inútil en debían/synology)

Autenticación kerberos.

Autenticación LDAP.

Certificado ssl.

Monitor de logs (snmp)

Eventos vía smtp......

 

 

Nada demasiado util si es para casa.Quitando los ISO y la consola claro.

 

Mi consejo. Seguro que buscando encuentras un generador de claves. O una clave en algún sitio.

Me parece un robo que tengas que pagar para poder usar una función integrada. ( Los servidores Intel venían sin el chip ni el rj45 y era lo que comprabas si querías usar la iLO/BMC)

 

Enviado desde mi Aquaris X5 Plus mediante Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now