Jump to content
XPEnology Community

N54L WOL?


my4keys82
 Share

Recommended Posts

Hello, I wonder if someone could help me get WOL working on my N54L?

 

I'm using XPEnology DS3612xs DSM 4.2 build 3211++ (repack v1.2) by Trantor.

I'm using the modded bios by TheBay with WOL enabled.

I've done everything I can find on this forum but still not having any success.

 

Vendor file modified with my real MAC address

Grub.conf - commented chksum/vendor/hw_model, added mac1=real mac address as a parameter to kernel image

 

My mac address is showing as the real hardware one and is not changing so all seems well here.

Whenever I try to set WOL enabled under Hardware in DSM it always reports a fail.

I've also tried "ethtool -s eth0 wol g" from terminal but no good.

 

Any help would be appreciated.

Mike.

Link to comment
Share on other sites

Hello, I wonder if someone could help me get WOL working on my N54L?

 

I'm using XPEnology DS3612xs DSM 4.2 build 3211++ (repack v1.2) by Trantor.

I'm using the modded bios by TheBay with WOL enabled.

I've done everything I can find on this forum but still not having any success.

 

Vendor file modified with my real MAC address

Grub.conf - commented chksum/vendor/hw_model, added mac1=real mac address as a parameter to kernel image

 

My mac address is showing as the real hardware one and is not changing so all seems well here.

Whenever I try to set WOL enabled under Hardware in DSM it always reports a fail.

I've also tried "ethtool -s eth0 wol g" from terminal but no good.

 

Any help would be appreciated.

Mike.

 

Hi Mike,

 

Almost the same configuration, and it's working here. I just followed http://xpenology.com/forum/viewtopic.php?f=2&t=665&p=4491&hilit=wol+chinese#p3312

 

Whenever I try to set WOL enabled under Hardware in DSM it always reports a fail, but never mind. It works, anyway.

 

Hope it helps.

Link to comment
Share on other sites

Honestly I don't know (only started doing this stuff 2 days ago) I just slightly modified the original sn in synology assistant by like 1 digit and put it there and it works.

 

literally all I did was install fresh img onto the usb, use ext2fs to modify grub.conf to what you see in the other post and then rebooted. all ok lol

 

can you post you grub.conf here so I can have a look?

Link to comment
Share on other sites

#serial --unit=0 --speed=115200

#terminal serial

default 0

timeout 3

fallback 0

 

title DSM 4.2-3211++ Repack v1.2

root (hd0,0)

#vender /vender show

#hw_model

kernel /zImage root=/dev/md0 ihd_num=0 netif_num=1 syno_hw_version=DS3612xs mac1=38eaa1a01a11

initrd /rd.gz

Link to comment
Share on other sites

and you have tried adding "# cksum /grub_cksum.syno"

between the "root (hd0,0)" and the "#vender /vender show" line? I had an error straight after the grub loader saying the checksum was invalid and it was giving me a random mac every time I booted until I added that.

 

I am currently at work I will give you my exact grub.conf file later when I get home and just change the mac if that doesn't work then one of the other files like vendor etc might have been messed up cause mine is a clean fresh install using the same dsm as you.

Link to comment
Share on other sites

So I've verified that WOL does work using an ubuntu live image so hardware and bios settings must be fine.

I then tried to start again with a new DSM install, still get stuck with the same problem.

I've checked with ethtool to make sure WOL is supported and enabled.

I must be doing something silly, maybe I'm not shutting the machine down in the correct way, how do you shutdown your microserver?

Does your power button shutdown gracefully, mine doesn't seem to do anything.

 

Thanks,

Mike.

Link to comment
Share on other sites

#serial --unit=0 --speed=115200

#terminal serial

default 0

timeout 0

fallback 0

 

title SYNOLOGY1

root (hd0,0)

# cksum /grub_cksum.syno

# vender /vender show

# hw_model

kernel /zImage root=/dev/md0 ihd_num=0 netif_num=1 syno_hw_version=DS3612xs mac1=C8CBB8C53A25 sn=B3J4N00011

initrd /rd.gz

 

that's my exact file and I haven't had to change anything else at all, I shutdown from dsm menu and from schedule and it always works. I have not modified default bios etc in anyway.

 

my guide...

install the bay 41 bios via usb drive

install trantor img to usb drive

modify grub the same as above with mac address from bios

boot n54l and install pat file, shutdown from dsm menu once all done

restart using any wol app

Link to comment
Share on other sites

Setup WOL via synology assistant is greyed out.

Am consistently getting the correct MAC addres reported, same as shown in bios.

 

Hi!

 

after this:

my guide...

install the bay 41 bios via usb drive

install trantor img to usb drive

modify grub the same as above with mac address from bios

boot n54l and install pat file, shutdown from dsm menu once all done

restart using any wol app

 

check that mac do not change at every boot

 

than you should do this:

viewtopic.php?f=2&t=665&p=3463&hilit=synoinfo.conf#p3312

My N36L get perfect WOL with the help from chinese forum:

http://nas1.cn/thread-64278-1-1.html

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file to /usr/syno/etc/rc.d/ and give the file execuable permission?[attachment=0]S99ZZZ_Shutdown.rar[/attachment]

reboot and enjoy

 

check that Setup WOL via synology assistant is black now (CTRL+E)

and ControlPanel/Hardware/WOL_on_LAN1 is enabled

 

shutdown N54L and try to send WOL command!

Link to comment
Share on other sites

Toshas,

 

I've followed these steps before several times. The shutdown script refers to a ddshutdown.sh which does not exist. Are you using Trantor v1.2?

 

Yes I did it yesterday on fresh install.

N40L with TheBay BIOS and Trantor 3211 v1.2 repack.

And yes I have no DSShutdown.sh in /var/packages/shutdown_script/.

Link to comment
Share on other sites

 Share

×
×
  • Create New...