Sign in to follow this  
RainbowShaggy

XPEnology x86 version and few questions

Recommended Posts

Hello everyone,

 

I would like to install XPEnology to my oldest netbook, but for the first I want to try it on Virtual Machine. So I created Virtual Machine on x86 architecture (because the netbook supports only x86 architecture), and then one SATA hard drive disc with 10 GB space. I used NanoBoot-x86-5.0.3.1-fat for the boot and DSM_DS214play_4528. After I booted up the nanoboot and then I inserted IP address to my browser. Then I forwarded port 22 to Virtual Machine. After all that I tried to upload the DSM file, but I've got error 13 and I don't know why. This si my first question.

 

The second question is what is the newest DSM what can I use for x86 architecture and for which device (type like DSxxx) I should use for XPEnology.

 

Thanks for the answers and sorry for my english

Share this post


Link to post
Share on other sites

You need more than 10Gb disk space. Otherwise you get the error 13 message. 20Gb is a safe minimum.

Share this post


Link to post
Share on other sites

Okay thanks for reply. I created VHD drive with 20 GB space and still I've got this error 13. And can I get answer for my second question? Thank you very much

Share this post


Link to post
Share on other sites

Error 13 seems to be "I had some problem writing the installation to disk". 10Gb was probably not big enough.

I did try to run up an old VM which was using Nanoboot but it failed and I have changed so much on my PC and network since then that it would probably take an age to debug.

However, I did notice that the .pat file I was using was for the DS3612xs and that might be your error 13 problem there.

 

As for x86 support, I think nanoboot was the last, but can't really remember. I would have to hunt through the forum for the 5.0 release - but then you could do that :smile:

Share this post


Link to post
Share on other sites

Ah! I hadn't seen that thread before and now I see what you are doing.

I am confused about the steps you have taken and why you are using port 22 at this point.

It should be:

1) Boot nanoboot in the VM

2) from your PC run synology assistant to find the DSM instance.

3) Right click on the instance and select connect to open a browser and start the installation process.

Share this post


Link to post
Share on other sites

Sorry mate.

I'm really confused about what you say about connecting to port 22 and trying to upload the DSM file. Are you trying to use WinSCP to physically upload the file or are you following the installation wizard that appears in the browser when you connect it to the nanoboot machine?

Share this post


Link to post
Share on other sites

That's okay :smile:

 

So. I write to you in steps what I've done:

 

1) I booted up nanoboot in VM

2) Selected the First option

3) I launched Synology Assistant from my PC to find IP address of the instance

4) The Synology Assistant opened automatically my browser with Synology DSM web interface.

5) I opened my router web interface to forward port 22 to IP address of the DSM instance

6) Then I started the installation process

7) Formatting of the drive was done, copy too and when Installation started I've got error 13.

 

I tried option download file from web. Upload DSM file and install dsm from synology assistant. And nothing worked :/

Share this post


Link to post
Share on other sites

Hi,

I'm not sure why you are doing step 5, but that shouldn't affect things.

I have tried to replicate your method but got lost in VMware hell.

All I can say is that error 13 is a problem writing the installation to the disk - not big enough, wrong disk type, wrong controller, can't find it, wrong or bad .pat file but I'm sorry that I can't provide a solution.

Maybe someone with a greater knowledge can help.....

Share this post


Link to post
Share on other sites

I read somewehere, that port 22 have to be forwarded. But who knows.

I think, that 20 GB is enough isn't it? Type what I've tried was VHD and Controller I tried SATA and SCSI. I really don't know where can be mistake.

Änyway thanks for your help :smile:

Share this post


Link to post
Share on other sites

UPDATE:

So I downloaded version DSM_DS214play_4493.pat and now everything worked.

But I have small question. Can I somehow update from interface to newer or newest version?

And when I boot DSM, I need to have inserted Nanoboot usb. Can I somehow boot without nanoboot when is dsm installed?

 

Thank you

Share this post


Link to post
Share on other sites

That's good news.

You need a version of the bootloader that matches the version of DSM you are trying to install. If you have the last x86 loader, then the matching DSM version is the latest you can install safely.

You need nanoboot usb inserted whenever you boot DSM. It takes the place of the ROM bootloader in a real Synology but it allows you to load DSM on non-Synology hardware.

Share this post


Link to post
Share on other sites

Oh I understand :smile:

I'm using the NanoBoot-x86-5.0.3.1-fat.img. So I think there is no way to install newer version right? But I saw somewhere, that they have 4528 version on x86, but how they installed this version?

 

EDIT: I see on this page http://xpenology.pety.me/files/nanoboot/CHANGELOG, that 5.0.3.1 support 4493, so I think, that 5.0.4.1 version of nanoboot for x86 not exist :sad:

Share this post


Link to post
Share on other sites
Sign in to follow this