Sign in to follow this  
relink2013

Mount remote folders so that DSM "thinks" they are local?

Recommended Posts

I recently got xpeno DSM 6 running in ESXi, however considering its potentially unstable nature, and the high cost of 16TB worth of HDDs, I am trying to utilize the power of XPEno running on a quadcore Xeon, but still use the storage of my current Synology DS412+.

 

Is there any way that I can mount the shares from my 412+ on my xpeno install in such a way that DSM "thinks" they are local shares? I especially need the home folders. The whole reason for me installing xpeno was to run the apps like Video Station, Photo Station, etc, on more powerful hardware, while keeping my data safely stored on my original Synology box.

 

On a side note: I have managed to mount a users home folder from one synology, into the homes folder of another one once before, but this seemed to be a fluke, or I had hanged some setting that I didnt realize. I have yet to beable to reproduce this a second time.

Share this post


Link to post
Share on other sites

As a possibly silly suggestion, but rather mounting the folder, try setting up a shared folder sync between the boxes

another thought is to try and mount the individual users home folders from the 412 in the 'root' homes folder of the xpe system

Share this post


Link to post
Share on other sites

I dont think I can do the first suggestion, my 412+ has 10.7TB of space on Volume1, and my xpeno install only has 100GB. However, you second suggestion...how would I go about doing that? could you elaborate? sounds intersting.

Share this post


Link to post
Share on other sites

I think I'm doing something similar to what you want - I mount my volume1 using NFS as my storage is managed by FreeNAS and not Xpenology - I only use Xpenology to take advantage of the software like Photo Station.

 

To get this to work, set up a small volume1 (I have a 3GB one) to act as a dummy. Then SSH in to your xpenology box, and open /etc/rc in vim.

 

Find the line that says "# checking and Mounting filesystem(s) ..."

Comment out the next couple of lines so it looks like:

 

# checking and Mounting filesystem(s) ...

#/usr/syno/bin/synobootseq --set-check-fs >/dev/null 2>&1

#/etc.defaults/rc.volume start

 

(hashes before each line)

 

Then after that add this line:

mount -t nfs YOURIP:YOURPATHTOSTORAGE /volume1

 

Reboot and enjoy, should be good to go. Only noticeable side effect so far is that CloudStation doesn't work, but apart from that everything seems to work just fine!

Share this post


Link to post
Share on other sites

Hi jamie,

 

triying the same http://www.xpenology.com/forum/viewtopic.php?f=2&t=26735&p=86693&hilit=cloudstation#p86608 but the goal is to store the content of the CloudStation folder to a share on a Qnap NAS.

Can you describe what I have to do on Qnap or in your case on the Freenas Machine so that xpenology can connect to the qnap.

How the string mount -t nfs YOURIP:YOURPATHTOSTORAGE /volume1 than really?

is this right?

mount -t nfs 192.168.1.2:/cloudstation /volume1

 

On ubuntu I was able to mount the nsf share to /mnt but on the Diskstation with DSM 5.2-5967 I see allways the error, that volume1 is crashed after reboot.

 

How it looks whit the rights? Where I have to set this correctly and is it possible to test the mount bevor rebooting the system?

 

Is there a solution to get the CloudStation Folder to work, via comandline?

Share this post


Link to post
Share on other sites

So I got it, the xpenology DiskStation volume1 is connectet to my Asustor NAS.

 

As jamie wrote, the CloudStation is not working :roll:, will be great, if we can solve this.

I was able to setup the CloudStation through the Appcenter I can also find the CloudStation through the App on ubuntu but I cant store the settings.

In the android ab I can setup the system completely, but it's not synchronizing the files, I see only the blue circle.

 

Also the whole Filestructure is build on the share, so something is disturbing the syncprocess.

 

What I was trying is to setup a 2en Volume and moved the Database on this Volume, but noch change.

Then I deleted the package and installed it again on volume2, same result.

Maybe it's only a thing whit the rights of the folder or it don't like the nfs file System...

 

Any idea best Theo

Share this post


Link to post
Share on other sites

HI,

 

I did the changes in the /etc/rc.subr, in there I found the specified lines, but after reboot there is no difference. Am I missing something?

I can mount manually the nfs share, so I think the command is correct...

 

Thanks

Share this post


Link to post
Share on other sites
Sign in to follow this