Polanskiman

[Tuto] Installer/Migrer DSM 5.2 à 6.0.2 (Loader Jun)

Recommended Posts

On 7/14/2017 at 0:18 PM, DenisPac said:

 

Bonjour,

 

Personne n'a été dans la même situation que moi pour m'aider ?

 

Merci d'avance

 

Denis

 

 

Bonjour,

 

Je suis dans la même situation N54L avec Esxi 6.0, je suis passer du 6.0 à la version 6.1 en suivant le tuto d'un post dans la section anglaise.

 

Il faut en premier lieu se rendre dans le bios, dans la partie CPU et désactiver l'option C1.

ensuite voici les actions que j'ai suivi :

 

1) téléchargez le fichier image de la première publication ici (j'ai utilisé le chargeur 1.02b ds3615) https://xpenology.com/forum/topic/6253-dsm-6xx-loader/

2) modifiez les paramètres de votre vm actuel et écrivez l'adresse MAC

 

3) Connectez-vous à votre interface Web DSM 5.2 et écrivez le numéro de série; 

 

Arrêt de la vm

4) télécharger et installer OSFmount, puis monter le fichier d'image téléchargé au point 1 (déverrouiller "lecteur en lecture seule"); Choisissez partiton 0 15 Mo

5) avec le bloc-notes ++ ou l'édition similaire grub.cfg avec l'adresse série et MAC du point 2 et 3, vous pouvez également modifier le délai d'attente par défaut; Je n'ai rien modifié de vid et pid

6) télécharger et installer le convertisseur d'image StarWind V2V; Convertissez le fichier image avec grub.cfg modifié (choisissez l'image du serveur VWware ESX)

7) cela entraînera 2 fichiers synoboot.wmdk et synoboot-flat.wmdk

8) téléchargez-les dans le même magasin de données où vous avez xpenoboot.wmdk ou vous pouvez créer un autre dossier; Vous pouvez utiliser le navigateur de banque de données pour télécharger des fichiers

9) modifiez les paramètres du vm et supprimez le disque dur indiquant le disque virtuel xpenoboot.vmdk ou synoboot.vmdk suivant les cas

10) ajouter un nouveau disque dur scsi 0: 0 point de repère indépendant indépendant de synoboot.vmdk

11) Je n'ai ajouté aucun port série

12) démarrez le vm et ouvrez immédiatement la console, car vous devez sélectionner la troisième entrée du menu de démarrage, celle relative à esxi (je n'étais pas assez rapide et j'avais besoin d'une réinitialisation vm)

13) ouvrez un navigateur Web pour trouver.synology.com

14) connectez, installez, migrez, installez manuellement avec le dernier fichier de pat vous pouvez télécharger à partir de liens ici https://xpenology.com/forum/topic/7294-links-to-dsm-and-critical-updates/

 

Je n'ai pas de souci pour le moment, je conseille une sauvegarde de tes paramètres avant le début de la migration tout de même.

 

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour traxert,

 

Merci pour cette réponse détaillée :-)

J'avais également trouvé ce tuto sur le forum anglais, mais avant de l'appliquer je voulais faire un test hors migration en créant une nouvelle VM à partir de zéro en utilisant le loader et de dernier DSM possible.

Par contre je n'avais pas fait attention à l'option C1 dans le BIOS.

Je vais regarder cela.

Merci encore et bonne journée

Share this post


Link to post
Share on other sites

Merci aussi pour la réponse, je suis dans la meme problématique, j'ai une VM sous Esxi qui fige assez souvent, du coup je pensais migrer vers DSM 6 pour, peut etre, régler ce problème. Je verrais pour tenter la migration

Share this post


Link to post
Share on other sites

Bonjour 

J ai enfin recu mes dd j ai donc creer la clef usb comme dans le tuto.

J ai verifier et reverifer.

Mais la clef usb ne boot pas.

Portant avec linux ou autre ca fonctionne nickel.

J ai reussi a booter avec ce loader https://mega.nz/#!KV8BjaLb!Bt28SEBMlvmcu3DdhMtpG-t-WmycNA4UKASfFwcyrjo

Celuis ci est assez lourd pese plus de 300mo

De ce tuto https://www.xpenology-fr.net/tag/dsm-6-0/

 

Je crois c est ancien loader qui de plus a ete retravaillé.

Quelqu un pourrait m expliquer pourquoi j arrive a booter avec un et pas l autre? 

J aimerai utiliser le dernier loader stable a cette heure.

 

Je suis sur une machine hp proliant gen 8 g1610t  produit  819185-421

 

Merci 

 

Edited by Krisrider24

Share this post


Link to post
Share on other sites

Je viens d'essayer la methode vraiment au top de Taxert, mon soucis c'est que j'utilise, sur mon esxi, une iso pour le boot du xpenoboot, lorsque je remplace l'iso par le vdmk que l'on a généré avec le grub modifié, ou l'img synoboot téléchargé au point 1), ça ne boot pas, ça reste sur un ecran noir.

Je sais pas trop comment m'y prendre du coup

Share this post


Link to post
Share on other sites

Bonjour, 

 

Quelle est la difference entre un loader.img et un .iso? 

 

Je m explique avec le loader jun 1.01 qui est en .img la clef usb ne boot pas.

Et si je prend le loader 1.02b pour dsm 6.1 qui lui est en .iso la clef usb boot.

 

J aimerai savoir pourquoi un boot et l autre non car je suis curieux et comment faire pour y remedier.

(J ai convertis le .img en .iso avec osfmount rien n y fait).

J ai un hp proliant g1610t gen8

Merci

 

 

 

Share this post


Link to post
Share on other sites
On 7/16/2017 at 5:11 PM, Krisrider24 said:

Bonjour, 

 

Quelle est la difference entre un loader.img et un .iso? 

 

Je m explique avec le loader jun 1.01 qui est en .img la clef usb ne boot pas.

Et si je prend le loader 1.02b pour dsm 6.1 qui lui est en .iso la clef usb boot.

 

J aimerai savoir pourquoi un boot et l autre non car je suis curieux et comment faire pour y remedier.

(J ai convertis le .img en .iso avec osfmount rien n y fait).

J ai un hp proliant g1610t gen8

Merci

 

Difficile de dire pourquoi ça ne marche pas mais si vous avec la dernière version qui marche alors pourquoi s'embête avec une vielle version?

Essayez avec le loader v1.02b au format .img voir si cela marche.

Share this post


Link to post
Share on other sites
10 minutes ago, Polanskiman said:

 

Difficile de dire pourquoi ça ne marche pas mais si vous avec la dernière version qui marche alors pourquoi s'embête avec une vielle version?

Essayez avec le loader v1.02b au format .img voir si cela marche.

Merci polanskiman

Alors en faite c n avait rien a voir avec ca.

J ai fait olusieur test durant deux jours et en faite le problème de boot etait lié a la clef usb

J utilisai une sandisk 16go et après j ai pris une vieille clef usb de marque boulanger b + et elle a booté. Je ne serais dire pourquoi.

Mais la tout fonctionne nickel avec le 1.02b et la derniere mise a jour 6.1.3 

Parfait 

Merci pour ton travail 

 

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

D'abord bravo à @jun, @Trantor, @Polanskiman et la communauté. Beau boulot à tous.

 

J'ai réussi à installer DSM 6.0.2 sur un Dell poweredge 2950 Bi Xeon 5400 et 8go de Ram.

Le raid se monte bien avec 6 disques en SATA (oui on peut mettre des disques SATA au lieu de SAS), je l'ai laissé tourné quelques jours sans problèmes apparent.

En revanche impossible d'évoluer en 6.1 ,  6.1.1 et plus..

Il semble que le driver de la puce Broadcom BCM 5708C nextreme II sur la carte mère ne fonctionne pas.....donc impossible d'aller plus loin.

J'ai updater les firmwares...en vain.

Les dernières moutures de DSM intègrent d'avantages de drivers pour de l'infiniband....certainement prévu pour leur soft de VMM. dommage....

Quelqu'un a une idée pour m'aider à franchir le cap?

 

Merci à tous....

 

J'essaierai d’écouter le port RS..j'ai pas encore essayé....

 

Bonne journée à tous ou bonne nuit :-)....il est 4h du mat...vais me coucher..lol

 

 

 

Share this post


Link to post
Share on other sites

Merci pour ce tutorial mais est ce qu'il est possible de faire une migration de Dsm 6.0.2 vers la dernière Dsm ?

J'ai essayé plusieurs fois en Virtuel mais je n'ai pas réussie.

 

Je fais une installation classic avec DS3615xs 6.0.2 Jun's Mod V1.01

Ensuite je change de loader pour utiliser DS3615xs 6.1 Jun's Mod V1.02-alpha, je fais mes mise à jours, ensuite il reboot et je reste sur la page qui me dit de récupérer les donner, mais sans réussite.

 

Merci d'avance 

Share this post


Link to post
Share on other sites

DSM 6.0.2 vers 6.1.3 ( DSM_DS3615xs_15152.pat ) J'ai réussi à migrer mais quand il reboot je ne vois plus le server avec l'assistance.

 

Je fais une installation avec DS3615xs 6.0.2 Jun's Mod V1.01, ensuite je supprime le synoboot.vmdk de mon server et je crée un nouveau HDD avec le nouveau synoboot.vmdk DS3615xs 6.1 Jun's Mod V1.02-alpha.

 

Le server boot normalement, il me dit de migrer, j'installe manuellement la mise à jour DSM_DS3615xs_15152.pat, il reboot ensuite plus rien ?

 

Vous avez une idée ?

 

SI je fais une installation directement avec DS3615xs 6.1 Jun's Mod V1.02-alpha pour avoir la dernière version  6.1.3 update 1, tout fonctionne.

Share this post


Link to post
Share on other sites
On 7/29/2017 at 5:46 PM, Sabrina said:

DSM 6.0.2 vers 6.1.3 ( DSM_DS3615xs_15152.pat ) J'ai réussi à migrer mais quand il reboot je ne vois plus le server avec l'assistance.

 

Je fais une installation avec DS3615xs 6.0.2 Jun's Mod V1.01, ensuite je supprime le synoboot.vmdk de mon server et je crée un nouveau HDD avec le nouveau synoboot.vmdk DS3615xs 6.1 Jun's Mod V1.02-alpha.

 

Le server boot normalement, il me dit de migrer, j'installe manuellement la mise à jour DSM_DS3615xs_15152.pat, il reboot ensuite plus rien ?

 

Vous avez une idée ?

 

SI je fais une installation directement avec DS3615xs 6.1 Jun's Mod V1.02-alpha pour avoir la dernière version  6.1.3 update 1, tout fonctionne.

Pourquoi supprimer synoboot.vmdk et pourquoi créer un nouveau HDD?

 

La procédure n'est pas bonne. il faut:


1 - installer DSM 6.0.2 avec le loader v1.01

2 - éteindre la machine (baremetal ou VM)

3 - changer le loader v1.01 à v1.02b (et non v1.02a)

4 - rallumer la machine (baremetal ou VM) avec le nouveau loader v1.02b

5 - utiliser find.synology.com ou alors Synology Assistant pour trouver la machine sur le réseau

6 - migrer la machine come indiquer à l'écran en utilisant le fichier .pat de DSM 6.1.3 précédemment téléchargé

7 - laisser faire

8 - vous devriez être sur DSM 6.1.3 après la mise à jour et 1 ou 2 reboot.

 

Nota bene: ceci est le tutorial pour 6.0.2 et non pour 6.1.1

Share this post


Link to post
Share on other sites

Merci Polanskiman pour cette méthode claire de maj 6.0.2 vers 6.1.3 que je n'avais pas vu ailleurs jusque là.

 

Question subsidiaire, à quoi devons nous nous attendre après cette MAJ ?

Devra t-on refaire la configuration comme sur une clean install (ce qu'on m'avait annoncé pour la migration vers 6.1.2) ou l'essentiel (users, packages, etc. même si c'est pas exhaustif à 100%) est bien migré ?

 

Si c'est le cas alors champagne !!!

 

 

Share this post


Link to post
Share on other sites

Bonjour

Je viens de mettre à jour depuis 5.0.2 vers 6.1.3 et ça s'est plutôt bien passé.

J'ai juste un hic.

Deux disques durs d'une de mes deux cartes SATA additionelles ne sont pas reconnus.

Comme je suis en volume SHR-2 avec redondance sur 2 disques, la machine tourne bien par chance, mais bon c'est chaud.

 

J'ai essayé en SataPortMap=622 et 511 (comme c'était déjà sur ma machine en DSM 5.0.2) mais pas mieux ! Les disques durs ne sont pas du tout vus par DSM

Une idée ?

Merci

Edited by LittleLama

Share this post


Link to post
Share on other sites

Up : En fait mes 2 disques durs étaient passés en eSata sur des ports de numéro différent.

Il a fallut jouer avec les paramètres esataportcfg, usbportcfg, internalportcfg de etc/synoinfo.conf et etc.defaults/synoinfo.conf pour retrouver les disques à la bonne place et faire une réparation ... ouf !

Share this post


Link to post
Share on other sites

Bonjour,

 

Je souhaiterai un conseil, ayant actuellement un hp proliant N54L en baremetal en 6.0.2-8451 update 11 avec le loader jun en V1.01. Voulant suivre les maj DSM, je me pose 2 questions qui sont les suivantes:

Première question, y'aura t'il un prochain loader compatible avec un processeur AMD ?

Seconde question dans l'hypothèse ou je migre vers un esxi, y'a t'il une solution de faire une banque de données sur la clé usb bootable de l'esxi afin de mettre la VM sur celle ci (afin d'eviter la perte d'un disque dur) ?

 

Merci d'avance pour vos réponse.

Share this post


Link to post
Share on other sites
23 hours ago, LittleLama said:

Up : En fait mes 2 disques durs étaient passés en eSata sur des ports de numéro différent.

Il a fallut jouer avec les paramètres esataportcfg, usbportcfg, internalportcfg de etc/synoinfo.conf et etc.defaults/synoinfo.conf pour retrouver les disques à la bonne place et faire une réparation ... ouf !


Salut,

Tu pourrais me décrire les étapes que tu as suivies pour retrouver tes disques ? J'ai le même problème à quelques détails près.

 

J'ai migré mon xpenology de 5.2-5644 en 6.1.3-15152 update 1, depuis que j'ai Maj, le syno ne reconnaît plus mes disques branchés sur ma carte RAID, mais seulement ceux brancher sur les ports SATA de la carte mere.

 

La carte RAID est bien identifiée par l'ordinateur.

 

Peux-tu m'aider stp ? 

Share this post


Link to post
Share on other sites

Salut 

Je ne sais pas si la question qur je vais est dans la bonne section mais le wol ne fonctionne plus sous dsm 6 j ai suivis le how to a la lettre sur la section principale mais ca ne fonctionne pas.

Le dossier rc.d dans le quel coller le script n existe plus. Je n ai trouvé que rc.sysv.

Si quelq un a le wol operationnel sous dsm et qu il pouvait me dire comment configurer ca serait cool. Et je pourrais de cette maniere explqiuez la procedure en anglais sur le how to de la section principale

Merci bon week

Share this post


Link to post
Share on other sites
Salut,

Tu pourrais me décrire les étapes que tu as suivies pour retrouver tes disques ? J'ai le même problème à quelques détails près.

 

J'ai migré mon xpenology de 5.2-5644 en 6.1.3-15152 update 1, depuis que j'ai Maj, le syno ne reconnaît plus mes disques branchés sur ma carte RAID, mais seulement ceux brancher sur les ports SATA de la carte mere.

 

La carte RAID est bien identifiée par l'ordinateur.

 

Peux-tu m'aider stp ? 

 

Salut  

En fait le symptôme est que les disques internes étaient vu en eSata (visible dans les disques amovibles comme les clés usb quoi)

 

J'ai suivi ce tuto https://hedichaibi.com/fix-xpenology-problems-viewing-internal-hard-drives-as-esata-hard-drives/

 

J'ai tâtonné un peu en mettant d'abord 21 ports internes,cm ce que je trouvais en faisant la méthode indiquée... et mon disque usb était vu en drive interne. En réduisant progressivement les ports on tombe sur la bonne configuration. L'usb est vu en usb, l'interne en interne, et j'ai mis 0 port eSata.

 

J'ai aussi modifié la variable maxdisks mais je sais pas si ça joue vraiment.

 

Enfin sur les variables hexa j'ai toujours mis 0x avant la valeur hexadécimale contrairement au tuto, mais là aussi pas sûr que ça joue.

 

 

Une fois la bonne configuration rétablie, il faut réparer le raid (les dd ajoutés seront formatés) et tout rentre dans l'ordre.

Share this post


Link to post
Share on other sites

Bonjour

Merci a jun trantor et polasnkiman et a tout ceux qui participe à l'amélioration de cette migration.

J'ai tanté de migré, j'ai suivi le tuto à la lettre pour la création de la clé USB. Lorsque je lance "find.synology.com" il me trouve bien mon Syno mais il me dit :

"Nous avons détecté que les disques durs de votre DS3615xs actuel a été supprimé à partir d'un précédent DS3615xs et l'installation d'un tout nouveau DSM est demandé avant de continuer."

Je n'ai pas fait l'install et j'ai rebooter avec mon ancienne clé avec le DSM 5.2 et la, pas de pb, mes disques sont bien présents.

Il faut dire que juste avant lors d'une coupure de courant il ne rebootait plus et il me mettait "killed" en derniere ligne. impossible de relancer mon syno. J'ai fait une mise a jour en version 5.2 5644 (j'etais dans une version inferieure) j'ai retrouver mes disques mais mon DSM était vierge, j'ai du reinstaller les appli, reconfigurer le réseau, etc. Comme j'avais fait une sauvegarde de la config il m'a restauré les partages, droits, compte, etc.

Maintenant si je passe en 6.02 et avec ce message vais-je perdre mes disques et mes données ?

Si qqun peut m'aider ou s'il a rencontré ce pb merci par avance

 

 

Share this post


Link to post
Share on other sites

Desole je n'ai pas précisé :

Ma carte mere : ASUS H87I

Carte réseau : embarquée

5 disques sata WD 2To branchés sur les ports sata de la carte mere du port 1 à 5 (rien d'exotique).

2 clé USB de 16 Go SANDISK (une pour la 5.2 et une pour migrer en 6.02).

Share this post


Link to post
Share on other sites

Oups en parcourant les posts je viens de voir que quelqu'un avait posté la m^me demande que moi.

Donc je vais tenter la migration

 

On 04/02/2017 at 2:16 PM, lochet93 said:

Bonjour,

 

Je suis en train de faire la migration vers 6.0.Tout ce passait bien, le NAS est détecté, je clique sur connecter et là j'ai le bouton installer avec en dessous le message

"Nous avons détecté que les disques durs de votre DS3615xs actuel a été supprimée à partir d'un précédent DS3615xs et l'installation d'un tout nouveau DSM est demandée avant de continuer". Est ce normal?

 

Merci de votre aide

 

Share this post


Link to post
Share on other sites

Bon, le passage au DSM 6 s'est pas bien passé du tout. il me detecte plus rien et le pire c'est que je le vois plus du tout.

heureusement que c'était un test sur une machine de spare.

 

Je vais voir pour installer un DSM 6.0 direct plutôt que de passer par un update.

Merci en tout cas pour tous les conseils présent sur la page.

Share this post


Link to post
Share on other sites

Bonjour, il semblerait que dans la 1.01 les drivers usb du HP54L ne soient pas présent et du coup on ne voit plus l'UPS que l'on voyait dans la 5.2.

Quelqu'un peut me confirmer que c'est bien un problème de drivers usb ?

 

Merci

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.