Polanskiman

[Tuto] Installer/Migrer DSM 5.2 à 6.0.2 (Loader Jun)

Recommended Posts

Hello,

 

Je viens de tenter l'install sur VM en transformant l'image de Arcao v2 en vmdk via Starwind (comme je l'ai fait pour Xpeno 5.2) et en skippant le modif du Grub.cfg vu que je n'utilise pas de clé (surement un problème ici... :wink: ) mais quand je lance ma VM, elle reste bloquée sur "Booting the kernel"...

 

Une idée pour m'aider ?

 

Vous avez réussi a l'installer en VM sous ESXi ?

Share this post


Link to post
Share on other sites

@jkd peux tu peux me donner ton modèle de carte mère ? Un clear cmos est peut être possible, il faut savoir que lorsqu'on flash un bios on flash uniquement une parti reinscriptible à volonté, mais il y a une version d'origine qui est stocker sur une mémoire qu'on ne peux pas modifier justement pour résoudre ce genre de problème, en général il faut déplacer un cavalier sur la carte mère ou faire un cour circuit avec un tournevis

 

Envoyé de mon C6833 en utilisant Tapatalk

Share this post


Link to post
Share on other sites
Après avoir écrit l'image de Jun sur une clé USB, je n'arrive pas à booter dessus alors qu'avec celle d'Arcao elle boot. Quelqu'un aurait une solution ?

 

Quelle application avez vous utilisé pour créer l'image sur le clef usb?

Share this post


Link to post
Share on other sites

Bonjour,

Après migration en DSM6 depuis 5.2 je ne vois plus mon XPEnology sur le réseau. Je le trouve bien via son IP, j'y accède bien via Safari mais impossible de monter les dossiers partagés. Je suis sur mac sous Sierra.

Je ne sais pas encore ce que ça donne sous Windows n'en ayant pas sous la main.

Quelqu'un aurait il une idée ?

Share this post


Link to post
Share on other sites
Fonctionne parfaitement avec le XPEnoboot de Jun (v1.01) sur VMware Workstation 12.5.0. Version de DSM : 6.0.2-8451 Update 2

Je n'ai pas fait le test avec Virtual Box.

 

Salut,

j'ai testé avec vmware 12 et ça fonctionne aussi mais je me pose plusieurs questions :

- comment modifier le S/N et le MAC vu que qu'il n'y a pas de boot sur clé usb puisqu'on lance un disque virtuel synoboot.img ?

- as-tu utilisé tes 3x4To ? si oui, en RDM ?

merci d'avance !

 

Si vous utiliser une des dernières version v.1.0 ou v.1.01 Jun a rendu possible la modification du S/N et MAC directement à partir de l'interface Grub. Il suffit d'appuyer la lettre "C" lorsque vous êtes dans le menu boot. Vous n'avez qu'une seconde pour le faire donc il faut être vif!!

95WsOj3.jpg

 

Pour modifier le S/N, écrire sn=[votre S/N]

3bBZ18n.jpg

Appuyez sur Enter (return) pour confirmer. Pour revenir au menu boot appuyez sur Esc puis Enter à nouveau pour booter DSM.

 

Sur un baremetal pour modifier le mac, écrire mac1=[votre numero mac SANS les ":" entre chaque pair]

Si vous avez plusieurs ports réseau alors vous pouvez rajouter mac2, mac3 etc

UzE8Zwc.jpg

 

Ceci étant dit, comme vous êtes sur une machine virtuelle je pense que le mac doit se changer à partir de la configuration de vmware et non à partir du menu boot. En tout cas c'est le cas pour moi lorsque j'ai essayé sur VirtualBOX.

 

AUTRE SOLUTION:

 

Ouvrir l'image sous ubuntu live et faire la modification directement sur le fichier grug.cfg.

Edited by Guest

Share this post


Link to post
Share on other sites
@jkd peux tu peux me donner ton modèle de carte mère ? Un clear cmos est peut être possible, il faut savoir que lorsqu'on flash un bios on flash uniquement une parti reinscriptible à volonté, mais il y a une version d'origine qui est stocker sur une mémoire qu'on ne peux pas modifier justement pour résoudre ce genre de problème, en général il faut déplacer un cavalier sur la carte mère ou faire un cour circuit avec un tournevis

 

Envoyé de mon C6833 en utilisant Tapatalk

 

Salut,

 

MEDION

Model : PC MT7

Typ : MED MT 490G

Carte mère : MS-7358 VER: 1.1

Share this post


Link to post
Share on other sites

Bonjour,

Comment savez-vous que cela fonctionne car sur mon N54L en lançant la commande ci-dessous dans putty mon processeur reste à sa fréquence max de 2200Mhh.

grep "MHz" /proc/cpuinfo

Mais en créant un script utilisateur au démarrage avec l'utilisateur root j'ai mon processeur qui descend à la fréquence de 800Mhz.

code à mettre

for c in $(ls -d /sys/devices/system/cpu/cpu[0-9]*);
do if ! grep -q 'conservative' $c/cpufreq/scaling_governor ;
   then echo conservative >$c/cpufreq/scaling_governor ;
fi
done

Et là l'économie d'énergie est activée.

 

C'était sous entendu en fait qu'il faut utiliser le script ci-dessus, en effet de base après l'installation le CPU est au max. Désolé si ce n'était pas claire.

Share this post


Link to post
Share on other sites
Après avoir écrit l'image de Jun sur une clé USB, je n'arrive pas à booter dessus alors qu'avec celle d'Arcao elle boot. Quelqu'un aurait une solution ?

 

Quelle application avez vous utilisé pour créer l'image sur le clef usb?

 

J'ai utilisé Win32disk disk imager, gnome multi writer et USB image writer (Linux mint) mais sans succès.

Share this post


Link to post
Share on other sites

 

Si vous utiliser une des dernières version v.1.0 ou v.1.01 Jun a rendu possible la modification du S/N et MAC directement à partir de l'interface Grub. Il suffit d'appuyer la lettre "C" lorsque vous êtes dans le menu boot. Vous n'avez qu'une seconde pour le faire donc il faut être vif!!

 

Ceci étant dit, comme vous êtes sur une machine virtuelle je pense que le mac doit se changer à partir de la configuration de vmware et non à partir du menu boot. En tout cas c'est le cas pour moi lorsque j'ai essayé sur VirtualBOX.

 

AUTRE SOLUTION:

 

Ouvrir l'image sous ubuntu live et faire la modification directement sur le fichier grug.cfg.

 

Merci Polanskiman pour toutes ces infos !! je vais tester chaque méthode et garder ma préférée (j'ai un petit faible pour la dernière pour l'instant, elle permettra de faire d'autres modifs ultérieurement)

Share this post


Link to post
Share on other sites

Hello,

 

Petite question, c'est possible de faire la mise à jour à partir d'une version 4.3 de xpenology ou il faut obligatoirement passer en 5.2 avant ?

Share this post


Link to post
Share on other sites
Hello,

 

Je viens de tenter l'install sur VM en transformant l'image de Arcao v2 en vmdk via Starwind (comme je l'ai fait pour Xpeno 5.2) et en skippant le modif du Grub.cfg vu que je n'utilise pas de clé (surement un problème ici... :wink: ) mais quand je lance ma VM, elle reste bloquée sur "Booting the kernel"...

 

Une idée pour m'aider ?

 

Vous avez réussi a l'installer en VM sous ESXi ?

 

Bonjour,

 

Au temps pour moi, j'étais persuadé d'avoir lu ce topic et n'avais pas trouvé de solution alors que tout y était (je m'étais trompé de post).

Désolé

 

Merci à Polanskiman et à nicoeron pour vos tutos !

Share this post


Link to post
Share on other sites
@jkd plutôt que de cassé la tête à tout dessouder pour rien tu as cas lire (en anglais désolé) ceci https://www.google.fr/url?sa=t&source=w ... Lo2jCpUPYw

 

Page 28 et tout devrais revenir dans l'ordre !

 

Envoyé de mon C6833 en utilisant Tapatalk

 

PC hors tension j'ai déplacé le cavalier comme indiqué dans le manuel, mais cela ne fonctionne toujours pas.

Share this post


Link to post
Share on other sites

J'ai déjà parlé précédemment de voir si la carte redémarre en faisant un reset du BIOS ( donc la pile ) et force de constater que cela n' a pas fonctionné.

Je confirme cela ne fonctionne pas.

 

La première solution est d' essayer de "reflasher à l' aveugle" avec un disquette qui lancera le flash.bat.

Encore faut-il que le chargeur du BIOS soit toujours fonctionnel..

Pour flasher avec une disquette il faudrait que le PC démarre, mais ce n'est pas le cas.

 

La seconde solution et la seule qui permette de réparer la carte mère est de remplacer la mémoire.

Comment faire ?

Où se trouve se trouve exactement cette mémoire sur la CM et où trouver une nouvelle mémoire ?

Share this post


Link to post
Share on other sites
Où se trouve se trouve exactement cette mémoire sur la CM et où trouver une nouvelle mémoire ?

 

Lire le contenu de mon avant dernière réponse ...

 

------------

Si vous êtes bon en électronique il suffit de la dessouder, la reprogrammer avec le firmware mis à disposition en la plaçant dans un programmateur.

S' il y a dans le contenu original l' adresse MAC de la carte réseau il suffit ensuite avec le flasher de la reprogrammer une fois l' EEPROM remise en place en utilisant l' option MAC=xxx .

Personnellement je dispose de tout ce qu'il faut pour le faire.

 

Je peux vous aider si vous avez un peu de matériel :

1 - Enlever l' étiquette qui est sur l' EEPROM ( située à coté du connecteur d' alimentation ) pour me donner la référence exacte indiquée

2 - Avec une petite pince coupante sectionner délicatement les pattes au ras de la mémoire

3 - Enlever le reste des pattes sectionnées sur le circuit imprimé ainsi que la soudure

4 - Me donner votre adresse afin que je vous envoie "gratuitement" une nouvelle mémoire reprogrammée

5 - Il vous restera à la ressouder délicatement

 

Je n'arrive pas situer l'EEPROM, combien de pattes y a t il ?

Share this post


Link to post
Share on other sites

J'ai un N54L. J'utilise Win32Imager pour mettre la version 1.0.1 du synoboot.img mais une fois les partitions de crées elles ne sont pas visible dans windows.

J'aimerai modifier le fichier grub.cfg mais je ne peux pas dans ce cas.

Est-ce que quelqu'un a une idée pour pouvoir avoir cette partition visible sous windows?

 

Merci

Share this post


Link to post
Share on other sites
[

 

Je n'arrive pas situer l'EEPROM, combien de pattes y a t il ?

 

Elle se situe a l 'extrème a coté des supports mémoires près du connecteur disquette. ( je regarde sur les photos .. pas sur )

La mémoire a une étiquette collée sur le dessus.

Cette mémoire est forme légèrement rectangulaire 7 pattes sur le plus petit coté, 9 sur le plus grand et a donc 32 pattes en tout.

 

Le seul composant avec une étiquette est bien rectangulaire mais à plus de 32 pattes ...

Share this post


Link to post
Share on other sites

 

Le seul composant avec une étiquette est bien rectangulaire mais à plus de 32 pattes ...

 

Relire juste avant je viens d' éditer le contenu du texte

 

Si c'est ce que je pense il y a un connecteur JSPI1 qui permettrait de reprogrammer le BIOS sans dessouder la mémoire.

Le brochage serait celui-ci : https://forum-en.msi.com/index.php?topic=256289.0

L' EEPROM est surement située juste à coté

Si c'est bien cela un petit programmateur ne coute quasiment rien.

http://www.ebay.fr/itm/25-SPI-Series-24 ... Sw8w1YAZOG

 

Sur googl y a des photos de ma CM (MSI ms-7358 ver. 1.1 socle 775) cela peux vous aider

 

Merci

Share this post


Link to post
Share on other sites

 

Le seul composant avec une étiquette est bien rectangulaire mais à plus de 32 pattes ...

 

Relire juste avant je viens d' éditer le contenu du texte

 

Si c'est ce que je pense il y a un connecteur JSPI1 qui permettrait de reprogrammer le BIOS sans dessouder la mémoire.

Le brochage serait celui-ci : https://forum-en.msi.com/index.php?topic=256289.0

L' EEPROM est surement située juste à coté

Si c'est bien cela un petit programmateur ne coute quasiment rien.

http://www.ebay.fr/itm/25-SPI-Series-24 ... Sw8w1YAZOG

 

Sur googl y a des photos de ma CM (MSI ms-7358 ver. 1.1 socle 775) cela peux vous aider

 

Merci

 

J'ai trouvé le connecteur JSPI1, y a bien un composant à coté "W7358 IM710R"

Comment s'utilisent le cable et le rogrammateur ?

Share this post


Link to post
Share on other sites
F5BJR said:

Relire juste avant je viens d' éditer le contenu du texte

 

Si c'est ce que je pense il y a un connecteur JSPI1 qui permettrait de reprogrammer le BIOS sans dessouder la mémoire.

Le brochage serait celui-ci : https://forum-en.msi.com/index.php?topic=256289.0

L' EEPROM est surement située juste à coté

Si c'est bien cela un petit programmateur ne coute quasiment rien.

http://www.ebay.fr/itm/25-SPI-Series-24 ... Sw8w1YAZOG

 

J'ai trouvé le connecteur JSPI1, y a bien un composant à coté "W7358 IM710R"

Comment s'utilisent le cable et le rogrammateur ?

 

Ce n' est pas être la bonne référence mais ce qui indiqué sur une étiquette qui peut se décoller

La mémoire SPI est surement avec un sigle MX ( Macronics ) ou Winbond

 

Pour utiliser le programmeur flash SPI il faut faire la correspondance entre les pins du support à 8 broches et celles du connecteur jaune par exemple avec un Ohmètre.

Ensuite il y a un piolte à installer et un logiciel à utiliser contenu dans le CDROM fourni.

 

Merci, j'essayerai de voir demain.

Share this post


Link to post
Share on other sites
F5BJR said:

Relire juste avant je viens d' éditer le contenu du texte

 

Si c'est ce que je pense il y a un connecteur JSPI1 qui permettrait de reprogrammer le BIOS sans dessouder la mémoire.

Le brochage serait celui-ci : https://forum-en.msi.com/index.php?topic=256289.0

L' EEPROM est surement située juste à coté

Si c'est bien cela un petit programmateur ne coute quasiment rien.

http://www.ebay.fr/itm/25-SPI-Series-24 ... Sw8w1YAZOG

et

jkd said:

J'ai trouvé le connecteur JSPI1, y a bien un composant à coté "W7358 IM710R"

Comment s'utilisent le cable et le rogrammateur ?

 

Ce n' est pas être la bonne référence mais ce qui indiqué sur une étiquette qui peut se décoller

La mémoire SPI est surement avec un sigle MX ( Macronics ) ou Winbond

 

Pour utiliser le programmeur flash SPI il faut faire la correspondance entre les pins du support à 8 broches et celles du connecteur jaune par exemple avec un Ohmètre.

Ensuite il y a un piolte à installer et un logiciel à utiliser contenu dans le CDROM fourni.

 

Merci, j'essayerai de voir demain.

 

Ca devient un peu du hors sujet. Peut être ouvrir un autre file de discussion (ou faire ça en PM) sur comment flasher/remplacer un EEPROM?

Merci.

Share this post


Link to post
Share on other sites
Après avoir écrit l'image de Jun sur une clé USB, je n'arrive pas à booter dessus alors qu'avec celle d'Arcao elle boot. Quelqu'un aurait une solution ?

 

Quelle application avez vous utilisé pour créer l'image sur le clef usb?

 

J'ai utilisé Win32disk disk imager, gnome multi writer et USB image writer (Linux mint) mais sans succès.

 

Avez vous essayé avec une autre clef usb?

Share this post


Link to post
Share on other sites
Hello,

 

Petite question, c'est possible de faire la mise à jour à partir d'une version 4.3 de xpenology ou il faut obligatoirement passer en 5.2 avant ?

 

Il faut impérativement passer à 5.2 d'abord.

Share this post


Link to post
Share on other sites
J'ai un N54L. J'utilise Win32Imager pour mettre la version 1.0.1 du synoboot.img mais une fois les partitions de crées elles ne sont pas visible dans windows.

J'aimerai modifier le fichier grub.cfg mais je ne peux pas dans ce cas.

Est-ce que quelqu'un a une idée pour pouvoir avoir cette partition visible sous windows?

 

Merci

 

Les partions EFI ne sont malheureusement pas visibles sur les versions de Windows antérieur à Windows 10. Il faut donc Windows 10 pour être capable de voir la partition, ou alors si vous avez un Mac, branchez votre clef USB dessus, ouvrez Terminal et écrivez ceci:

diskutil list

 

Vous devriez voir tous les disques disponibles sur votre machine:

/dev/disk0 (internal, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *640.1 GB   disk0
  1:                        EFI EFI                     209.7 MB   disk0s1
  2:                  Apple_HFS El Cap_TESTING_ENVIR... 214.1 GB   disk0s2
  3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
  4:                  Apple_HFS El Capitan              424.5 GB   disk0s4
  5:                 Apple_Boot Recovery HD             650.0 MB   disk0s5
/dev/disk1 (internal, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *640.1 GB   disk1
  1:                        EFI EFI                     209.7 MB   disk1s1
  2:                  Apple_HFS Mac 1                   639.8 GB   disk1s2
/dev/disk2 (internal, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *2.0 TB     disk2
  1:                        EFI EFI                     209.7 MB   disk2s1
  2:                  Apple_HFS Backup_OSX              1000.0 GB  disk2s2
  3:                  Apple_HFS Backup_DATA             999.9 GB   disk2s3
/dev/disk3 (external, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *4.0 GB     disk3
  1:                        EFI NO NAME                 31.5 MB    disk3s1
  2:           Linux Filesystem                         15.7 MB    disk3s2
  3:        Bios Boot Partition                         4.2 MB     disk3s3

 

Dans la liste ci dessus il faut chercher la partition EFI de votre clef USB. Dans mon cas c'est disk3s1 (3ième ligne en partant du bas). Il suffit ensuite d'écrire:

mkdir /Volumes/efi

suivi de:

sudo mount -t msdos /dev/disk3s1 /Volumes/efi

La partition EFI de votre clef USB est maintenant montée.

 

Notez bien dans la dernière commande que j'ai utilisé disk3s1. Votre partition n'aura surement pas le même nom donc faites bien attention.

 

--------------

MAJ: Sous windows 7 ou antérieur vous pouvez aussi utiliser ça >>> http://www.osforensics.com/tools/mount-disk-images.html. Il faut monter la partition qui contient les données seulement et non pas toute l'image. Décochez la case "lecture seule". Editez le fichier grub.cfg avec l'éditeur de texte que j'ai mis sur le tuto.

Edited by Guest

Share this post


Link to post
Share on other sites
Bonjour,

Mon premier post :smile:

Après une grosse après midi de galère, enfin migration en DSM6 vue et fonctionnelle.

HP Gen 8 avec 4 disques en facade.

V1.1 de jun.

Après moults essais, prises de tête, car mon synology plus vu sur le réseau, j'ai changé de clef usb (celle de mon DMS5 que j'avais réutilisée ne faisait que 1Go). Et bien la nouvelle fonctionne bien du premier coup ! Donc à priori faire gaffe à prendre au dessus de 1go (je n'ai rien changé d'autre en passant sur la nouvelle clef).

 

Si ca peut aider certains...

 

Bon courage

 

Je ne vois pas pourquoi une clef de 1Go ne pourrait pas marcher. Dans le tuto j'ai mis une clef de 4Go tout simplement car de nos jours c'est standard mais je suis persuadé que meme une clef de 512Mo marcherait. A mon avis votre clef doit avoir un problème. Lorsque l'image est copiée sur la clef USB, 3 partitions sont crées, une de ~31Mo, une autre de ~16Mo et la 3ième de ~4.2Mo. Le reste n'est pas utilisé. Celle ou se trouve les données est la partition de 31Mo.

 

Et juste pas souci de précision c'est la version v1.0.1 et non v.1.1 :ugeek:

 

------------

MAJ: J'ai essayé avec un clef USB de 128Mb d'une vitesse fulgurante d'écriture de 12Mb/s datant donc de la préhistoire et cela a marché certes lentement, mais sans problème.

 

Bonjour,

Effectivement après tests et une autre clef de 512 Mo récupérée ça fonctionne nickel. Merci du retour :smile:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.