Jump to content
XPEnology Community

DS3622xs DSM 7.1 USB support with RedPill Tinycore


Recommended Posts

Hi,

 

i already posted the question RedPill - the new loader for 6.2.4 - Discussion but i think it was not the matching topic for my question (topic is growing too fast for detailed discussion).

 

I used tinycore to install DS3622xs+ with DSM 7.1-42661 Update 1 on my N54L hardware.

 

On my prvious DSM 6 install i succesfully used zigbee usb dongles with homeassistant.

I tried two different dongles with different driver chips (FTDI and CP210x) on the new DSM 7.1 install.

 

For the FTDI based dongle the drivers are already included in the stock kernel so i just loaded them as previously done with DSM6:

 

sudo insmod /lib/modules/usbserial.ko
sudo insmod /lib/modules/ftdi_sio.ko

 

Unfortunately both tested usb dongles are not detected by the system.

 

The "dmesg" command shows no log output if the dongles are plugged in. (Not a single line related to the USB dongle, seems like no events are created)

If i plug a USB drive in the same USB port the drive i loaded and available in DSM so the USB hub and port seem to work fine in general. 

 

Here is the output of "dmesg | grep usb" after the usb dongle was replugged several times:

 

[    2.265247] <redpill/usb_boot_shim.c:229> Registering USB boot device shim
[    2.265487] <redpill/usb_boot_shim.c:194> Registered usbcore module notifier
[    2.269655] <redpill/usb_boot_shim.c:247> Successfully registered USB boot device shim
[   13.933321] usbcore: registered new interface driver usbfs
[   13.933528] usbcore: registered new interface driver hub
[   13.933736] usbcore: registered new interface driver ethub
[   13.933943] usbcore: registered new device driver usb
[   13.934137] <redpill/usb_boot_shim.c:166> usbcore registered, adding device watcher
[   13.934405] <redpill/call_protected.c:112> Got ptr ffffffffa00d7db0 for usb_register_notify
[   13.934698] <redpill/usb_boot_shim.c:127> Registered USB device notifier
[   13.972036] <redpill/usb_boot_shim.c:75> Found new device <vid=xxxx, pid=xxxx> - didn't match expected <vid=xxxx, pid=xxxx> (prev_shimmed=0)
[   13.979871] <redpill/usb_boot_shim.c:75> Found new device <vid=xxxx, pid=xxxx> - didn't match expected <vid=xxxx, pid=xxxx> (prev_shimmed=0)
[   13.988036] <redpill/usb_boot_shim.c:75> Found new device <vid=xxxx, pid=xxxx> - didn't match expected <vid=xxxx, pid=xxxx> (prev_shimmed=0)
[   14.044782] usbcore: registered new interface driver usb-storage
[   14.302061] usb 2-3: new high-speed USB device number 2 using ehci-pci
[   14.440089] usb-storage 2-3:1.0: USB Mass Storage device detected
[   14.442075] scsi host6: usb-storage 2-3:1.0
[   14.442352] <redpill/usb_boot_shim.c:91> Device <vid=xxxx, pid=xxxx> shimmed to <vid=xxxx, pid=xxxx>
[   16.494373] <redpill/bios_shim.c:215> Symbol #59 in mfgBIOS "broadwellnk_synobios" {syno_usb_prohibit_event}<ffffffffa018a470>
[   25.413853] systemd[1]: Starting Mount usb fs...
[   25.914175] usbcore: registered new interface driver usblp
[   25.931881] usbcore: registered new interface driver usbhid
[   25.932107] usbhid: USB HID core driver
[   25.973474] <redpill/bios_shim.c:215> Symbol #59 in mfgBIOS "broadwellnk_synobios" {syno_usb_prohibit_event}<ffffffffa0b59470>
[   48.955098] usbcore: registered new interface driver usbserial
[   48.998396] usbcore: registered new interface driver ftdi_sio
[   48.998620] usbserial: USB Serial support registered for FTDI USB Serial Device

 

The "lsusb" command also only shows connected USB drives. The zigbee dongles dont show up in the lsusb output:

 

|__usb1          1d6b:0002:0404 09  2.00  480MBit/s 0mA 1IF  (ehci_hcd 0000:00:12.2) hub
|__usb2          1d6b:0002:0404 09  2.00  480MBit/s 0mA 1IF  (ehci_hcd 0000:00:13.2) hub
  |__2-3         f400:f400:0200 00  2.00  480MBit/s 100mA 1IF  (USB Disk 2.0 HEADER1397438310856)
|__usb3          1d6b:0002:0404 09  2.00  480MBit/s 0mA 1IF  (ehci_hcd 0000:00:16.2) hub

 

@flyride mentioned it could be related to the discontinued USB support by synology:

 

https://macandegg.com/2021/06/synology-dsm-7-0-ends-support-for-usb-devices/#:~:text=DSM 7.0%3A No more USB sticks&text=First%2C the support for external,LTE sticks%2C Bluetooth dongles anymore.

 

I still have the feeling the issue is somewhere else. I would guess synology just removed additional usb drivers and hide devices except for Usb drives from the UI but i can not really imagine they put so much effort into kernel / driver modification to fully prevent the system from detecting other USB devices.

 

Also there are manuals like: https://mariushosting.com/synology-how-to-add-usb-support-on-dsm-7/

which describes how to load the missing driver modules (same as i did above) to enable the USB support on DSM7 (and a lot of users responded it worked).

 

Can maybe someone with Tinycore and DS3622xs + DSM 7.1 test if USB devices are alow not showing in the syslog (except for USB ones) ?

Instead of Zigbee or Zwave dongles i also tried to attach a keyboard to the N54L, it is also not detected according to the syslog.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...