Jump to content
XPEnology Community

Active Backup pour RaspberryPi


Recommended Posts

Bonjour à tous,

 

Je me suis lancé un défi d'utiliser Active Backup pour sauvegarder l'ensemble de mon rapsberry sur lequel tourne toute ma domotique. Mais si j'en suis à poster ici c'est que je rencontre un pb...

 

Depuis un client SSH connecté au raspberryPi, je télécharge l'agent depuis le repo Syno :

wget https://global.download.synology.com/download/Utility/ActiveBackupBusinessAgent/2.4.0-2234/Linux/x86_64/Synology%20Active%
20Backup%20for%20Business%20Agent-2.4.0-2234-x64-deb.zip

 

Ensuite je lance l'installation en sudo :

pi@domotique:~/temp-syno $ sudo ./install.run
Verifying archive integrity...  100%   MD5 checksums are OK. All good.
Uncompressing Active Backup for Business Agent  100%
Atteint :1 http://archive.raspberrypi.org/debian buster InRelease
Réception de :2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15,0 kB]
Atteint :3 https://deb.nodesource.com/node_16.x buster InRelease

15,0 ko réceptionnés en 2s (6 552 o/s)

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
3 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
 * start checking dependency of (4)
 * checking linux-headers-5.10.103-v7+
 * found linux-headers-5.10.103-v7+ not installed, install automatically
 * installing linux-headers-5.10.103-v7+
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-headers-5.10.103-v7
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-5.10.103-v7 »
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-5.10.103-v7 »
* install linux-headers-5.10.103-v7+ failed, please try again later, or run 'apt install linux-headers-5.10.103-v7+ manunally or download and in
stall package from https://packages.ubuntu.com/buster/linux-headers-5.10.103-v7+

 

Et là c'est le drame, impossible de trouver les headers dans la bonne version pour installer l'agent. Quelqu'un aurait une idée ? 

  • Faut-il que je mette à jour mon Raspberry (aujourd'hui je suis avec Raspbian 10 - Buster) ?
  • Existe-t-il une version plus ancienne de l'agent? si oui où la trouver ?

 

Merci par avance pour votre aide

 

Nico

Link to comment
Share on other sites

Bon je suis passé à la version 11 - Bullseye et c'est pareil :(

 

pi@domotique:~/temp-syno $ sudo ./install.run
Verifying archive integrity...  100%   MD5 checksums are OK. All good.
Uncompressing Active Backup for Business Agent  100%
Atteint :1 http://raspbian.raspberrypi.org/raspbian bullseye InRelease
Atteint :2 http://archive.raspberrypi.org/debian bullseye InRelease
Atteint :3 https://deb.nodesource.com/node_16.x bullseye InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
W: Le fichier configuré « ui/binary-armhf/Packages » ne sera pas pris en compte car le dépôt « http://archive.raspberrypi.org/debian bullseye InRelease » ne dispose pas de la source « ui » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « ui/i18n/Translation-en » ne sera pas pris en compte car le dépôt « http://archive.raspberrypi.org/debian bullseye InRelease » ne dispose pas de la source « ui » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « ui/i18n/Translation-fr_FR » ne sera pas pris en compte car le dépôt « http://archive.raspberrypi.org/debian bullseye InRelease » ne dispose pas de la source « ui » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « ui/i18n/Translation-fr » ne sera pas pris en compte car le dépôt « http://archive.raspberrypi.org/debian bullseye InRelease » ne dispose pas de la source « ui » (erreur de saisie dans sources.list ?)
 * start checking dependency of (4)
 * checking linux-headers-5.15.32-v7+
 * found linux-headers-5.15.32-v7+ not installed, install automatically
 * installing linux-headers-5.15.32-v7+
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet linux-headers-5.15.32-v7
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « linux-headers-5.15.32-v7 »
* install linux-headers-5.15.32-v7+ failed, please try again later, or run 'apt install linux-headers-5.15.32-v7+ manunally or download and install package from https://packages.ubuntu.com/bullseye/linux-headers-5.15.32-v7+

 

Link to comment
Share on other sites

Posted (edited)

Salut,

J'y connais rien a Active Backup, mais peut etre je pourrai te donner des pistes avec un oeil "extérieur".

 

https://kb.synology.com/en-global/DSM/help/ActiveBackupBusinessAgent/activebackupbusinessagent?version=7#2

Dans la doc il est écrit :

System requirement:

Supports kernel versions between 2.6 and 5.4

 

Quel est ton kernel actuel ? Pour le savoir :

uname -a

 

Pourrai tu nous montrer ton fichier sources ?

cat /etc/apt/sources.list

 

Edited by EVOTk
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...