DSM 6.1.x Loader


Recommended Posts

Hi Folks, i have a issue with IGBXE driver into Jun 1.01 Image on Gen 8 Baremetal.

It seems there is some problem with MMIO

[   15.985894] ixgbe 0000:07:00.0: SR-IOV: bus number out of range
[   15.988036] ixgbe 0000:07:00.0 (unregistered net_device): Failed to enable PCI sriov: -12
[   16.162859] ixgbe 0000:07:00.1: SR-IOV: bus number out of range
[   16.164981] ixgbe 0000:07:00.1 (unregistered net_device): Failed to enable PCI sriov: -12
[   21.064691] BTRFS: has skinny extents

As you can see it seems i don't have enough resources.

It depends from machine, or it depends from some options in kernel compilation?

many Thanks

Link to post
Share on other sites

Can you share it?

I had a TS879 pro w/e3 1225 16g ram

I imported to Qnap's VM and I failed.

 

Anyone success to import DSM 6 to Qnap's VM?

 

 

Hi all,

anyone tryied to import VM into QNAP Virtualization Station?

Im getting this error: (0.00/100%)\\rqemu-img: Could not open /share/CACHEDEV1_DATA/VirtualPC/Syno6/DS3615xs/synoboot.vmdk: Invalid extent lines:RW 102400 VMFS synoboot.img 0# The Disk Data Base #DDBddb.adapterType = lsilogicddb.deletable = trueddb.encoding = UTF-8ddb.longContentID = 7e24a756b77e33e24ac940cc6ccf51e5ddb.thinProvisioned = 1ddb.uuid = 60 00 C2 9a ee da ca 33-df 5e 04 3f 80 55 f9 62ddb.virtualHWVersion = 10

 

When i create own virtual machine without importing and then try to start i get this:

(0x1) internal error: process exited while connecting to monitor: 2016-11-13T12:42:09.320176Z qemu-system-x86_64: -drive file=/share/CACHEDEV1_DATA/VirtualPC/Syno6/DS3615xs/synoboot.img,if=none,id=drive-ide0-0-0,format=qcow2,cache=writeback: Image is not in qcow2 format .

 

Image is not in qcow2 format?

 

Thanks for any suggestions, Vitek

 

EDIT: Figured it out...

First what is needed is to modify .vmx file, because VMware ESXi does not support HW version 12, just edit it to 11 or 10. Then there is no prolem to import it to ESXi and afterwards export OVF template. I exported it as OVA and imported do Qnap. If anyone is interrested i can share link with ova.

Link to post
Share on other sites
anyone has been tested that cpu with xpenology ? this is a china i7 1151 cpu, have a great spec and have a great price http://ali.pub/7quix

 

I am using i3 6320 with passmark score of 6025 at 50 W http://www.cpubenchmark.net/cpu.php?cpu ... 40+3.90GHz

and is awesome. I was too considered the 6400t for the low wattage but i afraid it will give a very close score but the clocks are slow.

 

If you get 6400t post your finding, sure it will work , but dunno on performance.

My use of the synology is mainly for Emby Server and media files.

 

Hope it helps

 

/wave

Link to post
Share on other sites
Hi, i'm running Jun's Loader 1.01 on a HP Microserver Gen8. I've noticed that hdd are always spinning, they don't go into hibernation. Could someone tell me if is this ok or i'm missing a step? On the power setting i set hibernation for sata to 10 minutes. I've resilio sync package installed but i tried stopping it with the same problem.

 

Does HDD hibernation works for you?

 

Thanks

 

Hi There

 

There are allot of services or packages that prevent hdd hibernation from occurring.

I also have a Gen8 but never saw my drives enter hibernation.

I have a real synology DS216J and it does hibernate the drives....but very rarely. Like once or twice a day maybe, sometimes not at all for 2 or 3 days.

 

So it depends very much on what services or packages you are using.

 

I found this on the Synology site which might help explain this :

 

https://www.synology.com/en-global/knowledgebase/DSM/tutorial/General/What_stops_my_Synology_NAS_from_entering_System_Hibernation

 

I have literally removed all packages and disabled all services, no difference. It's a pretty fresh install, too.

I installed ipkg and iotop to monitor what is accessing the drive, and I see at the top:

 

 
TID  PRIO  USER     DISK READ  DISK WRITE  SWAPIN     IO>    COMMAND
4491 be/3 root        0.00 B/s    3.90 K/s  0.00 %  0.60 % [jbd2/md0-8]
12830 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.04 % [kworker/1:2]
4679 be/4 root        0.00 B/s   15.61 K/s  0.00 %  0.00 % syslog-ng -F --worker-threads=

 

The top one, jbd2, is appearing up there every 2-3 seconds and disappears in the same second just to come again. This is fitting with the hdd led lighting up every few seconds, too.

After a quick search i found out it is a journaling block service for ext4, but what is causing this to appear every few seconds? Could that be the service constantly accessing the drive?

Or could it be this syslog-ng?

 

Edit:

 

Seems like it is constantly writing this into kern.log as well as messages:

2017-02-15T19:34:08+01:00 DS_Kevin kernel: [ 2253.772455] ACPI Error: [PGRT] Namespace lookup failure, AE_NOT_FOUND (20130328/psargs-359)
2017-02-15T19:34:08+01:00 DS_Kevin kernel: [ 2253.772459] ACPI Error: Method parse/execution failed [\_GPE._L6F] (Node ffff8801690b5ec0), AE_NOT_FOUND (20130328/psparse-537)
2017-02-15T19:34:08+01:00 DS_Kevin kernel: [ 2253.772465] ACPI Exception: AE_NOT_FOUND, while evaluating GPE method [_L6F] (20130328/evgpe-580)

These 3 lines come up several times a second, making the log files very big.

Looks to me like a BIOS problem, maybe I'll try to update it. I would really like to know if anyone knows what could cause this permanent errors.

Link to post
Share on other sites

Hi, All.

I have Baremetal Intel 5500PSL / 4x 2Tb onboard SATA / XPEnoboot 5.2-5967.1.

Try to upgrade to 6.0.2 loader. Make new boot flash USB, enter vid & pid, but do the big mistake: accidentally upload DSM_DS3615xs_15047.

Now, WebAssistant ask me again and againg: "Welcome back!" and show "Recover" button.

I'm try all other boot option in grub menu, but nothing happens.

What can I do now, that would not lose the information on the disks? :smile:

Link to post
Share on other sites
dont you have a spare hard disk or usb , where you can make a new boot?

deattach your disk first, create a new boot, and attach it again to be safe?

I'm try this variant: off server, deattach boot USB flash , write img again on this flash, attach flash, boot. Nothing.

Or you mean do not turn off server? Or I need another USB flash with another vid/pid?

Link to post
Share on other sites
Did somebody already try Jun's Loader / DSM 6.0.2 on the new Apollo Lake boards (J3455/J4205)? Several times I've been reading "it should work" in this discussion, but it seems to me nobody actually tried? A few pages back somebody mentioned it’s not booting and I’ve been reading about problems using Ubuntu on Apollo Lake boards. Just want to have a confirmation before making a mistake in buying, I prefer to have a WORKING J3710 board over a black screen Apollo Lake :smile:

 

Thanks!

J3455 works well...no problems. If you buy it, UPDATE BIOS right away. 1.2 version is stable. 1.0 was s*** and wasnt working at all.

Link to post
Share on other sites
This is not correct. Asrock J3455 is Working but the Network is very very slow! Network Chipset is Realtek RTL 8111GR.

 

Are you sure? I'm here at J3455 AS Rock. Had intel first added because of easier way to change Mac address (ethtools) but had to use the NIC for another project.

I'm here at maxed out speeds on that RTL 8111GR NIC. <- Not true ....

 

Not so maxed out indeed.. just verified with iPerf and it maxes about 75MB/s also more parallel tasks will be limited to about 75? Better to replace intel NIC?

Link to post
Share on other sites

Well I did some tests. I have here several NICs. There is no significant difference between the onboard Realtec 81111GR, intel Gigabit CT desktop adapter and HP NC 110T. All of them fluctuate between 75 / 90MBs with iperf. The onboard performs even better then the HPNC110T. From windows or OSX i get transferspeeds of about 110MBs based on SMB3. Quite okay! (I use all my disks as individual drives so no raid, all of them are "basic"). So for me there is no reason for a no buy of the j3455 except from turbo boost which would be a nice bonus if it wwas working. I enabled my onboard nic again :wink:

Link to post
Share on other sites

Any chance of having some extra drivers added? I'd need the Intel WiFi Link 5100/5300 drivers, even as a separate module would be nice! I believe the two use the same module, and possibly are even covered by the regular iwlwifi module if I'm not mistaken.

Link to post
Share on other sites
@Ziomalsky :

I could upgrade an ESXI to 6.1 with no problem (download from Synology site).

The underlying server is a Dell T130 (low end config).

I never use XPEnology on a barebone computer...

 

Thanks for the info. That is great news. I too run on ESXi (6.5 on r710 H200).

 

Please post back if you run into any issues. Thanks again.

Link to post
Share on other sites
@Ziomalsky :

I could upgrade an ESXI to 6.1 with no problem (download from Synology site).

The underlying server is a Dell T130 (low end config).

I never use XPEnology on a barebone computer...

 

 

Failed on VMware Workstation 12.0.1

 

After the 6.1 upgrade, the Web console say the harddisk is moved to DS3615xs and ask me to recover (loop)

Both upgrade and new install failed in the same way

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.