DSM 6.1.x Loader


Recommended Posts

On 18-9-2017 at 9:27 AM, reziel84 said:

hi guys

someone can help me? i have esx 6.5 with old 5.2 xpeno.  please can help me to migrate to 6.1 without loosing data? i have much moore than 2tb of file in raid1.....

please can contact me in private message and help me?

many thanks

 

Follow the steps in this tutorial. Worked for me. Only difference is that I'm using a baremetal but it should work for VM also. Got from 5.2 latest build all the way to DSM 6.1.3-15152 Update 4.

 

Link to post
Share on other sites

Hi guys,

I followed the migration tutorial and would like to share my experiences.

 

HW/SW: HP DL380 G6 ESXI 6.0

DSM 5.2 with LSI 2008 RAID Contoller in Passthrough Mode.

 

1. MAC/SN Modification of .img

2. Create new DSM 6.1 VM in VMWorkstation following  a youtube tutorial

3. Used VM Converter in order to copy the machine to esxi.

4. In DSM 5.2 VM I replaced 5.2 Bootloader .vmdk with 1.02b .vmdk

5. Started  DSM 5.2 VM with 1.02b Bootloader and started "Migration"

6. Migration finished with a crash of VM and esxi (bluescreen)

7. Changed OS version of migrated VM to Linux 3.x

8. Started migrated DSM 6.1 VM to find out that it's destroyed!

 

from now it's about troubleshooting:

 

9.   I started the VM from step 3 and installed a configuration.dss without the shared folders from my DSM 5.2

10. Created 4 vmxnet3 NIC's and the RAID Controller (PCI Device)

11. Started the DSM 6.1 VM and repaired volumes.

 

RESULT: NO DATA LOST!

 

BUT:

1. ONLY 1 NIC was working. I couldn't ping from a remote machine NIC 2,3,4. I was able to ping on the DSM itself and the configuration looked good.

2. JUMBO Frames did not work.

3. I removed  the 4 NIC's and replaced them with 4 E1000 NIC's

 

RESULT: All adapters are working. JUMBO Frames still not working

 

I couldn't find anything about compatibility of VM NIC types yet. Is anybody aware of bestpractices?

I would like to use the vmxnet3 adapter witth MTU 9000 again, like in the DSM 5.2!

 

Link to post
Share on other sites
5 hours ago, roylee01 said:

Is it safe to install the latest DSM 6.1.3-15152 Update 5? 

If you're using DS3615xs then Update 5 seems to be ok so far yes. However several people have reported issues with DS3617xs & Update 4/5.

Edited by Dfds
Link to post
Share on other sites

I've done a test with a DSM 6.1.3-15152 with out a Passthrough Device. In this VM I've used 4 VMXNET3 NIC's. All NIC's are working , but without JUMBO Frames.

 I used the 3615xs image!

 

Is anybody using  DSM 6.1.3-15152 3615xs with Passthrough devices and  VMXNET3 NIC ?

Link to post
Share on other sites
57 minutes ago, boosterbosch said:

Hi all,

 

I'm running xpenology baremetal on an HP gen8 microserver using Jun's v1.01 bootloader and dsm version 6.0.2.8451 Update 9.

 

Can I by upgrading to the v1.02b bootloader update DSM to version 6.0.3.8754?

Do not upgrade to 6.0.3.

With the v1.02b loader you are able to Upgrade to version 6.1.X.

  • Like 1
Link to post
Share on other sites

Hello,

 

thank you for sharing this peace of power with mankind. I confirm Loader 1.02b working on AMD AM1 5350 with ASRock AM1B-ITX 8GB RAM, first SATA drive is here the Sata 1 of ASMedia extension chip from the board and not AMD Sata1 from the 5350 chip. Since 24 hours no problems so far.

I keep running VM DSM5.0 4493 with phpVirtualBox on DSM 6.1.1. To my surprise the phpVirtualBox recognise the true AMD 5350 itself.

 

I love this project and visit since DSM4.3 of t.

02-10-2017 20-57-20.png

Link to post
Share on other sites

if you have some time and like experiments, there might be a way to use the amd sata, as it is eperimental its only suggested to try with a extra usb stick and one or two empty disks (unplug anthing "productive" before testing)

we need one/some guinea pig's/lab rats, so it depends if you are more like brain or pinky ... (https://en.wikipedia.org/wiki/Pinky_and_the_Brain)

:-)))

 

 

Link to post
Share on other sites
On ‎10‎/‎2‎/‎2017 at 1:36 PM, manalishit said:

I've done a test with a DSM 6.1.3-15152 with out a Passthrough Device. In this VM I've used 4 VMXNET3 NIC's. All NIC's are working , but without JUMBO Frames.

 I used the 3615xs image!

 

Is anybody using  DSM 6.1.3-15152 3615xs with Passthrough devices and  VMXNET3 NIC ?

I've investigated this issue and found out that it is not related to vmxnet3 adapters. These adapters are working well including LAG and MTU up to 3050.

 

It seems that the NIC-LAN mapping in the VM is changing, when using a passthrough device.

 

In DSM 5.2-3615xs with a passthrough device it was

NIC1-LAN1, NIC2-LAN2, NIC3-LAN3, NIC4-LAN4

 

In DSM 6.1.3-15152-3615xs without a passthrough device it is

NIC1-LAN1, NIC2-LAN2, NIC3-LAN3, NIC4-LAN4

 

In DSM 6.1.3-15152-3615xs with a passthrough device it is

NIC1-LAN1, NIC2-LAN4, NIC3-LAN2, NIC4-LAN3

 

Since I'm using different VLAN's I have lost the connection to the adapters.

 

Can someone confirm this behavior?

NIC.png

LAN.png

Link to post
Share on other sites

Hello, 

I would like to know if there is a tutorial on woe to install the latest 1.02b loader and DSM 6.1.3 on a VMware esxi environment.

I've done a lot of research but noting I have tried seems to work.

Please, let me know if there is a guide somewhere and a special download link for the files specifically for esxi.

I did find a VM image but unfortunately I am on esxi 6.0 and the link VM was for 6.5.

I really appreciate your help and keep up with the good work!!

 

Zeek

 

Link to post
Share on other sites
On ‎10‎/‎2‎/‎2017 at 10:04 AM, manalishit said:

1. MAC/SN Modification of .img

2. Create new DSM 6.1 VM in VMWorkstation following  a youtube tutorial

3. Used VM Converter in order to copy the machine to esxi.

4. In DSM 5.2 VM I replaced 5.2 Bootloader .vmdk with 1.02b .vmdk

5. Started  DSM 5.2 VM with 1.02b Bootloader and started "Migration"

 

Link to post
Share on other sites
6 hours ago, getto05 said:

synology  assistant does not find the loader. I tried the network card tg-3468 - r8169.ko, the native VIA Rhine II network card also does not work. 


extra.lzma also did not help.

 

who can screw the driver?

 

the r8168.ko might be the better choice, i did two extra versions of the v3 extra.lzma for that purpose, so have a look here

 

Link to post
Share on other sites
On 10/2/2017 at 1:45 AM, OBWANDO said:

I had a question about expanding drives.

 

So I have a supermicro board with a LSI SAS9207-8i on it, and it has 8 internal SATA ports. Im running Jun 1.02b, and 6.13 R3.

I have had 6 2TB drives connected to it and 1 SSD cache for about a year and one failed, so I figured I'd add 2 more and replace the 3rd one with 3 TB drives.

Problem #1 - When I replaced the 2TB with a 3TB drive, it repaired, but didnt expand the set to the larger size.

 

thats only for SHR mode, if its in "normal" raid mode it will not work

if its shr(1, like one redundancy disk) its only morking if you have at least two disks with additional space usualy its like you have 6 x 2TB disks in shr1 (aka raid5), you replace 2 disks with 3TB, then the shr1 will be like a raid5  with 2TB from every disk and the 2 x 1TB that is unused will be a raid 1 consiting of 2x1TB so 1TB usable, shr will then "glue" it together with LVM and extend the file system (at least that what i think how shr works)

so if you only have/see one 3TB drive only 1TB without redundancy is availible and so nothing to offer for extension

 

On 10/2/2017 at 1:45 AM, OBWANDO said:

Problem #2 - When I added the 2 drives, they appear as eSATA disks.

If i do a quick dmesg it shows all 8 drives as SCSI drives as 0-7 (example: scsi 6:0:7:0: qdepth(32), tagged(1), simple(0), ordered(0), scsi_level(7), cmd_que(1))

 

There are 4 USB3 ports and 2 controllers in the system (on board has 6, LSI has 8).

I changed the synoinfo.conf to esataportcfg="0x0000", usbportcfg="0x0400", internalportcfg="0x00FF"

 

as you have 6 + 8 = 14 ports  your internalportcfg hast to be

in bits: 11 1111 1111 1111 = 3FFF

and usb (4xusb)  11 1100 0000 0000 0000 = 3C000

 

 

 

On 10/2/2017 at 1:45 AM, OBWANDO said:

I was running my grub.cfg with SataPortMap=81 (which recognizes 6 drives and 1 ssd) and changed it to SataPortMap=86

 

if you set sata port map the it should be as the ports are on the pcie devices so = 68, as 6 onboard and after this 8 pors fom lsi

usualy you dont have to set it, i guess you problem with sataportmap came from the wrong internalportcfg

 

 

 

Link to post
Share on other sites

Dear Synology friends, 

 

I am upgrading from a DS212+ to a DS916+ Braswell x86 64
On my DS212+ ARM I have running HDHumeRun Expand + 
TVHeadend + Oscam . I will like to have the same configuration 
on the DS916+ Braswell x86 64  Any body know a link to 
download this list_smargo-1.20-unstable_svn11279-x86_64
for synology Braswell x86 64 or have one to share Please? 

Thanks in advance.

 

Kind regards,
Negrito

Link to post
Share on other sites
If you're using DS3615xs then Update 5 seems to be ok so far yes. However several people have reported issues with DS3617xs & Update 4/5.


No probs here so far on ds3617 and update 5 on esxi 6

Gesendet von meinem Z2 Plus mit Tapatalk

Link to post
Share on other sites
On 9/2/2017 at 9:49 PM, emkookmer said:

i know what I did wrong, and it's a read facepalm.....

anyway i got a little bit further, it seems my logical drive (smart array P410i) is not recognized. my guess would be that the drivers are not loaded, but is should be supported:

I even added Polanskiman's Extra.lzma custom ramdisk , but still no luck as it doesn't contain hpsa.ko

 

How do I enabled these drivers.

 

 

 

The HP Smart Array P410i force you to create a raid array/primary partition, with this you will not be able to install XPEnology.

 

I've replaced the HP smart array 410 controller with a  LSI SAS 9207-8i (SKU : LSI00302 | EAN : 0830343006892 )
 
with this i'm able to access my drives now.

Link to post
Share on other sites
6 hours ago, bartjuu said:

Guys, any progress on Hyper-V support? Or already supported?

 

the method how juns loader (the only way availible for dsm 6.1) work is to use the original kernel and patch (kind of invisible for dsm) on the fly to make it work without synology hardware, so there is no known way of making/compiling a new kernel for runnig dsm at the moment

at least i have not read here that anyone tryed to build a new kernel and tryed to use it with or wihtout jun's loader - with the protections synology integrated in dsm it might be impossible to replce the kernel delivered with dsm in the pat file

 

as hyper-v and amd (specific support beside x64) support needs a new kernel with build in support for this ... there is now way i can see how this will be done in a forseeable future (atm some amd processors work, other might not, hyper-v does not work at all)

 

if someone comes up with a methode to use a newly compiled kernel with dsm 6.1 it might be possible to build a kernel with hyper-v support but as long as the live patching and the original kernel is used it will not happen (if someone knows more dont hesitate to correct my words)

 

Link to post
Share on other sites
34 minutes ago, emkookmer said:

 

The HP Smart Array P410i force you to create a raid array/primary partition, with this you will not be able to install XPEnology.

 

I've replaced the HP smart array 410 controller with a  LSI SAS 9207-8i (SKU : LSI00302 | EAN : 0830343006892 )
 
with this i'm able to access my drives now.

 

its not about the array creation its simply that there is no working driver for hpsa controllers availible (for dsm 6.1 we tryed the kernel build in and the open source driver both did not work so no support for this controllers), if your network or storage controller has no driver in synologys dsm itself or in the extra.lzma that you load with jun's loader - no xpenology

the safest way for prolonged working system is to use hardware that is supported in the original dsm from synology (kernel modules provided by synology), that way you are not depending on drivers jun or someone else has build

 

Link to post
Share on other sites
56 minutes ago, IG-88 said:

 

its not about the array creation its simply that there is no working driver for hpsa controllers availible (for dsm 6.1 we tryed the kernel build in and the open source driver both did not work so no support for this controllers), if your network or storage controller has no driver in synologys dsm itself or in the extra.lzma that you load with jun's loader - no xpenology

the safest way for prolonged working system is to use hardware that is supported in the original dsm from synology (kernel modules provided by synology), that way you are not depending on drivers jun or someone else has build

 

this is a little bit true, but with the extra.lzma that you provided the hard drives where detected, but could not be formatted.

This was due to the hardware raid controller (P410i) forcing to use a raid configuration.

 

I've read up on the P410i and it turns out that other systems (FreeNAS filesystem ZFS) have had the same problems.

 

anyway  i just replaced the controller with a supported one and i'm set to go now. :grin:

Link to post
Share on other sites
On 10/3/2017 at 10:24 PM, zeekworld said:

Hello, 

I would like to know if there is a tutorial on woe to install the latest 1.02b loader and DSM 6.1.3 on a VMware esxi environment.

I've done a lot of research but noting I have tried seems to work.

Please, let me know if there is a guide somewhere and a special download link for the files specifically for esxi.

I did find a VM image but unfortunately I am on esxi 6.0 and the link VM was for 6.5.

I really appreciate your help and keep up with the good work!!

 

Zeek

 

I have run the latest XPEnology DSM/bootloader in ESXi with no problems. I just made a regular USB stick for installation and passed it through to the VM machine, then did a regular "bare metal" install of it. Just set the VM machine to boot into bios (UEFI) (and enable EFI), then in the virtual UEFI set the USB as boot device.
Any particular problems you have? Specific errors?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.