DSM 6.1.x Loader


Recommended Posts

anyone got wake on lan working? I enabled it in the bios and in synology, but no success.

 

Should the original mac address work?

 

Have you tried using the old shutdown fix method? I haven't got that far yet it's on my todo list.

 

 

For now I'm calling it quits on that and moving forward on building my actual shr ext4 volume that I will use as a destination hyper backup machine. Anyone have a few quick words on if ext4 or btrfs matters for this purpose? There is a lot of conflicting reports on the net, and at the end of the day how much will it matter?

 

As I understand it btrfs has good data integrity checks which seems like a major advantage in a data storage and backup environment where bitrot is a potential issue. ext4 doesn't offer that layer of checking and is therefore less reliable with respect to data integrity. I haven't used anything with btrfs so I don't know how it's implemented in a real world environment? I assume the core features of btrfs are usable so there are snapshot, deduplication and cloning options to name a few benefits. The big issue seems to be the limitation of raid system support and in our case shr and the advantages that has for mixed drive support.

 

I think the topic needs a thread in its own right because it's going to be a decision we all face now that we can make use of DSM6. Many of us have a mishmash of drives so retaining shr would be an advantage. I was going to rebuild my systems with fresh installs of DSM6 but now you have got me rethinking that idea. :???:

 

Thanks for the info! Yeah I knew about the bitrot prevention (something I have personally never seen), but haven't ever heard many hard facts about the deduplication and cloning options, just a lot of either "btrfs is the worst, doesn't do what it says and is slower" or "you are ignorant and irresponsible if you are using a file system other that btrfs."

 

Is there anything that ties this installation directly to the 3615xs aside from the model number? I haven't tried changing that but wasn't sure if you could swap that out in the grub.cfg and download a pat for a different model. Obviously there are other issues with sn and mac addresses for quickconnect. But it would be awesome to just get a btrfs volume created, then migrate that to the 3615xs that seems to be working great.

 

To be honest my knowledge is pretty limited on the subject. Like you I have heard good and bad things about it. Wendal of Tech Syndicate fame seems quite impressed by it and he is clued up on such things. Until you put it through its paces for your use case it will be hard to judge imho. We need a thread where the pros and cons can be trashed out based on peoples experience using DSM 6. Check this out >

part one is worth a watch and it would make sense to watch them in order.
Link to post
Share on other sites

Hi all

 

I have tried with sata 4 etc

 

But there is a error message it ells me HDD 3 + 4 has erros and the sata ports are disabled.

Before there was installed DSM 5967.1

 

Here is the Grub.cfg

 

 

 

serial --port=0x3F8 --speed=115200

terminal_input serial console

terminal_output serial console

set default='0'

set timeout='2'

set fallback='0'

 

menuentry 'Synology DS3615xs' --class os {

insmod fat

linux /image/DS3615xs/zImage root=/dev/md0 syno_hdd_powerup_seq=0 netif_num=1 HddHotplug=0 SataPortMap=4 syno_hw_version=DS3615xs vender_format_version=2 vid=0x090C pid=0x1000 console=ttyS0,115200n8 sn=C7LWN09761 mac1=0011322CA785 withefi elevator=your_magic_elevator quiet

initrd /image/DS3615xs/ramdisk.lzma

}

 

 

Loader

 

-cda1-gen8boot.img

-junuefibios

 

With both the tell me HDD 3+4 are corrupted mybe i have to format all HDDS?

 

Thank you for your help.

BR

 

Michael

Link to post
Share on other sites
Thanks for the info! Yeah I knew about the bitrot prevention (something I have personally never seen), but haven't ever heard many hard facts about the deduplication and cloning options, just a lot of either "btrfs is the worst, doesn't do what it says and is slower" or "you are ignorant and irresponsible if you are using a file system other that btrfs."

 

Is there anything that ties this installation directly to the 3615xs aside from the model number? I haven't tried changing that but wasn't sure if you could swap that out in the grub.cfg and download a pat for a different model. Obviously there are other issues with sn and mac addresses for quickconnect. But it would be awesome to just get a btrfs volume created, then migrate that to the 3615xs that seems to be working great.

 

Jun had to mimic certain missing PCI functions within the patcher, or there abouts, that are required for the boot loader to run. As a result, this loader is hard coded for the DS3615xs. To access another model, you have to determine what pci functions are not covered in the loader and edit them in to the module he created; just chaning the grub data doesn't work... I know the module name but I still haven't found the module itself as I wanted to look at enabling a rackstation with LSI drivers!

 

The lack of SHR is something that I would miss, and despite BTRFS containing good work, I'd rather have SHR2 then fork out for 8 4tb drives for example!

Link to post
Share on other sites
Hi all

 

I have tried with sata 4 etc

 

But there is a error message it ells me HDD 3 + 4 has erros and the sata ports are disabled.

Before there was installed DSM 5967.1

 

Here is the Grub.cfg

 

 

 

serial --port=0x3F8 --speed=115200

terminal_input serial console

terminal_output serial console

set default='0'

set timeout='2'

set fallback='0'

 

menuentry 'Synology DS3615xs' --class os {

insmod fat

linux /image/DS3615xs/zImage root=/dev/md0 syno_hdd_powerup_seq=0 netif_num=1 HddHotplug=0 SataPortMap=4 syno_hw_version=DS3615xs vender_format_version=2 vid=0x090C pid=0x1000 console=ttyS0,115200n8 sn=C7LWN09761 mac1=0011322CA785 withefi elevator=your_magic_elevator quiet

initrd /image/DS3615xs/ramdisk.lzma

}

 

 

Loader

 

-cda1-gen8boot.img

-junuefibios

 

With both the tell me HDD 3+4 are corrupted mybe i have to format all HDDS?

 

Thank you for your help.

BR

 

Michael

 

i had the same error.

you have search in synology assistant for your xpenology server.

wenn it is good you see it is migratable

right click on it and choose for install, upload the pat file en let it do his job that have work for me.

Link to post
Share on other sites
I think my N40L uses a Broadcom BCM5723 based driver for the onboard NC107i and I can't see it on the network after the current version of the loader boots. So it looks like it's not supported right now. Hopefully there will be more drivers added in the not so distant future.

 

Can you boot a linux (ubuntu for ex) and give me the name of the module used by your network card ? I will build it :smile:.

 

Hi Setunakawa,

 

I used mint command lspci -v and the reported kernel driver and module in use is reported as "tg3". If you need more info let me know and if you give me the commands you want me to run that would help I'm not great with linux command line. :oops:

 

Thanks for taking a look it would be nice to get the Gen7's on to DSM6. Could you also add Jun's latest romdisk file to your build to make it easier for people to use?

 

Thanks in advance.

Hello !

 

Just to report I check on my HP N54L, it is the same as yours :

NAS_N54L> readlink /sys/class/net/eth0/device/driver

../../../../bus/pci/drivers/tg3

 

Kernel driver in use: tg3

 

I would be happy to try DSM 6 on my N54L... I don't know if I have to wait for drivers or if I can/should try with esxi version.

 

Thank you

Link to post
Share on other sites
Hi all

 

I have tried with sata 4 etc

 

But there is a error message it ells me HDD 3 + 4 has erros and the sata ports are disabled.

Before there was installed DSM 5967.1

 

Here is the Grub.cfg

[spoiler=]serial --port=0x3F8 --speed=115200

terminal_input serial console

terminal_output serial console

set default='0'

set timeout='2'

set fallback='0'

 

menuentry 'Synology DS3615xs' --class os {

insmod fat

linux /image/DS3615xs/zImage root=/dev/md0 syno_hdd_powerup_seq=0 netif_num=1 HddHotplug=0 SataPortMap=4 syno_hw_version=DS3615xs vender_format_version=2 vid=0xXXXX pid=0xXXXX console=ttyS0,115200n8 sn=xxxx mac1=xxxx withefi elevator=your_magic_elevator quiet

initrd /image/DS3615xs/ramdisk.lzma

}

 

Loader

 

-cda1-gen8boot.img

-junuefibios

 

With both the tell me HDD 3+4 are corrupted mybe i have to format all HDDS?

 

Thank you for your help.

BR

 

Michael

 

I haven't tried the gen8boot img but as I understand it's functional and there is nothing wrong with your grub that stands out. It's probably not a good idea to publish the values you're using in a public forum by the way. You should probably regenerate the Serial and Mac if the unit connects to the web and synology's website, plus someone else could start using your serial and mac.

 

The junuefibios image needs the updated patched rom file that's in jun's bear metal EFI img.

 

I used junuefibios.img + Jun's rom patch file to build a fresh server using an old 250GB hd which had a test install of the latest DSM 5.2.x including the latest minor updates. I went for migration and it completed without any issues. No formatting was required! Then I reinserted my live disks and migrated from 5.2.x to 6.x, again with no issues or reformatting.

 

I'm not sure why your experience is different?

 

I didn't use the SataPortMap=x and I didn't change the console parameters. I set-up the console emulation in the Gen8 bios. The only issue I had was the date time corrupted in the bios on reboot. I rebooted and fixed the bios time/date and everything has been sweet ever since.

 

I just checked the md5 of my local copy of the pat file (the one I installed from) against a fresh download from Synology and they matched.

 

@Orphée

 

It depends on whether you want a baremetal or virtual set-up? I don't think you will need to wait too long to find out if the new img file works once Setsunakawa works his magic.

 

Edit:

 

Afaik all the Gen7's use the same Nic hardware.

 

@setsunakawa

 

The suspense is killing me! :lol:

Link to post
Share on other sites
Anyone had success installing on hardware without AHCI so we can reuse old pc (4/5+ years old) as we did with xpenoboot 5.2?

 

I've tried 4 different PC that hasn't AHCI setting in bios and The installer say "no disk installed in your ds3615xs"

I would be glad to success to install on the oldest Intel D525 Atom Thecus NAS.

No any error in this few days, also can update 6.0.2 8451 update1.

Last time i try to install on the socket 1155 PC also ok.

Link to post
Share on other sites
Anyone had success installing on hardware without AHCI so we can reuse old pc (4/5+ years old) as we did with xpenoboot 5.2?

 

I've tried 4 different PC that hasn't AHCI setting in bios and The installer say "no disk installed in your ds3615xs"

I would be glad to success to install on the oldest Intel D525 Atom Thecus NAS.

No any error in this few days, also can update 6.0.2 8451 update1.

Last time i try to install on the socket 1155 PC also ok.

Link to post
Share on other sites
i've added tg3 and mlx4 drivers with last jun's version :

https://mega.nz/#!J1UG1SxY!lkZ67BHhbr8b ... p9FgpqMs44

It's still hybrid efi & bios :smile:.

 

Sorry for the size, I forgot to cleanup FAT32...

 

Thanks for the speedy delivery. :cool:

 

Sadly it hasn't worked for me the machine still isn't joining my network? :shock:

Edited by Guest
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.