DSM 6.1.x Loader


Recommended Posts

1 minute ago, Dfds said:

Ok, I've just checked my settings & SataPortMap=1 & my 5 WD Black disks are seen by DSM Ok, so maybe try that.

you got a n54l to ?

 

Edit : just looked in my grub and its also SataPortMap=1 :(

Edited by wiruzdk
Link to post
Share on other sites
1 minute ago, maxime said:

Please, can you explain it better? Thank you so much!

 

Not really sure what more there is to explain, the setting I was referring to is this line in grub.cfg.

 

set sata_args='sata_uid=1 sata_pcislot=5 synoboot_satadom=1 DiskIdxMap=0C SataPortMap=1 SasIdxMap=0'
 

Link to post
Share on other sites
1 minute ago, Dfds said:

Not really sure what more there is to explain, the setting I was referring to is this line in grub.cfg.

 

set sata_args='sata_uid=1 sata_pcislot=5 synoboot_satadom=1 DiskIdxMap=0C SataPortMap=1 SasIdxMap=0'
 

Perfect. Thanks

 

Link to post
Share on other sites
1 minute ago, Dfds said:

Not really sure what more there is to explain, the setting I was referring to is this line in grub.cfg.

 

set sata_args='sata_uid=1 sata_pcislot=5 synoboot_satadom=1 DiskIdxMap=0C SataPortMap=1 SasIdxMap=0'
 

thats wierd i have the same settings the drive just wont show up :(

Link to post
Share on other sites

 

 

On 7/15/2017 at 10:26 PM, CrazyCreator said:

 

 

how do a hard reset? or you mean a reboot from/with iLO Web-GUI?

 

On 7/15/2017 at 3:43 PM, ikia said:

Hi Hooligan :smile:

 

Can you tell me how did you do Hard Reset on HP Gen8? 

 

Regards

Igor

rebooted from iLO i mean. its not hard reset but years with smartphones broke me ;) 

Link to post
Share on other sites

Updated from 6.0.1 up8 to 6.1.3 on esxi, 100%, no problem, everything is working as espected.

 

just one small detail now on dsm the boot disk (synoboot.vmdk + synoboot.img), shows as disk on dsm, is thare any way to hide this?

Link to post
Share on other sites
1 hour ago, Dfds said:

You could try flashing the bios again, this appears to be a newer version:

 

http://www.nathanielperez.us/blog/hp-proliant-n40l-bios-modification-guide

 

or getting a 2 port pcie sata card

just tried flashing the modded bios stil have the same problem.. and i have just tried installing a new HDD and reinstall DSM_DS3615xs_8451 and stil same problem cant find disk 5

Link to post
Share on other sites

i finally figured it out had to set

 

Sata ID Combined Mode to Disabled

Enable OnChip Sata Channel, OnChip IDE Type to IDE

SATA ESP and SATA Power on all PORT to Enabled.

 

and now its working with 5 drives

 

thank you.

 

Link to post
Share on other sites
1 hour ago, wiruzdk said:

i finally figured it out had to set

 

Sata ID Combined Mode to Disabled

Enable OnChip Sata Channel, OnChip IDE Type to IDE

SATA ESP and SATA Power on all PORT to Enabled.

 

and now its working with 5 drives

 

thank you.

 

Glad you got it sorted.

Link to post
Share on other sites
16 minutes ago, Dfds said:

Glad you got it sorted.

there is just one last thing it is being recognized as disk 6 and the dsm says 11 disk available

 

i would like dsm to have 5 disk available and the 5 disk being recognized as disk 5 and not disk 6

 

i think it has something to do with sataportmap i have tried with 5 and 1 but both recognized it as disk 6

Link to post
Share on other sites

Before going to my production system I wanted to test it with an old drive I still had lying around. It has an older version of DSM installed, however I forgot the password on it..... How can I reset the password with 6.1? Anybody have an idea?

 

Have a Q1900. I have successfully uploaded the new DSM version and tried to migrate, however as mentioned stuck on logging into the system...

Link to post
Share on other sites
11 hours ago, m3rlinux said:

Yep! I mean reboot from iLO! ;)

 

8 hours ago, Hooligan said:

 

 

 

rebooted from iLO i mean. its not hard reset but years with smartphones broke me ;) 

 

i install without a reboot from iLO ... only the normal reboot after put the update button.

Link to post
Share on other sites

Is it possible/wise to update in one go from 5.2 to 6.1. just tested it on a spare drive with 5.2 on it, and all went smooth, however before jumping to production two questions:

 

1. Will I retain the SHR setup? in the new 6.1 it is no longer possible te select SHR (unless you change the settings through synoinfo.conf

2. can I jump in one go from 5.2 to 6.1? or is it wise to install 6.02 first?

 

thanks

 

on a Q1900 with SHR and 4 HDD's

Link to post
Share on other sites
1 hour ago, pwvandeursen said:

Is it possible/wise to update in one go from 5.2 to 6.1. just tested it on a spare drive with 5.2 on it, and all went smooth, however before jumping to production two questions:

 

1. Will I retain the SHR setup? in the new 6.1 it is no longer possible te select SHR (unless you change the settings through synoinfo.conf

2. can I jump in one go from 5.2 to 6.1? or is it wise to install 6.02 first?

 

thanks

 

on a Q1900 with SHR and 4 HDD's

 

I believe SHR is only enabled on consumer units by default (like the DS916p). As you said you can enable SHR on enterprise class devices but it's something which has to be done via SSH.

 

Also others have had success with migrating their existing SHR array to a loader with SHR disabled, it just means you cannot create any more SHR arrays without editing your config first. The worst that will happen is DSM will just not mount your volume, though SHR is only disabled via the GUI not system-level. I tested this myself in VMware a while ago and it worked for me (but I went from 6.0.2 to 6.1.1).

Edited by filippo333
  • Like 1
Link to post
Share on other sites

Thanks Filippo333 for the clear answer. So what you say is if I have a SHR, it will retain that configuration, eventhough a fresh system can not select SHR as a RAID option. It used to be an option as I started from scratch on the DS3615xs, and built the SHR on that with 4 drive (2x3tb and 2 x6TB so don't want to go to RAID 5 as that will cost 3TB of storage). Since DSM 6, it can no longer be selected as option in the DS3615xs, possibly still on the more consumer focused units indeed.

 

Would be great to hear some feedback from others on the update route (5.2->6.1 or 5.2->6.02->6.1)

Link to post
Share on other sites
55 minutes ago, pwvandeursen said:

Thanks Filippo333 for the clear answer. So what you say is if I have a SHR, it will retain that configuration, eventhough a fresh system can not select SHR as a RAID option. It used to be an option as I started from scratch on the DS3615xs, and built the SHR on that with 4 drive (2x3tb and 2 x6TB so don't want to go to RAID 5 as that will cost 3TB of storage). Since DSM 6, it can no longer be selected as option in the DS3615xs, possibly still on the more consumer focused units indeed.

 

Would be great to hear some feedback from others on the update route (5.2->6.1 or 5.2->6.02->6.1)

 

That's correct SHR normally continues working when migrated to a loader which doesn't officially support it OOTB :smile:

Obviously I do strongly recommend editing the config file on the DS3615xs loader if you want to continue using SHR.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.