jun

DSM 6.1.x Loader

Recommended Posts

My "live" system currently runs DSM 6.0.2-8451 update 9 via ESX 6.5. This is with Jun's v1.01 loader for DS3615xs.

My data drives are connected to my LSI2008 based HBA flashed to IT mode and passed through to this VM.

 

Yesterday I created another VM but this time based on the DS3617xs using Jun's v1.02a2 and created one virtual disk as a test. It is running DSM 6.1.1-15101 update 2. So far so good. No issues. No time bomb errors. Installed some apps as a test. Will try this for a week or two to make sure there are no issues and then create a new VM with the same settings and pass my drives through.

 

Currently on my "live" system, volume1 is setup as SHR. should this migrate ok to the new 6.1.1 based VM?

 

Cheers,

James

 

 

Sent from my iPad using Tapatalk Pro

 

I dont advise to migrate to DSM 6.1.1. There is problem with migration on esxi vm. Before you do that with live system do some tests with migration first. As far as i know all users doing migration on esxi reported brick system, including me.

Share this post


Link to post
Share on other sites

As far as i know there is n problem with clean install. My test vm with DSM 6.1.1 on esxi 6.0 worked with no problem few weeks. (jun's loader 1.02a2, ds3617xs)

Share this post


Link to post
Share on other sites
I used Migration with Junes 1.02 Loader (network worked)

but after reboot the network does not come up!?

i found out there is a difference between normal boot and install boot

 

with "loadlinux 3615 usb mfg" the network works

with the normal boot " loadlinux 3615 usb" the network does not come up

 

Have you had any luck fixing it? Booting with mfg forces a reinstall, so I'm not sure if that would work on the long term.

Share this post


Link to post
Share on other sites

I have been on Jun's 1.01 running with DSM 6.0.2 for ds3615xs for quite some time, runs stable and faultless for months.

I have been notified a new update of DSM 6.0.3 is avaliable for weeks but reluctant to update until just now. I have always been able to update using the updater in control panel over the past few updates. But this time my dsm would not boot up. The local IP is changed and I got given the option to recover. Not hard to guess the recovery didn't work out.

 

So I am going to try upgrading to Jun's v1.02a2 and hopefully by installing the new DSM 6.1, it will work again.

 

One technical issue though. As the hard drives I am using is the main production drives with my important data, I have a thought of first unplug all the drives and install the DSM 6.1 with a spare hard drive. That should classify as a clean install, then I will plug back in my production drives; in theory I should then be able to "migrate" or "re-habit" my data back to the new DSM 6.1. Can anyone confirm this will work?? Will I be able to then transfer the DSM 6.1 settings and main system files back to my production drives from the spare, optimally unplug the spare drive to free up the bay again???

 

Kind of nervous because I didn't expect upgrading to 6.0.3 would go wrong, even I knew migrating to 6.1 would be more likely to fail and avoided it. So any help and advice would be deeply appreciated. Thank you

Share this post


Link to post
Share on other sites

To add in some background, I am running ESXi 6 on a HP Microserver Gen8, with the built-in B120 controller run in ACHI mode and passthrough to the DSM virtual machine. Which means my production Hard Drives should technically plugged in and formatted just like a normal Synology NAS would be.

Share this post


Link to post
Share on other sites

you should be careful about the 6.1 version

6.1_15047 is ok but its not the newest anymore (no further updates), the actual 6.1.1_15101 uses the same kernel, means same botloader as for 15047 works (aka jun 1.0.2a/a2), updating from a older version usualy does'nt work, clean istall does

so for you there ist no perfect solution, 6.1 keeps config but its already outdated, 6.1.1 needs a little bit more work to get a clean install

Share this post


Link to post
Share on other sites

Thank you IG-88 for your response. I am proceeding with my plan at the moment. Unfortunately I hit the wall already as we speak. I encountered the Error 13, which I expereienced previously when testing Jun's 1.02a DS3615xs loader on a separate testing vm. I wasn't running a passthrough back then so I thought the error was caused by that. Now with passthrough error 13 remains, that is tricky. Will need to see what I can do to work it.

Share this post


Link to post
Share on other sites

So I just saw the red text on the updated tutorial regarding shouldn't update to 6.0.3 on v1.01 when looking for solution to my situation. Damn. I wish any updated or important notes was made clear in the forum, like a specific headline in big text or a prompt note or something. Not to blame anyone but this forum is bloated with questions of outdated DSM5 and query of different issue, it is just so difficult to aware of any update, not to mention any important notice.

Share this post


Link to post
Share on other sites

as long as you dont know that an update is working it's red flaged by default you newer if sysnology has done soemthing like bringing in code to prevent xpenology from using the synology images and updates

and a forum is not the best form, a wiki might be more up to it

maybe the englsih section should be split up into areas for 5.0, 5.5, 6,0 and 6.1?

Share this post


Link to post
Share on other sites

I managed to install DSM 6.1.1 (and later Update 2) on ESXI 6.5 on my Gen8.

 

This is the procedure i followed:

- Dismounted all the RDM Drives for security reason

- Created a new VM from scratch with 2 disks, the first from Jun (1.02a for ds3615xs) boot image, the second empty for the OS (20GB)

- Installed the latest version and run the update to reach the latest version (DSM 6.1.1-15101 Update 2)

- Hotmounted the RDM disks in the VM (that were correctly recognized but unusable)

- Created the Raid Group and the volume for the OS disk (the 20GB one) in order to have the same Raid Group # for the 4 data disks

- Rebooted the VM

- The RDM disks were correctly mounted with no further work, their Raid Group and Volume were preserved.

- Reinstalled all the packages and the backup of their configurations

 

CeNmPof.jpg

Share this post


Link to post
Share on other sites

is anyone able to get juns 1.02 loader to work with a mediasmart server?. the only one that works for me is 1.00 hybrid. the other arcao one thats 100MB doesnt cut it. but the uefi hybrid boot one that is 200MB works for 6.02 but after update 9 the system is done for.. will there be any verbose output like the other bootloader which was pretty helpful in troubleshooting, if init.d is stuck

Share this post


Link to post
Share on other sites
So I just saw the red text on the updated tutorial regarding shouldn't update to 6.0.3 on v1.01 when looking for solution to my situation. Damn. I wish any updated or important notes was made clear in the forum, like a specific headline in big text or a prompt note or something. Not to blame anyone but this forum is bloated with questions of outdated DSM5 and query of different issue, it is just so difficult to aware of any update, not to mention any important notice.

 

 

bingo!!!!!!!!!!!!!! you said what ive been saying for 3 years!. when you want help or to read something valid to a problem your having its not here. Correct again this forum is beyond bloated and 4 years of bloated goodness. No structure no decent enough wiki guides. (polanskiman has stepped up to the plate but its going to require a good couple of months of nonstop updates to make this a better place than what it is) Those that had good guides literally just said eff this place and moved on their own way. I wouldn't blame them. Why write up something when youre talking to a wall?. I wrote some guides on mediasmart server but it was cared for as much as a homeless man peeing on your car... so yeah Another thing that needs to make this place better is update the bb functions. A big rule of thumb to follow here. DONT DO UPDATES, because if it breaks your chances of going back are slim. in some way im greatful for owning a legit 12 synology with quad nics =)

 

lastly if it wasnt for the very few people that make this place what it is we would all be buying a synology. thanks to those that made this project happen.

Share this post


Link to post
Share on other sites

Hey, I am back to report I have revived my DSM and all data; only lost the DSM settings e.g. user, apps, backup schedules, etc. It was done with the method I mentioned in my previous post, by installing a new DSM on a spare disk to repair the corrupted system partition on my existing storage disks. I take it a opportunity to clear up some bloated and abandoned settings, so I am pleased with the result.

 

And this is where I think the forum should evolve. I am sure there are plenty of users without much technical knowledge in coding programming but have some kind of idea how to get round things just like myself in this forum (obviously there are also many more with such knowledge and tinkering capability), but there are relative lot more of those who just don't know what they are doing yet want to grab a piece of this holy grail of xpenology, those who jump into it without knowing anything then only ask everything without even a look around. Thats what bloating the forum, together with a unorganised forum structure and buzzard searching engine made looking up useful information and write ups even more obscure.

 

I still think there are good guys doing the community great here, I can tell by some of the search returned result. But why hiding them and requiring a search to reveal them? if you list them out clearly, with good layout and appropriate location, it will efficiently lower the bloat questions and threads and posts.

Share this post


Link to post
Share on other sites
Hey, I am back to report I have revived my DSM and all data; only lost the DSM settings e.g. user, apps, backup schedules, etc. It was done with the method I mentioned in my previous post, by installing a new DSM on a spare disk to repair the corrupted system partition on my existing storage disks. I take it a opportunity to clear up some bloated and abandoned settings, so I am pleased with the result.

 

And this is where I think the forum should evolve. I am sure there are plenty of users without much technical knowledge in coding programming but have some kind of idea how to get round things just like myself in this forum (obviously there are also many more with such knowledge and tinkering capability), but there are relative lot more of those who just don't know what they are doing yet want to grab a piece of this holy grail of xpenology, those who jump into it without knowing anything then only ask everything without even a look around. Thats what bloating the forum, together with a unorganised forum structure and buzzard searching engine made looking up useful information and write ups even more obscure.

 

I still think there are good guys doing the community great here, I can tell by some of the search returned result. But why hiding them and requiring a search to reveal them? if you list them out clearly, with good layout and appropriate location, it will efficiently lower the bloat questions and threads and posts.

 

so how far are you exactly on your system?. I am running a mediasmartserver and exactly after the 9th update my system does not want to be accessible via ip or anything. runing dsm 6.02 revision 9 to 10. im open to suggesstions on revival.. as far as i know using a ubuntu disk and doing the mdadm lvm2 stuff doesnt really help me in terms of getting my system to BOOT properly. sure I can access the system volume and folders but what im looking for is something to edit to make it actually boot up. I really wonder what is in update 10 that causes the system to BREAK. What I miss or hope is jun develops a hybrid bootloader for 1.02. the current ones dont play nice with what im testing.

Share this post


Link to post
Share on other sites

 

so how far are you exactly on your system?. I am running a mediasmartserver and exactly after the 9th update my system does not want to be accessible via ip or anything. runing dsm 6.02 revision 9 to 10. im open to suggesstions on revival.. as far as i know using a ubuntu disk and doing the mdadm lvm2 stuff doesnt really help me in terms of getting my system to BOOT properly. sure I can access the system volume and folders but what im looking for is something to edit to make it actually boot up. I really wonder what is in update 10 that causes the system to BREAK. What I miss or hope is jun develops a hybrid bootloader for 1.02. the current ones dont play nice with what im testing.

 

I got it back up and running few hours ago, then spent few hours working on all the settings to match mostly how I had it before. With the recent wannacry strikes around the globe, i also try to tighten my security such as setting more restrictive firewall rules and blocking unused ports, etc. I think my failure in upgrading to DSM 6.0.3 did indeed give me this great opportunity to do so.

 

My DSM is running on a Gen8 Microserver under esxi 6, so it would be different experience to your mediasmart server setup i would imagine. From what you described if 6.0.2 rev8 did work flawlessly, you might want to download the .pat file of 6.0.2 rev8 and fresh install onto a spare Hard Drive, get over the initial setup, then plug in your original Hard Drive. DSM will then prompt your to repair your original Hard Drive. After the repair, you should be able to turn off the machine and unplug the spare Hard Drive, boot it up again with your original Disk. Down side is, you won't retrieve your DSM settings. But for me it is fine as I want to start over, but most importantly my data were kept intact this way.

Share this post


Link to post
Share on other sites

Hello,

 

Firstly thanks for support here.

I had ESXi 6.5 and 5.2 version of DSM on HP Microserver Gen8. 1x 120 GB SSD, 4x 3 TB seagate NAS hdd (RDM).

 

I tried to install loader 1.02a2 (DS3617xs) and DSM 6.1.1_15101. But I get always "error 13".

But I installed loader 1.02a (DS3615xs) and DSM 6.1_15047. This is working with my all data.

 

I am using 8 GB SDCard for loader. I tried same SDcard for install. (I switched Bare Metal)

 

Why did not install loader 1.02a2 (DS3617xs) and DSM 6.1.1_15101 ?

 

Sincerely,

Edited by Guest

Share this post


Link to post
Share on other sites
Why did not install loader 1.02a2 (DS3617xs) and DSM 6.1.1_15101 ?

3617xs(1.02a2) have same problems for me on bare metal, but 3615xs(1.02a) - no problems at all

Share this post


Link to post
Share on other sites
Hello,

 

Firstly thanks for support here.

I had ESXi 6.5 and 5.2 version of DSM on HP Microserver Gen8. 1x 120 GB SSD, 4x 3 TB seagate NAS hdd (RDM).

 

I tried to install loader 1.02a2 (DS3617xs) and DSM 6.1.1_15101. But I get always "error 13".

But I installed loader 1.02a (DS3615xs) and DSM 6.1_15047. This is working with my all data.

 

I am using 8 GB SDCard for loader. I tried same SDcard for install.

 

Why did not install loader 1.02a2 (DS3617xs) and DSM 6.1.1_15101 ?

 

Sincerely,

 

Interesting. I am on Gen8 Microserver, ESXi 6.0, tried both DS3615xs 1.02a and DS3617xs 1.02a2, neither worked, both produce error 13.

Share this post


Link to post
Share on other sites

 

Interesting. I am on Gen8 Microserver, ESXi 6.0, tried both DS3615xs 1.02a and DS3617xs 1.02a2, neither worked, both produce error 13.

 

I forgot to say "I am using Bare Metal" with new installation.

 

@Lordbl4;

Yes, I am using bare metal and same result. So that' s not only mine problem. May be it will fix soon.

 

Thanks,

Share this post


Link to post
Share on other sites

So for now, no solution for people who accidentally upgraded to 15101?

 

I've tried "reinstalling" (popped 3617xs 1.02a2 loader on my drive, booted it, migration went fine then bam disappeared from the network), to no avail.

Share this post


Link to post
Share on other sites
So for now, no solution for people who accidentally upgraded to 15101?

 

I've tried "reinstalling" (popped 3617xs 1.02a2 loader on my drive, booted it, migration went fine then bam disappeared from the network), to no avail.

This is what I have seen others do:

 

try mounting the raid array in live ubuntu usb. Then replace /lib/modules/[yournic].ko with the one in /lib/modules/update/[yournic].ko

 

Let us know if that works.

Share this post


Link to post
Share on other sites
So for now, no solution for people who accidentally upgraded to 15101?

 

I've tried "reinstalling" (popped 3617xs 1.02a2 loader on my drive, booted it, migration went fine then bam disappeared from the network), to no avail.

This is what I have seen others do:

 

try mounting the raid array in live ubuntu usb. Then replace /lib/modules/[yournic].ko with the one in /lib/modules/update/[yournic].ko

 

Let us know if that works.

 

Thanks for the heads-up. I'll try to do so (pity that I have literally no idea which NIC driver I'll need, but I guess I'll just push the whole modules/update folder to modules/, overwriting old files).

Share this post


Link to post
Share on other sites

Hello Guys,

 

I week ago I migrated my nas from 3615xs DSM 6.0.2u11 with customized Jun v1.02a2 bootloader to 3617xs DSM 6.1.1u2. Unfortunately I had to do clean install because upgrading caused not loading network drivers. Maybe caused with a different kernel driver loader script. Fortunately I have serial cable connected to nas, so it was easy to modify /etc.default/VERSION file to change version and restart upgrade process again.

 

So my suggestion is to do clean install if you decide to jump to this latest version from old one.

 

@Jun: It would be good to have special bootloader choice to force reinstall Xpenology kernel modules and patches start scripts. I tried Install/Reinstall choice, but this didn't help me.

Share this post


Link to post
Share on other sites
Hello,

 

Firstly thanks for support here.

I had ESXi 6.5 and 5.2 version of DSM on HP Microserver Gen8. 1x 120 GB SSD, 4x 3 TB seagate NAS hdd (RDM).

 

I tried to install loader 1.02a2 (DS3617xs) and DSM 6.1.1_15101. But I get always "error 13".

But I installed loader 1.02a (DS3615xs) and DSM 6.1_15047. This is working with my all data.

 

I am using 8 GB SDCard for loader. I tried same SDcard for install. (I switched Bare Metal)

 

Why did not install loader 1.02a2 (DS3617xs) and DSM 6.1.1_15101 ?

 

Sincerely,

 

You cant switch from ds3615xs to ds3617xs without fresh install. Those hardware are not compatible, different architecture.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.