DSM 6.1.x Loader


Recommended Posts

Got this up and running on an older pc with the idea that I can move it to my parents house and have an off site backup of my ds1513+. One issue I ran into was the ds3615xs no longer supports shr in dsm 6.0 when making new volumes, and for me that has got me stuck in my tracks. I'm planning on using a pile of my old hdds to get my total space and they are of various sizes. As I understand this is a dynamic patcher correct? What is the likelihood that this would work on a system that still supports shr? I would use the corresponding pat and change sn and model number in grub.cfg of course. I was going to try this, but am currently still testing as it is for stability, and didn't feel like clearing the whole thing out in the middle of that and messing it up if it flat out won't work from the git go. Any thoughts or guidance would be super helpful. Thanks to all that have worked on this!

 

SHR was removed from ds3615 officially. It was re-enabled by those that created the loaders.

 

https://www.synology.com/en-us/products/DS3615xs#spec

 

Just an FYI :smile:

Link to post
Share on other sites

 

Then maybe we should take some inspiration from what was done for Hackintosh with OSX. The loaders are patching ACPI tables (DSDT & SSDT) to make the devices recognized properly. We can actually use GRUB to load modified ACPI tables. Using that approach we should be able to add virtual devices & rename existing ones. We would be able to use vanilla kernel without any modification (as long as the devices are supported).

 

Interesting, i'm playing with hackintosh and there is a way to patch original DSDT with one edited for Osx, i can extract DSDT from generic mainboard bios and i can patch with DSDT from stnology, as you know in .pat file there is often bios update, there are several program to edit UEFI bios and extract DSDT

if someone can view synology specific, we can add these into generic DSDT from potentialy every mainboard that have uefi bios.

Link to post
Share on other sites
SHR was removed from ds3615 officially. It was re-enabled by those that created the loaders.

 

https://www.synology.com/en-us/products/DS3615xs#spec

 

Just an FYI :smile:

 

Does this mean this version should have SHR capabilities? When building a new volume it told me I needed to setup a raid array, and I did not have shr as an option. Has anyone gotten this to work? I used the pat file from synology, was I wrong in doing that? Is there a different one I should be using? If I were to build my shr volume in dsm 5, then redo the system as dsm 6, will I be able to keep shr capabilities? I can obviously test some of this myself, but when it takes days to build these volumes, I kind of would like to have an idea if it will work or not if it is already known by others.

 

Is anyone else having issues with speed of their servers? DSM 6 seems to really bog down and take forever to apply saved settings on this setup and not be as snappy as my real DS. Could just be in my head though. This is running on a intel e2210 (2ghz) with 3g of ddr2 memory. The cpu load and ram load meters never really go that high, but just seems kind of laggy.

Link to post
Share on other sites
I can confirm it works on gen 8.

 

 

Ordered Microserver, but not works :sad:

 

Install ok. reboot and say "migrable" all in loop... any suggestion?

 

Used the UEFI/Legacy image on page 10. Set sata to ahci in bios

 

Can You share your grub.cfg?

 

Thanks

 

@tuonoazzurro

 

Download the UEFI image version, browse the image and copy the ramdisk file and replace the one one on your current image with that one.

Link to post
Share on other sites

Hi,

 

could please somebody help me how to open the synoboot.vmdk and edit grub.cfg to update mac s/n ?

 

I tried with liveCD etc. but each time I got an empty disk of 20Mb ...

 

Tried also ~10 soft under Windows but each time no write possibility, only read ...

 

Thanks !

Link to post
Share on other sites

So it looks like the official DS3615xs no longer supports SHR1/2 at all. Does that mean that the dev team should be looking towards an alternative model that supports SHR? It looks like the models below this: RackStation RS2416+/​RS2416RP+ support SHR only now, with the enterprise range (DS3615xs belongs here) only supporting traditional RAID modes. The enterprise range is also the only one with native SAS support using the LSI cards.

Link to post
Share on other sites
So it looks like the official DS3615xs no longer supports SHR1/2 at all. Does that mean that the dev team should be looking towards an alternative model that supports SHR? It looks like the models below this: RackStation RS2416+/​RS2416RP+ support SHR only now, with the enterprise range (DS3615xs belongs here) only supporting traditional RAID modes. The enterprise range is also the only one with native SAS support using the LSI cards.

 

It never did, it was a feature they removed w/ the 2015 model. The other loader guys re-enabled it. I think it's there, just disabled behind the scenes. They'd have to chime in for more info.

Link to post
Share on other sites
I can confirm it works on gen 8.

 

 

Ordered Microserver, but not works :sad:

 

Install ok. reboot and say "migrable" all in loop... any suggestion?

 

Used the UEFI/Legacy image on page 10. Set sata to ahci in bios

 

Can You share your grub.cfg?

 

Thanks

 

@tuonoazzurro

 

Download the UEFI image version, browse the image and copy the ramdisk file and replace the one one on your current image with that one.

 

 

Very good. all working. DSM 6.0.2 8451 Update 1. DO NOT UPDATE TO UPDATE2. after reboot it stuck to grub saying "invalid magic number". you had to reflash the usb key, but after a reboot same thing again.

Edited by Guest
Link to post
Share on other sites

Yeah sorry, what I meant was that as we're now using a untouched synology kernel/PAT that means that we can't have it back unless the kernel is patched again which appears to be opposite to what this loader is trying to achieve. Moving model would allow us to have it back without needing to edit the bootloader. Happy if I'm wrong, as I use SHR as doing 12 bays using all 3tb drive is prohibitive and especially if trying to expand to more than that.

Link to post
Share on other sites
Someome can make me an img with Win32DiskImage from a working bare metal build? Thank you.

 

Sent from my Oppo R5s

 

there are yet all image needed. You need to check some requirement:

 

1- Du you need AHCI from what i understood.

 

now you have 2 choiches:

 

1- Do you have UEFI? Go with the image in the first post

2- Do you have not UEFI? Use the image hybrid uefi/legacy on page 10. here, do you have RS232 serial port? if yes all ok, else you need to copy the file in images/ds3615XS/ramdisk.lzma from the image from the first post in the same folder on the usb key created from the hybrid image otherwise it ask you to install every reboot.

 

Bye

Link to post
Share on other sites
For me too. tried with the ubuntu live cd in vmware. mounted the boot vmdk and saved. ESXI gives me an error that the vmdk is to old.

 

Need an easy way to edit the mac / serial.

 

My understanding is that nobody is using the Esxi solution with updated s/n and Mac ... as asked several time without success ... :???:

Link to post
Share on other sites

Very good. all working. DSM 6.0.2 8451 Update 1. DO NOT UPDATE TO UPDATE2. after reboot it stuck to grub saying "invalid magic number". you had to reflash the usb key, but after a reboot same thing again.

 

no problem here with the UEFI-version. I just installed update 2. The System rebooted an everything is working.

 

Gesendet von meinem SM-G935F mit Tapatalk

Link to post
Share on other sites

Very good. all working. DSM 6.0.2 8451 Update 1. DO NOT UPDATE TO UPDATE2. after reboot it stuck to grub saying "invalid magic number". you had to reflash the usb key, but after a reboot same thing again.

 

Just to be sure, this has no relevance on ESXi, right?

Link to post
Share on other sites

Very good. all working. DSM 6.0.2 8451 Update 1. DO NOT UPDATE TO UPDATE2. after reboot it stuck to grub saying "invalid magic number". you had to reflash the usb key, but after a reboot same thing again.

 

no problem here with the UEFI-version. I just installed update 2. The System rebooted an everything is working.

 

Gesendet von meinem SM-G935F mit Tapatalk

 

No problem here either on a Gen8 baremetal using the img from page 10.

 

setsunakawa Hybrid UEFI/BIOS Baremetal img

viewtopic.php?f=2&t=20216&start=90#p73344

 

Thanks for sharing @setsunkawa and Jun. :smile:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.