jun

DSM 6.1.x Loader

Recommended Posts

Hello,

 

I read the whole thread :smile:

 

I changed the entry in grub.cfg

 

it looks like

 

serial --port = 0x3F8 --speed = 115200
terminal_input serial console
terminal_output serial console
set default = '0'
set timeout = '1'
set fallback = '0'

menuentry 'Synology DS3615xs' --class os {
insmod fat
linux / image / DS3615xs / zImage root = / dev / md0 syno_hdd_powerup_seq netif_num = 0 = 0 = 1 HddHotplug syno_hw_version = DS3615xs vender_format_version = 2 vid = pid = 0x0741 0x05e3 console = ttyS0,115200n8 sn = C7LWN09761 mac1 = 0011322CA785 withefi elevator = your_magic_elevator quiet
initrd /image/DS3615xs/ramdisk.lzma
}

[...]

all the time I get error 21

 

in what may be the problem of what I'm doing wrong?

 

That grub.cfg file of yours seems wrongly formatted.

 

Here is how it should look like:

 

serial --port=0x3F8 --speed=115200
terminal_input serial console
terminal_output serial console
set default='0'
set timeout='1'
set fallback='0'

menuentry 'Synology DS3615xs' --class os {
insmod	fat
linux	/image/DS3615xs/zImage root=/dev/md0 syno_hdd_powerup_seq=0 netif_num=1 HddHotplug=0 SataPortMap=x syno_hw_version=DS3615xs vender_format_version=2 vid=0x05e3 pid=0x0741 console=ttyS0,115200n8 sn=xxxxxxxxxxx mac1=xxxxxxxxxxxx withefi elevator=your_magic_elevator quiet
initrd	/image/DS3615xs/ramdisk.lzma
}

 

Replace:

SataPortMap=x (x being the number of drives)

sn=xxxxxxxxxxx and mac1=xxxxxxxxxxxx (xxxxxxxxxxx being your own serial number and mac address).

Edited by Guest

Share this post


Link to post
Share on other sites
Hello,

 

I read the whole thread :smile:

 

I changed the entry in grub.cfg

 

it looks like

 

serial --port = 0x3F8 --speed = 115200
terminal_input serial console
terminal_output serial console
set default = '0'
set timeout = '1'
set fallback = '0'

menuentry 'Synology DS3615xs' --class os {
insmod fat
linux / image / DS3615xs / zImage root = / dev / md0 syno_hdd_powerup_seq netif_num = 0 = 0 = 1 HddHotplug syno_hw_version = DS3615xs vender_format_version = 2 vid = pid = 0x0741 0x05e3 console = ttyS0,115200n8 sn = C7LWN09761 mac1 = 0011322CA785 withefi elevator = your_magic_elevator quiet
initrd /image/DS3615xs/ramdisk.lzma
}

 

 

my usb vid is

 

 USB Storage:

 

          Product ID: 0x0741

          Vendor ID: 0x05e3 (Genesys Logic, Inc.)

          Version: 2.20

          Speed: Up to 480 Mb / sec

          Manufacturer: Generic

          Location ID: 0x14200000 / 7

          Available Current (mA): 500

          Current Required (mA): 98

          Extra Operating Current (mA) 0

          Media:

 

 

 

all the time I get error 21

 

in what may be the problem of what I'm doing wrong?

 

That grub.cfg file of your seems wrongly formatted.

 

Here is how it should look like:

 

serial --port=0x3F8 --speed=115200
terminal_input serial console
terminal_output serial console
set default='0'
set timeout='1'
set fallback='0'

menuentry 'Synology DS3615xs' --class os {
insmod	fat
linux	/image/DS3615xs/zImage root=/dev/md0 syno_hdd_powerup_seq=0 netif_num=1 HddHotplug=0 SataPortMap=x syno_hw_version=DS3615xs vender_format_version=2 vid=0x05e3 pid=0x0741 console=ttyS0,115200n8 sn=xxxxxxxxxxx mac1=xxxxxxxxxxxx withefi elevator=your_magic_elevator quiet
initrd	/image/DS3615xs/ramdisk.lzma
}

 

Replace:

SataPortMap=x (x being the number of drives)

sn=xxxxxxxxxxx and mac1=xxxxxxxxxxxx (xxxxxxxxxxx being your own serial number and mac address).

 

Thank you very much for your answer

sn how do I download it

if I type the MAC address of the card that I have installed in the pc?

Share this post


Link to post
Share on other sites

 

Replace:

SataPortMap=x (x being the number of drives)

sn=xxxxxxxxxxx and mac1=xxxxxxxxxxxx (xxxxxxxxxxx being your own serial number and mac address).

 

Thank you very much for your answer

sn how do I download it

if I type the MAC address of the card that I have installed in the pc?

 

SN >>> https://www.dropbox.com/s/zzi5we293gudb ... .xlsm?dl=0

MAC >>> Mac address of the network card of your nas.

Share this post


Link to post
Share on other sites

 

Replace:

SataPortMap=x (x being the number of drives)

sn=xxxxxxxxxxx and mac1=xxxxxxxxxxxx (xxxxxxxxxxx being your own serial number and mac address).

 

Thank you very much for your answer

sn how do I download it

if I type the MAC address of the card that I have installed in the pc?

 

SN >>> https://www.dropbox.com/s/zzi5we293gudb ... .xlsm?dl=0

MAC >>> Mac address of the network card of your nas.

 

 

I enter the data or what is in the picture and sn macadres?

because as soon as you edit a file that's synology asystans is not my letter

 

617cbaf939537c8d1f5b787a0287f5d5_1477641295.jpg

serial --port=0x3F8 --speed=115200
terminal_input serial console
terminal_output serial console
set default='0'
set timeout='1'
set fallback='0'

menuentry 'Synology DS3615xs' --class os {
  insmod   fat
  linux   /image/DS3615xs/zImage root=/dev/md0 syno_hdd_powerup_seq=0 netif_num=1 HddHotplug=0 SataPortMap=x syno_hw_version=DS3615xs vender_format_version=2 vid=0x0951 pid=0x1665 console=ttyS0,115200n8 sn=C7LWN09761 mac1=00:11:32:2C:A7:85  withefi elevator=your_magic_elevator quiet
  initrd   /image/DS3615xs/ramdisk.lzma
}

Share this post


Link to post
Share on other sites

I enter the data or what is in the picture and sn macadres?

because as soon as you edit a file that's synology asystans is not my letter

 

617cbaf939537c8d1f5b787a0287f5d5_1477641295.jpg

serial --port=0x3F8 --speed=115200
terminal_input serial console
terminal_output serial console
set default='0'
set timeout='1'
set fallback='0'

menuentry 'Synology DS3615xs' --class os {
  insmod   fat
  linux   /image/DS3615xs/zImage root=/dev/md0 syno_hdd_powerup_seq=0 netif_num=1 HddHotplug=0 SataPortMap=x syno_hw_version=DS3615xs vender_format_version=2 vid=0x0951 pid=0x1665 console=ttyS0,115200n8 sn=C7LWN09761 mac1=00:11:32:2C:A7:85  withefi elevator=your_magic_elevator quiet
  initrd   /image/DS3615xs/ramdisk.lzma
}

 

Note sure I understand what you are saying.

 

mac1:00:11:32:2C:A7:85 should be without colon >>> mac1=0011322CA785 (although it might work with colon, not sure about this)

As already stated once, SataPortMap=x (x being the number of drives).

Please read carefully.

Edited by Guest

Share this post


Link to post
Share on other sites

I'm sorry because I am confused :smile:

 

whether changes vid pid sn mac should I do

 

/grub/grub.cfg?

Share this post


Link to post
Share on other sites
Yeah, there is feature/bug in loading kernel modules in Jun's modification. At first DISK_MODULES are loaded from ramdisk in /linuxrc.syno, that's ok. In /sbin/post.init are EXTRA_MODULES copied to hdd only when they are not exist and they are then loaded after chroot from hdd (in hdd's /etc.default/rc). So:

  • The installation step replace kernel modules (e.g. e1000e) with their version from pat file that cause not loading our updated kernel modules from ramdisk. Thus we have to replace these bad modules after reboot with version from ramdisk.
  • Also rc.modules file is not updated after first copy in the installation step. Thus when is updated from Jun's original ramdisk to my ramdisk v1, added kernel modules are not loaded. This explain why my network card didn't work with Trantor's r8169 module because the important r8168 wasn't loaded.

 

I will fix both in my v2 ramdisk.

Just want to thanks you !

 

It works !!!

Now I can use my network card of the mobo :grin:

Share this post


Link to post
Share on other sites
Supporting AMD CPUs require complete kernel recompilation. Kernel sources for DSM 6.0.2-8451 Update 2 is not available, only DSM 6 beta 7274.

Thanks :smile: , that's what I suspected.

 

 

Hello, Can you tell me what is the last DSM version I can update my HP Gen7 to ? Is there a tutorial to explain how ? I'm sorry but I've read the whole thread and i can't find pecisely the answer. Thanks.

Share this post


Link to post
Share on other sites
I'm sorry because I am confused :smile:

 

whether changes vid pid sn mac should I do

 

/grub/grub.cfg?

 

Yes.

 

Thank you very much for your help everything works :smile:

 

I question whether you can start here hdmi that has such kodi (XBMC)

Share this post


Link to post
Share on other sites
Supporting AMD CPUs require complete kernel recompilation. Kernel sources for DSM 6.0.2-8451 Update 2 is not available, only DSM 6 beta 7274.

Thanks :smile: , that's what I suspected.

 

 

Hello, Can you tell me what is the last DSM version I can update my HP Gen7 to ? Is there a tutorial to explain how ? I'm sorry but I've read the whole thread and i can't find pecisely the answer. Thanks.

I'm running DSM 5.2-5967 Update 2 in a baremetal install on a Gen7 setup, by reading various threads on this forum and googling. The answers are there, you just need to look for them.

 

I can't remember exactly which ones I used right now, and come to think of it, I think I used a variety of sources to understand how to get my setup to work just right.

 

It probably helps that my day job is as a server IT professional.

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

Thank to all passionate who participates in this performance !

 

Everything works fine on my (fresh) Gen8, and I would like to clarify 2 things:

 

1) I have tested disks (used in my Gen7 with DSM 5.2) without cleanup / format operation. The DSM 6.0.2 has detected the previous version of DSM and have fixed the system partition issue (old DSM version), without removing data (as proposed during the process). From user stand point, is good (no needs to transfer/migrate data).

Is it safe (filesystem ext4 vs Btrfs introduced with DSM 6) ?

 

2) With this version of ramdisk (DS3615xs), is it possible to use "Virtual DSM" feature ?

 

Thank you !

 

Rikk

Share this post


Link to post
Share on other sites

How can i enable both lan cards in DSM 6 ? I have the gigabyte h97 wifi rev1.1 motherboard.

 

What king of changes i have to do in the /grub/grub.cfg?

Share this post


Link to post
Share on other sites

I am hoping someone in here will be so kind to tell me what I am doing wrong, I am trying to install on a Dell Optiplex 760

 

I downloaded the hybrid .img

 

Edited the PID ViD & Mac

 

I did not do the serial simply because I dont know how to generate, But I assume you dont need this if your not using quick connect.

 

I am able to get it load up tells me it sees a drive from a prev install, I choose migrate, No matter what I do it reached 56% and Error 13.

 

Will someone direct me to proper files/ method for my Optiplex 760 non UEFI bare metal ?

 

Thank you all kindly.

Share this post


Link to post
Share on other sites
I am hoping someone in here will be so kind to tell me what I am doing wrong, I am trying to install on a Dell Optiplex 760

 

I downloaded the hybrid .img

 

Edited the PID ViD & Mac

 

I did not do the serial simply because I dont know how to generate, But I assume you dont need this if your not using quick connect.

 

I am able to get it load up tells me it sees a drive from a prev install, I choose migrate, No matter what I do it reached 56% and Error 13.

 

Will someone direct me to proper files/ method for my Optiplex 760 non UEFI bare metal ?

 

Thank you all kindly.

 

Error 13 = wrong VID and PID.

 

For the SN just generate one. It needs it. Use this: https://www.dropbox.com/s/zzi5we293gudb ... .xlsm?dl=0

 

edit: error 13 = wrong VID and PID during setup. In your case it seems to happen after. Not sure what that is.

Share this post


Link to post
Share on other sites

If syno_libata_get_index is missing in the genuine syno kernel it means that it's disable, otherwise when we insmod module it shouldn't complain about missing function.

Can you repack this in a test ramdisk so I can test it with my mobo using ata_piix.

 

There is testing ramdisk: https://mega.nz/#!6F0AgTbZ!JzJCYhkek8p-m3y4VrErssLPWVKI2qZi2vLS_mPaqYs

 

It contains these modules (built with CONFIG_SYNO_FIXED_DISK_NAME=n): ahci_platform, ata_piix, pata_ali, pata_amd, pata_it821x, pata_jmicron, pata_marvell, pata_mpiix, pata_oldpiix, pata_pdc2027x, pata_pdc202xx_old, pata_platform, pata_rdc, pata_sc1200, pata_sch, pata_sis, pata_via, sata_nv, sata_promise, sata_sil, sata_sis, sata_uli, sata_via and sata_vsc

 

For others: Don't use this ramdisk on production environment. It's only for testing how will these disk kernel modules built with CONFIG_SYNO_FIXED_DISK_NAME=n behave.

Share this post


Link to post
Share on other sites

Hi, I have a Acer m1640 with work DSM5 (5967.2) but with this new bootloader I can't to do work mi ethernet.

 

It is capable with RTL8211BL ?

Share this post


Link to post
Share on other sites
Thank to all passionate who participates in this performance !

 

Everything works fine on my (fresh) Gen8, and I would like to clarify 2 things:

 

1) I have tested disks (used in my Gen7 with DSM 5.2) without cleanup / format operation. The DSM 6.0.2 has detected the previous version of DSM and have fixed the system partition issue (old DSM version), without removing data (as proposed during the process). From user stand point, is good (no needs to transfer/migrate data).

Is it safe (filesystem ext4 vs Btrfs introduced with DSM 6) ?

 

2) With this version of ramdisk (DS3615xs), is it possible to use "Virtual DSM" feature ?

 

Thank you !

 

Rikk

 

You need btfrs for Virtual DSM... I suppose you're using ext4 because you have migrated your volume from DSM 5.2, so you have to backup, format and restore data back.

 

Ciao

ema

Share this post


Link to post
Share on other sites
I've created a tutorial for baremetal migration from dsm 5.2 to dsm 6.0 in English so this thread can re-focus on development matters. Hope it helps. viewtopic.php?f=2&t=22100

 

 

Change mac1=0011322CA785 to mac1=[your mac address] You can also add mac2=[our mac2 address] if you have a 2nd NIC.

 

i have try to add mac2=MYMAC and doesn't work :sad:

It works only with one lan card, not both of them.

any ideas ?

Share this post


Link to post
Share on other sites
Power off button

Here is the package. Just extract it, copy files and directories from power-off dir to root and reboot your nas.

 

button.ko and evdev.ko prepared from quicknick 7274 kernel sources, acpid and config is from another thread on this forum.

 

I compiled it in Debian chroot directly on my nas:

cp synoconfigs/bromolow .config
make ARCH="x86_64" oldconfig
make ARCH="x86_64" menuconfig
# set as module: Device Drivers ---> Input device support --> Event interface 
make ARCH="x86_64" modules

 

I am using GA-H170N-WIFI, I manually extract the file to individual folder but doesn't seem the power button is working.

Edited by Guest

Share this post


Link to post
Share on other sites

If syno_libata_get_index is missing in the genuine syno kernel it means that it's disable, otherwise when we insmod module it shouldn't complain about missing function.

Can you repack this in a test ramdisk so I can test it with my mobo using ata_piix.

 

There is testing ramdisk: https://mega.nz/#!6F0AgTbZ!JzJCYhkek8p-m3y4VrErssLPWVKI2qZi2vLS_mPaqYs

 

*****************************

 

After overwrite ramdisk for use sata disks in IDE mode ( not AHCI ) i cannot see the NAS

Operating system stopped, lights extinguished networks

Before with one HDD in AHCI mode i have no problem

Edited by Guest

Share this post


Link to post
Share on other sites

I have a GA-H170N-WIFI but only 1 LAN is working.

Intel I219V chip and the other one controlled by an Intel I211AT chip.

in DSM network shown I have 2 LAN. but actually 1 is not working.

Anything I can troubleshoot here?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now