jun

DSM 6.1.x Loader

Recommended Posts

5) login to DSM, sudo -s as root user, execute "cp /lib/modules/update/* /lib/modules/"

Why are you copying modules to the main module directory? Those updated modules are in principale loaded at boot.

 

w/o this step some drivers seems to failed to load in my dsm, e.g. NIC driver,

 

I assume this could be caused by the dirty upgrade I did instead of clean installation, however this approach just works, for both 6.0 to 6.1 and 6.1 to 6.1.1 :smile:

Share this post


Link to post
Share on other sites

Ok, trying all day with the DS3617xs images, and I keep getting the "Failed to install the file. The files is probably corrupted. (13)" message.

 

I've tried multiple usb keys, same results.

 

But using the DS3615xs image (v1.02a) it installs fine using the DSM_DS3615xs_15101 pat file.

 

Writing out the DS3617xs image to the same key and making the same changes to grub.cfg always fails to install.

 

System is a intel S1200KP server board, xeon 1225 cpu with 16gb ram and an HP HP 412648-B21 dual gig ethernet card.

Fresh install, no data on system. Playing with 2 2tb drives.

Share this post


Link to post
Share on other sites

Hi Guys

 

I have a question on VM.

 

I have a successful system running with Jun's original Loader in VM (VMware 6.5) with DSM 6.0.2-8451 Update 9

I initially setup one virtual hdd from my datastore at 300Gig but have a need for more space.

I have over 700gig free on my datastore and want to increase this drive to 500gig or 600gig.

Can i do this ?

Will the synology pick this up and use the additional space ?

I know i could just add another virtual disk and provision it but id rather have one volume.

I dont want to lose the data so thought id ask here if anyone has done this, before I attempted it and possibly trash my system and data ?

 

Many thanks :geek:

Share this post


Link to post
Share on other sites
Hi Guys

 

I have a question on VM.

 

I have a successful system running with Jun's original Loader in VM (VMware 6.5) with DSM 6.0.2-8451 Update 9

I initially setup one virtual hdd from my datastore at 300Gig but have a need for more space.

I have over 700gig free on my datastore and want to increase this drive to 500gig or 600gig.

Can i do this ?

Will the synology pick this up and use the additional space ?

I know i could just add another virtual disk and provision it but id rather have one volume.

I dont want to lose the data so thought id ask here if anyone has done this, before I attempted it and possibly trash my system and data ?

 

Many thanks :geek:

 

Why dont you try to create test VM with, let say, 20GB hard drive. Install some packages, add fake data and then change hdd size. Best lessons comes from practice. It takes about 1 hour or less.

Share this post


Link to post
Share on other sites

Please, does someone add network drivers for hp 332i interface (gen8) on 1.02a loaders? Many thanks. :smile:

 

Inviato dal mio LG-D855 utilizzando Tapatalk

Share this post


Link to post
Share on other sites
Hi.

Anyone tried to update to 6.1.1-15101-2 version?

Updated gen 8 microserver to update 2 everything seems fine

Share this post


Link to post
Share on other sites
Hi.

Anyone tried to update to 6.1.1-15101-2 version?

 

Updated Gen8 baremetal to 6.1.1-15101 Update 2. Reboot required. Everything seems okay. All Packages and services are working.

Share this post


Link to post
Share on other sites

HI there

 

Sorry if this is a repeat question.

 

Im fine with bare metal installs, but the VM install is kicking my butt.

Im trying to install on VMware 6.5 with Jun v1.02-alpha for DS3615xs

i get the VM up and see the setup page where i need to insert the PAT file.

I downloaded DS3615xs_1501.pat and tried to install that. I then get a failed to format hdd error (35)

 

What i did was to create a folder on my datastore.

Then I copied all 4 files from the loader to that folder

When importing the VM It seemed corruped as i got network errors and could not delete or edit anything in the vm.

I then had to edit the .vmx file and remove all the ethernet config, without doing this the vm would always complain about

being part of the incorrect network port. and i could not edit the vm at all. the only way was to delete all the ethernet lines in the .vmx file

then upload that to the datastore and import the VM again.

then i reinstalled the network and this was ok.

I then deleted the disk and re-added it pointing to synoboot.vmdk and setting it as SATA 0:0 and independant - persistent.

then i added my storage drive as SCSI 0:0 and dependant mode

 

it boots up fine and i get the initial setup page but when uploading the DSM pat file and starting the install i get the

error that it cant format with error 35

 

Is there a guide someone has put together on how to get the VM installed on vmware 6.5 ? (ive tried searching a bit to no luck)

 

Any assistance would be greatfull.

 

This was after the sugestion to create a temp vm to test my disk expansion etc from my previous question.

 

My existing VM is on the old 6.0 DSM with the original jun loader and i used a .ova file uploaded by korovis which had all the hard work done.

So this is my first attempt really at getting this done from the provided loader files.

 

Many thanks

Share this post


Link to post
Share on other sites

Possible to update /upgrade baremetal (hp n54l) from DSM 6 to latest 6.1 with new loader? is there a upgrade guide or must it be a fresh installation?

Share this post


Link to post
Share on other sites
Hi.

Anyone tried to update to 6.1.1-15101-2 version?

 

Updated Gen8 baremetal to 6.1.1-15101 Update 2. Reboot required. Everything seems okay. All Packages and services are working.

Is it possibile to update from 6.0.2? Can you tell how? Thanks.

 

Inviato dal mio LG-D855 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Better yet, could one of you guys with a working VM in ESXI 6.5 with the latest loader, please export an .ova of that and send me a link to it.

This will be the quickest way for me to get going on the new loader in VM :mrgreen::mrgreen:

 

Pretty Please

 

I have spend the entire day now and no matter what i do, i cannot format the drive.

 

Many thanks

Share this post


Link to post
Share on other sites

i changed from scsi controller to sata controller, then my esx 6.5 was able to find the drivers and format was succesful

Share this post


Link to post
Share on other sites
i changed from scsi controller to sata controller, then my esx 6.5 was able to find the drivers and format was succesful

 

WOW!!! that worked.

 

I stumbled on that earlier in the day, but did not go ahead with it as it said it was going to format 2 disks......so i thought it was going to format the large storage one i added and the synoboot drive. (which ive had happen on the old DSM 5.2)

 

Going ahead with that anyway, has allowed me to format and setup the system!!!

i have the VM now installed with loader 1.02a2 and DS3617xs and DSM 6.1.1-15101 Update 2

 

Thanks so much.......i kid you not i have tried everything today for the entire day....i was so frustrated :razz:

 

Even tried to get it going on vm workstation and had the same format issue.....was actually packing and and giving up when you posted that :mrgreen::mrgreen::mrgreen:

 

Thanks mate

Share this post


Link to post
Share on other sites

any clue how to update to 6.1.1. u2? (i'm on esx 6.5, 6.1.1 u1) and I cannot find the update :sad:

Thank you

Share this post


Link to post
Share on other sites
Hi there, any success on ds3617xs with DSM 6.1.1?

 

Finally, I can install DSM 6.1.1 using ds3617xs on bare-metal. Here is my installation procedure:

 

1. Using v1.02a2 and create the boot image with correct SN and MAC1 onto a USB drive

2. Only install 2 hard disk (I have 4 disks for RAID5)

3. Use find.synology.com and install thru web with default value

4. Wait for installation and reboot again

5. Install 6.1.1 update2 and wait for reboot

6. Install the remain 2 disks, and it is working now...

 

Good luck to all...

Share this post


Link to post
Share on other sites

I've successfully updated Gen8 baremetal DS3615xs to 6.1.1-15101 Update 2 using 1.02 alpha loader. All seems to be OK except a HIGH security warning about DSM system files have incorrect hash values (when running Security Advisor).

Incorrect hash values of system disk array have been found in the following file(s):

/usr/lib/modules/bnx2x.ko, /usr/lib/modules/usbnet.ko

I know it's not a big deal but still ... is this normal ? Many thanks for your work and time.

Share this post


Link to post
Share on other sites

@Netstorm, was it a migration from 6.0.2? What steps did you follow?

 

I've successfully updated Gen8 baremetal DS3615xs to 6.1.1-15101 Update 2 using 1.02 alpha loader. All seems to be OK except a HIGH security warning about DSM system files have incorrect hash values (when running Security Advisor).
Incorrect hash values of system disk array have been found in the following file(s):

/usr/lib/modules/bnx2x.ko, /usr/lib/modules/usbnet.ko

I know it's not a big deal but still ... is this normal ? Many thanks for your work and time.

Share this post


Link to post
Share on other sites

Any plans to release 1.02 proper Jun? 1.02a2 has been rock stable for me both in VMware and my Baremetal Skylake system :smile:

 

Sent from my SM-G935F using Tapatalk

Share this post


Link to post
Share on other sites

Hi there,

 

I'm Trying to upgrade 6.1.1-15101 Update 2 and it's failing (ERR = 21) !

 

I'm using DS3617xs 1.02a2 with 6.1.1-15101 Update1. My hardwer is an Acer Aspire one 725 (netbook). it works great, all work.

 

Where is the problem during this update? :sad:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now