Jump to content
XPEnology Community

Recommended Posts

Posted (edited)

Hi everyone, I've been trying to install xpenology for days now. I am using jun loader 1.04b. My problem is that the nas is recognized, but after the installation on reboot it is not found anymore. This actually prevents the installation and if I don't format the hard disks and try a new installation, the system offers me the migration, but when it has finished rebooting the problem remains. I tried 4 usb sticks, a new one arrived today, same problem, I tried to mount a lan card on pci express (realtek) the integrated one is an atheros, I tried to install with a single hard disk, I disabled the hard drives from the bios startup disk,leaving only usb as primary, but nothing always the same problem, I'm sure I have changed correctly, the id, the serial and the mac in grub. sorry for my English.

My system: i5 4460 asrock h81m-itx Ram 16gb

Edited by ginepraio
Link to comment
Share on other sites

Make sure you are installing a supported version. The last DSM version for Jun 1.04b is 6.2.3-25426

https://global.download.synology.com/download/DSM/release/6.2.3/25426/DSM_DS918%2B_25426.pat

 

That means download and save the above to your computer, then do "Manual Install" where you upload the PAT file from your PC.

 

If you let DSM download and install for you, it will pull an incompatible version.

Link to comment
Share on other sites

Also the embedded LAN card is: a Qualcomm® Atheros® AR8171 - there is a Synology native driver for this but there might be a silicon rev that is newer than the driver. Supported PCI ID's are 1969:1091, 1969:10A1, 1969:E091

 

Maybe it might not be supported without using extra.lzma.... @IG-88 its the alx embedded kernel module, any advice?

Link to comment
Share on other sites

1 hour ago, flyride said:

Maybe it might not be supported without using extra.lzma.... @IG-88 its the alx embedded kernel module, any advice?

alx.ko is part of jun's initila extra.lzma and also in the extended version

the driver supports

1969:10A0
1969:10A1
1969:1090
1969:E0A1
1969:E091
1969:1091

 

afair i added support in alx source for killer 2500 (0xe0b1) in 918+ (2400 was already supported in kernel 4.4)

 

when we take this as fact https://linux-hardware.org/?probe=4d97102ada

then it's 1969:10a1 and that should work ootb with juns loader

and it does as its found with initial boot of the loader so the problem must be something else

that is supported by the fact that it happens the same with he realtek nic (and that one is widely used)

 

-try to install with dhcp (dont change ip during install to fixed, keep it dhcp and change later after install)

-dont use online as source, that might get you 6.2.4 and that will not work with jun's loader, provide the *.pat file local as file

-use 6.2.3 as file, https://global.download.synology.com/download/DSM/release/6.2.3/25426/DSM_DS918%2B_25426.pat

if that does nor work try 6.2.0 https://global.download.synology.com/download/DSM/release/6.2/23739/DSM_DS918%2B_23739.pat

keep in mind that using a newer version of dsm then 6.2.0 might update the zImage and rd.gz files on the loaders 2nd partition resulting in a state where you cant install a "older" dsm version so either copy the old files back to the loader or redo the loader completely before trying 6.2.0 (synology assistant will show you the dsm version of the loader)

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...