Jump to content
XPEnology Community

TinyCore RedPill Loader Build Support Tool ( M-Shell )


Peter Suh

Recommended Posts

1 час назад, Captainfingerbang сказал:

Just doing my due diligence here out of curiousity. I Can see an Arc loader here. https://github.com/AuxXxilium/arc/releases/tag/24.2.10

and i see a LIST of patches here: https://github.com/AuxXxilium/arc-patches

But i dont see an "Arc Loader with Arc Patch" any where. could you please point me to the patch portion or is it included? I'm a lil lost

:)

Just install Arc Loader and select "With Arc Patch" when config it !

Link to comment
Share on other sites

8 hours ago, Captainfingerbang said:

Just doing my due diligence here out of curiousity. I Can see an Arc loader here. https://github.com/AuxXxilium/arc/releases/tag/24.2.10

and i see a LIST of patches here: https://github.com/AuxXxilium/arc-patches

But i dont see an "Arc Loader with Arc Patch" any where. could you please point me to the patch portion or is it included? I'm a lil lost

 

@Captainfingerbang

 

I asked you a favor, but didn't you see it?

 

 

Link to comment
Share on other sites

8 hours ago, Captainfingerbang said:

This begs one question ONLY from curiousity, could one use 1 set serial/mac on 2 different machines at same time? And Keep QC?

 

 

I don't think this will work.

In my case, I had DS918+ SN and QC and migrated to DS920+.

It means that there was no ban in this process alone.

Link to comment
Share on other sites

23 hours ago, dj_nsk said:

test only ==> Arc Loader with Arc Patch

 

11 hours ago, Peter Suh said:

 

 

I understand that Arc loader provides various crack tools for violating the license that can irritate Synology.

 

This is a sensitive matter.


@dj_nsk, @Captainfingerbang  I hope you two will no longer mention ARC's license violations in this topic.


I do not agree with ARC's violations.


Please inquire in the ARC section.

 

8 hours ago, Captainfingerbang said:

Just doing my due diligence here out of curiousity. I Can see an Arc loader here. https://github.com/AuxXxilium/arc/releases/tag/24.2.10

and i see a LIST of patches here: https://github.com/AuxXxilium/arc-patches

But i dont see an "Arc Loader with Arc Patch" any where. could you please point me to the patch portion or is it included? I'm a lil lost

 

7 hours ago, dj_nsk said:

:)

Just install Arc Loader and select "With Arc Patch" when config it !

 

You have both been asked by Peter Suh not to derail the thread with the ARC loader which is a separate loader.

If you have questions or comments about that loader, create a new thread.

Link to comment
Share on other sites

12 минут назад, Polanskiman сказал:

 

You have both been asked by Peter Suh not to derail the thread with the ARC loader which is a separate loader.

If you have questions or comments about that loader, create a new thread.

Yes, I apologize to my dear @Peter Suh

(I didn't pay attention to which branch I was responding to)

Link to comment
Share on other sites

Hi

 

while checking about AMD GPU support in XPEnology, I ran into this post :

 

https://jim.plus/blog/post/jim/amd-gpu-drivers-for-synology

 

apparently, he managed to get AMD GPU working with Synology SA6400.

 

I unfortunately do not have a full understanding of the explanation given and I was wondering how could this work be integrated in the loader to get proper gpu integration and hardware acceleration support in Plex for instance

 

thanks

fishton

Link to comment
Share on other sites

On 2/12/2024 at 7:30 PM, Peter Suh said:

 

I don't think this will work.

In my case, I had DS918+ SN and QC and migrated to DS920+.

It means that there was no ban in this process alone.

So what i just attempted was:  I used my real serial and mac from my original 918+ but now using SA6400 TCRP FRIEND new test build, of course i turned off the 918+,

im able to login to Synology site from DSM but when i go to enable QC i get this error: I dns already set to 8.8.8.8. 8.8.4.4  so i dont know if i have to wait??

Peter how did you get this working?

 

image.thumb.png.de30038ad74f981dec4cad640402a480.png

Link to comment
Share on other sites

On 2/12/2024 at 9:29 AM, Peter Suh said:

 

I'm sorry. Even though I knew that the 5900X was a model without an iGPU, I overlooked it.
If you decide to migrate to a model other than DS918+, I recommend trying SA6400 instead of DS2422+.
If you have an Intel iGPU in the original SA6400, H/W transcoding is easily handled.
There is no need to install AME, nor does it require a genuine Serial or Mac. Codec patches are also unnecessary.
However, I am also curious about how the SA6400 operates without an iGPU.
If H/W transcoding is not possible, at least S/W transcoding should work.
I also have Works that can be run with only a Xeon CPU without an iGPU.
I will tell you the results of testing how the SA6400 works.

 

I can confirm that running SA6400 with no IGPU on 5900x fully works with creating thumbnails. All 4k videos have thumbnails.

EDIT! THIS IS INCORRECT ITS ONLY MAKING THUMBNAILS FOR 4k VIDEO THAT IS AVC,  NOT HEVC.

What is WEIRD is that my DS918+ build with Real Serial Mac DOES convert 4k Hevc WITHOUT IGPU on X99 E5-2680v4

The very scary thing that happened with this machine was, i built the loader with 2422. Somehow it got switched to SA6400. 

Is there something in your tools that maybe "suggests" the proper loader based on hardware, then selects it?

 

This really freaked me out.

Edited by Captainfingerbang
Link to comment
Share on other sites

On 2/12/2024 at 7:30 PM, Peter Suh said:

 

I don't think this will work.

In my case, I had DS918+ SN and QC and migrated to DS920+.

It means that there was no ban in this process alone.

 

I have a couple things left to do guys and still using TCRP Friend by Peter Suh for new build.

  • I need to get my QC from 918+ working over to SA6400 machine , its not allowing me.
  • Then move 10 ssd shr over without issue.
  • Peter, are you suggesting that because the DS920+ is the Successor to the DS918+ is why QC still works? Like same family?
  • Now i need a solution for Creating video thumbnails for 4k videos that are HEVC

 

Backing up 918+ now.

Any suggestions?

 

I want to just throw this all away and purchase new INTEL setup with IGPU. Frustrating.

 

 

 

 

Edited by Captainfingerbang
Link to comment
Share on other sites

Can please tell me how can I set M-shell to assign my existing hdd synology bootloader to show in grub? Right now it only showing Tinycore Redpill Image on list.

Also, when I use ./rploader.sh postupdate ds_model_version it throwing error.

 

tc@box:~$ ./rploader.sh postupdate ds918p-7.1.1-42962
platform_selected={
  "id": "ds918p-7.1.1-42962",
  "platform_name": "apollolake",
  "downloads": {
    "os": {
      "sha256": "9905e145f3bd88fcc938b00882be10281861867e5165ae98aefa37be0d5d34b5"
    }
  },
  "add_extensions": [
    {
      "all-modules": "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-modules/master/all-modules/rpext-index.json",
      "powersched": "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/powersched/rpext-index.json",
      "storagepanel": "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/storagepanel/rpext-index.json"
    }
  ]
}
Rploader Version  : 1.1.0.0
Extensions        :   all-modules
  powersched
  storagepanel 
Extensions URL    : "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-modules/master/all-modules/rpext-index.json",
"https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/powersched/rpext-index.json",
"https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/storagepanel/rpext-index.json"
TARGET_PLATFORM   : ds918p
TARGET_VERSION    : 7.1.1
TARGET_REVISION   : 42962
KERNEL_MAJOR      : 4
MODULE_ALIAS_FILE : modules.alias.4.json
SYNOMODEL         : ds918p_42962
MODEL             : DS918+
KERNEL VERSION    : 5.10.55
Local Cache Folder : /mnt/sdb3/auxfiles
DATE Internet     : 18022024 Local : 18022024
Checking Internet Access -> OK
Loader sources already downloaded, pulling latest
Already up to date.
Removing any old redpill.ko modules
Looking for redpill for : ds918p_42962 
parse error: Expected string key before ':' at line 1, column 4
Module does not contain platorm information for ds918p_42962

 

 

I want to boot in my nas drive. I previously had tinycore redpil apollolake 7.1.0 42661 update to 42962 via DSM GUI. After update I am in hdd recovery loop in Tinycore Redpill which showing old DSM model still. So I want to use M-shell.

 

Link to comment
Share on other sites

10 hours ago, goodone007 said:

Can please tell me how can I set M-shell to assign my existing hdd synology bootloader to show in grub? Right now it only showing Tinycore Redpill Image on list.

Also, when I use ./rploader.sh postupdate ds_model_version it throwing error.

 

tc@box:~$ ./rploader.sh postupdate ds918p-7.1.1-42962
platform_selected={
  "id": "ds918p-7.1.1-42962",
  "platform_name": "apollolake",
  "downloads": {
    "os": {
      "sha256": "9905e145f3bd88fcc938b00882be10281861867e5165ae98aefa37be0d5d34b5"
    }
  },
  "add_extensions": [
    {
      "all-modules": "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-modules/master/all-modules/rpext-index.json",
      "powersched": "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/powersched/rpext-index.json",
      "storagepanel": "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/storagepanel/rpext-index.json"
    }
  ]
}
Rploader Version  : 1.1.0.0
Extensions        :   all-modules
  powersched
  storagepanel 
Extensions URL    : "https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-modules/master/all-modules/rpext-index.json",
"https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/powersched/rpext-index.json",
"https://raw.githubusercontent.com/PeterSuh-Q3/tcrp-addons/master/storagepanel/rpext-index.json"
TARGET_PLATFORM   : ds918p
TARGET_VERSION    : 7.1.1
TARGET_REVISION   : 42962
KERNEL_MAJOR      : 4
MODULE_ALIAS_FILE : modules.alias.4.json
SYNOMODEL         : ds918p_42962
MODEL             : DS918+
KERNEL VERSION    : 5.10.55
Local Cache Folder : /mnt/sdb3/auxfiles
DATE Internet     : 18022024 Local : 18022024
Checking Internet Access -> OK
Loader sources already downloaded, pulling latest
Already up to date.
Removing any old redpill.ko modules
Looking for redpill for : ds918p_42962 
parse error: Expected string key before ':' at line 1, column 4
Module does not contain platorm information for ds918p_42962

 

 

I want to boot in my nas drive. I previously had tinycore redpil apollolake 7.1.0 42661 update to 42962 via DSM GUI. After update I am in hdd recovery loop in Tinycore Redpill which showing old DSM model still. So I want to use M-shell.

 

 

This is not a case where postupdate should be used.

postupdate is no longer needed.

Did you rebuild your loader for 7.1.1-42962?

Updates should not be made without rebuilding the loader.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...