nearffxx

Error installing custom build kernel

Recommended Posts

I built the XPEnoboot 5.2-5967.1 kernel with the .config and rd.gz extracted from the zImage. It can boot it, but the web interface wont allow me to install the pat and got error 13. Can any developer give me hint?

I recompiled because it doesn't support my macbook, so I patched the ahci.c file.

r02uyw.jpg

Here is my iso

https://mega.nz/#!LUF2kZDZ!l-trRPgU0XoNZ170O0OZY0xxQHbZ5B-hJHxUAirDMKA

Share this post


Link to post
Share on other sites

It seems the issue with the updater, which want to upgrade the BIOS and it fail. I'm trying to attach a debugger to see find the issue.

Share this post


Link to post
Share on other sites
It seems the issue with the updater, which want to upgrade the BIOS and it fail. I'm trying to attach a debugger to see find the issue.

Try to choose second option and manual select .pat file, you onlu have to reconfigure network, users and so on, yours files are safe

Share this post


Link to post
Share on other sites

Hi, in which way you have extracted rd.cpio from zImage?

I have the same problem for one my project and, maybe i found a way.

Share this post


Link to post
Share on other sites
Both option doesn't work. I tried in virtualbox.

Hi, i think it's a packing problem of the kernel and rd.gz, i tried to setup a VM which boots from network, compile my own kernel, use rd.gz from original Xpenoboot img, same result.

What i did

extract rd.cpio from Xpenoboot img, expanded in a temp dir, compile kernel without path of rd.cpio into kernel config, compile modules, add new modules comes from kernel compiling to rd.cpio espanded, repack rd into rd.cpio, gzip rd.cpio, copy both bzImage and rd,gz into /tftp on boot server

no luck installation error

 

at this point we have to wait kernel dev if they could show us a entire process to build .img in rigth way

Share this post


Link to post
Share on other sites