Question on Migrating


Recommended Posts

I have been testing redpill  on my HP N54L for a couple of weeks or so and it's been working great with no problems. I have another pc based server emulating DS918xs+. I now want to move those drives to my new server emulating DS3622xs+ and not exactly sure of the procedure. I have read a lot but still a little confused since there are emulating different models. Thanks in advance.

Link to post
Share on other sites

Never mind. I just jumped in and swapped drives and migrated and seems to be ok. Only comment I can say is no improvements that I can see but I am a rookie to this still and I am guessing some of you geeks know a lot of great things with 7 😂

Link to post
Share on other sites

I do find DSM7 to be a bit "snappier" to respond and finish tasks.  Changing from Photo Station to Syno Photos seemed to be a bit of an "upgrade".  I like the Syno Photo Android app (for syncing and backup) better than Photo Station (for Android).  

 

However the lack of USB dongle support has made the whole thing a bit of a downgrade for me as I used a zwave stick (USB) with Home Assistant (3rd party app) with DSM6.  I may have to return to 6.2 if I can't find an alternative for DSM7 to run my home automation stuff.

  • Like 1
Link to post
Share on other sites
20 hours ago, rickym said:

I have been testing redpill  on my HP N54L for a couple of weeks or so and it's been working great with no problems. I have another pc based server emulating DS918xs+. I now want to move those drives to my new server emulating DS3622xs+ and not exactly sure of the procedure. I have read a lot but still a little confused since there are emulating different models. Thanks in advance.

Me too, except from 6.2.x DS3615xs to 7.1 DS3622xs+ or maybe DS920+ since I big time use Plex, and would like the HW Transcoding built-in support. 🤩

  • Like 1
Link to post
Share on other sites
On 4/29/2022 at 8:46 PM, gericb said:

Me too, except from 6.2.x DS3615xs to 7.1 DS3622xs+ or maybe DS920+ since I big time use Plex, and would like the HW Transcoding built-in support.

there might be some problems with disks arrangements in 920+ (dtb file)

just use 918+ for 7.1, there is no difference in functionality as the hardware base difference is just apollolake vs geminilake and the kernel and i915 driver is the same

if its still Optiplex 7040 with a Core i7-6700 (Skylake Family) then the i915 driver should work ootb and the only thing to add would be the i915 firmware files

/lib/firmware/i915/

bxt_dmc_ver1_07.bin
bxt_guc_ver9_29.bin
bxt_huc_ver01_07_1398.bin
cnl_dmc_ver1_06.bin
glk_dmc_ver1_04.bin
kbl_dmc_ver1_04.bin
kbl_guc_ver9_39.bin
kbl_huc_ver02_00_1810.bin
skl_dmc_ver1_27.bin
skl_guc_ver9_33.bin
skl_huc_ver01_07_1398.bin

from here (or from whats in my extra.lzma for 6.2.3)

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915

imho the dmc files in general (and the skl dmc in your case) would be enough but having them all does not hurt

(bxt and glk dmc file would usually be already there as they are part of DSM)

 

  • Like 2
Link to post
Share on other sites
On 5/1/2022 at 5:10 AM, IG-88 said:

there might be some problems with disks arrangements in 920+ (dtb file)

just use 918+ for 7.1, there is no difference in functionality as the hardware base difference is just apollolake vs geminilake and the kernel and i915 driver is the same

if its still Optiplex 7040 with a Core i7-6700 (Skylake Family) then the i915 driver should work ootb and the only thing to add would be the i915 firmware files

/lib/firmware/i915/

bxt_dmc_ver1_07.bin
bxt_guc_ver9_29.bin
bxt_huc_ver01_07_1398.bin
cnl_dmc_ver1_06.bin
glk_dmc_ver1_04.bin
kbl_dmc_ver1_04.bin
kbl_guc_ver9_39.bin
kbl_huc_ver02_00_1810.bin
skl_dmc_ver1_27.bin
skl_guc_ver9_33.bin
skl_huc_ver01_07_1398.bin

from here (or from whats in my extra.lzma for 6.2.3)

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915

imho the dmc files in general (and the skl dmc in your case) would be enough but having them all does not hurt

(bxt and glk dmc file would usually be already there as they are part of DSM)

 

I too want to compliment you @IG-88 and your willingness to very clearly and concisely, give of your time, experience, knowledge.  I only have so many hours in the day to be reading through all the various topics/threads/sub-threads, it's not the most efficient or straight forward, and the minutia of the most important details can be totally missed, just because it was on another thread elsewhere.  You bring it all together, so quick - I really appreciate all your efforts and help!

 

I have been trying to keep up with the dtb issues of the 920+, so will follow your logical recommendation of the 918+ in the meantime.

 

Since my ds31615xs is with Jun's Loader 1.03b, I don't need to keep using that USB or modify it to go to DSM 7.0.1, I can just make a new USB with the TCRP and migrating/updating from 6.2.3 to 7.0.1 ds918+ as well, is that right?  Then a few more steps to get to the initial 7.1 and then a few more to the 7.1 latest update... 🤔

Link to post
Share on other sites
17 hours ago, gericb said:

I can just make a new USB with the TCRP and migrating/updating from 6.2.3 to 7.0.1 ds918+ as well, is that right?

yes

 

17 hours ago, gericb said:

few more to the 7.1 latest update...

i've not done any updates with rp loader  and 7.x yet but there are enough people with 7.0.1 u3 systems so i guess it should be possible to installing updates

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.