Jump to content
XPEnology Community
  • 0

Virtualbox redpill TC DSM 7.0.1 - can not create volume





I have successfully installed DSM 7.0.1 42218 with TC redpill in virtualbox on a virtual ds3622xs+


I've added 2 HDD's as data drives and there both visible in DSM.

When I want to make a storage pool and volume I get a error that the entry for the field modify allocated size is invalid.


Even if I choose MAX (which is 3) I still get the error. No matter if I choose 1 or 2. Google on this error did not give me a solution. Anybody knows what is going on?






Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

@Casper1982 how did you manage to install DSM 7.0.1_42218 on VirtualBox ? can you share your .vbox configuration file ?


reason is I'm having no success in VirtualBox with the DSMv7.x series either with TCRP loader method or with a possible update path from last working Jun's Loader DSM 6.2.3-25426 (in te latter update case i get an "Unknown Error (21)"


- whereas in the case of a direct TCRP install procedure the loader boots upto BusyBox but fails to use the loaded e1000e module which results in

ip: ioctl 0x8913 failed: No such device

and no eth0 network interface hence stuck there.

This happens for all TCRP scripts v0.4.6, v0.8.0.1 and even the dev version of v0.9.0.2 and both later DSM v7.0.1.x and v7.1.0.x its always the same message above


I have tried configuring the VirtualBoxes with other Network adapters as well , even the ParavirtualizedNetwork (virtio-net) and can see the module loaded but no network interface.


PS: I'm runnung VirtualBox as the host on a Windows 10 PC !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...