Anyone want to Zoom to help w/ bare metal install? I'll pay!


Recommended Posts

Hi everyone,

 

I'm a relatively tech savvy person, but I've recently built my own server and keep getting tripped up trying to get Xpenology installed.  Seemingly every step I go through, I run into some kind of problem and after an hour of googling, I'll figure it out only to have the cycle repeat...

 

Here is the hardware I'm working with:

 

CPU: Xeon e3-1265L v3

MB: Asus h81i-plus

Memory: 8GB DDR3

HD: Three WD Red 4GB and 500GB WD Red NVME (for cache)

NIC: Realtek RTL8111G

 

I've gotten as far as creating the synoboot USB installer and am able to boot from it, but I can't find the machine on Synology assistant.  If I had to guess, it's because of the NIC as it needs the Realtek drivers.  My MB is a mini-itx with only one PCIe slot and so I'm resisting buying an Intel NIC because I'd like to use that slot for caching.  I did find a post where you had to use OSF Mount to replace the NIC drivers for the Realtek ones, but that didn't seem to work as it's still not showing on Synology assistant.

 

Anyways, I feel like I'm close but I'm a little overwhelmed and tired of troubleshooting.  I'd be willing to pay someone $50 for an hour of their time to Zoom and connect with me to assist.  It feels worth it to me at this point lol.  I'm close to just using FreeNAS, but I own a DS216j and know DSM and would love to be able to keep using it.

 

Thanks in advance!  If anyone is interested in helping a noob, please let me know.

Link to post
Share on other sites
1 hour ago, dean4109 said:

CPU: Xeon e3-1265L v3

MB: Asus h81i-plus

if its 6.2.3 to install the 1st advise would be to use loader 1.04b for 918+, your cpu allows it and that one work in uefi too (3615/17 aka loader 1.03b only works in old legacy aka csm mode and needs to be booted from the usb legacy device - not the usb uefi device)

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

jun's loader (all 3 flavors) have the realtek driver so imho the nic is not your problem

also dont expect to much of as (single) nvme ssd, dsm will use it only as read cache and thats kind of pointless in most home environments as it only speeds up date you already used and with a 1G nic its mostly the nic that holds you back wen it comes to network speed (1G = ~112MByte/s)

 

if you are interested in the hardware based video transcoding then 918+ is your way anyway

if you master the install you would need some more steps to get that working with 6.2.3 and even the nvme would need some manual tweaking to get it working - but 1st you would need to master the install (and dint update 6.2.3 further then u3, 6.2.4 or 7.x need different loaders and that is completely different to configure/use (and still in development phase)

Link to post
Share on other sites

I appreciate the response!

 

So I had been going back and forth trying to do a bare metal install, but I actually was able to get DSM 7 working with esxi so I'm just going to run with that.  VMware will give me some versatility if I want to use the server for something else down the road, and it's a bonus that I was able to get DSM 7 too.

 

Now I'll spend the next week or so setting up my media server as docker is completely new territory for me lol.  Maybe I'll learn something that I can put on my resume one day...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.