Sign in to follow this  
vertigo-uk

HELP installing xpenology on hp microserver gen8 error 38

Recommended Posts

hi all noob here

 

i purchased a hp microserver 1610 at the weekend along with a wd red 1tb

 

i installed the hdd in bay 1, plugged ethernet cable from router into eth1 and powered on the server

 

i changed the boot order to usb 1st and flashed XPEnoboot DS3615xs5.2-5644.5 to my usb stick.

 

i went through and selected install and let it do its thing until i got to the xpenology diskstation login message.

 

i launched synology assistant and connected to the server. so far so good.

 

i selected the DSM_5.2-5644.pat file and clicked install.

 

it configured network setting and started to format the system partition (uploading in bottom corner) it gets to 98% and fails with error38.

 

what am i missing. do i have to change the sata controller to ahci in the bios(is it defaulted to raid). do i need to remove the usb stick once i get to the diskstation login _ message, do i need to enable iLo4 on eth1 first or is it on by default, could it be my firewall although i believe that's disabled, could it be because i clicked connect in SA before clicking install do i need to deselect "create a shr volume after installation".

 

new to all of this but from searching around it appears as though error 38 means no communication between mb and hdd. in the bios the hdd is recognised although for some reason both the usb boot key and the hdd have the same drive letter c:/ i also noticed that on initial boot there is no ip address in the bottom corner as stated on other forum posts. (iLo4 ip - UNKNOWN) is this normal until it installs

 

any help getting this working is greatly appreciated.

Edited by Guest

Share this post


Link to post
Share on other sites

UPDATE-

 

disabled firewall on pc and router

changed sata mode to ahci

tried unclicking shr

tried numerous different img/pat etc

 

still doesnt work. i also notice that eth0/1 shows not running on xpenology screen. unable to change to static ip as it wont let me type. root at login prompt might need to try and find a old keyboard rather than a usb. Although I have heard that ps/2 to USB adapter don't work either

 

at the moment i have a £200 paperweight

Share this post


Link to post
Share on other sites

there are lots of people running G8s so I think this should work, although I've not played with one myself

 

As to things to try I would

Reformat the HDD to remove any 'spurious' partitions created by a failed install

Update the bios to latest version

boot xpe with no hdd attached but all network ports connected and see if SA finds it/assigns IPs

set bios to only boot from usb (legacy mode) and disable hdds in boot order

try the hdd on different sata ports

disable any controller cache

ahci/jbod for sata

install with just one nic connected, not the ilo port

Share this post


Link to post
Share on other sites
Sign in to follow this