Starting off on the right foot…


Recommended Posts

Hi, I’m Ed and clueless. I have an old PC and wanted to try out xpenology. I’ve read and watched videos and thought I had a grasp. 
Then I saw some ask if there PC was too old. Hmmm That’s been an issue. 
Can somebody PLEASE start me off right?

 

I want to install xpenology as like an OS (I think it’s called bare metal?)

I have a Dell 530 with a modded Q6600, 8gb ram.

Bios 1.0.18……

 

I’m lost. I think some older bios/pc can only use certain loaders and files…… grrrrrrr

i saw a list with MBR and others. Still pulling my hair out with dockers. 

Please help a old man start off on the right foot…..

Link to post
Share on other sites
13 hours ago, BigDabz said:

I want to install xpenology as like an OS (I think it’s called bare metal?)

I have a Dell 530 with a modded Q6600, 8gb ram.

Bios 1.0.18……

i guess its a Inspiron 530

https://linux-hardware.org/?probe=44903c7ee0

we can see the pci id's of the devices and the used drivers in that link

 

storage is ahci (at least when correctly set up in bios)

network controller is only 10/100 MBit and its supported with a driver directly in dsm (at least for ds3615/3617)

so in theory you should be able to use dsm 6.1/6.2 and even 7.0 (e1000e driver is also part of tinycore's driver set)

 

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

1st thing you can see that you dant have to try a loader for 916+/918+ because your cpu is to old for these

this indicates that if there is a problem with uefi/csm mode you can use loader 1.02b for dsm 6.1, that version works for both

 

start off with loader 1.02b for 3615, no modifications to the loader or it's files, see if you can find it in network (synology assistant or maybe your dhcp server, often the internet rouer)

if that works you can try to mod the grub.cfg of the loader to match the vendor and device id of the usb you use for booting with the loader

now try to install dsm 6.1 as in the tutorials

 

if you want dsm 6.2 you can now try the same with loader 1.03b, leave your working loader and disk as is and use a new usb and do the same as above, 1st try without modding the loader and just look for it in your network, if not then you can try the same with the mbr format loader that can be found here

https://xpenology.com/forum/forum/98-member-tweaked-loaders/

 

you can also try the new tutorials for dsm 7.x like this one

https://xpenology.com/forum/topic/59956-redpill-tinycore-loader-installation-guide-for-dsm-701-baremetal/

 

Edited by IG-88
  • Thanks 1
Link to post
Share on other sites
  • 3 weeks later...

I finally got to test it. 
I printed 5 pages and took care of all prerequisites for 102b/ds3615xs.

 

I used an USB stick and 1 hd I had laying around. Both listed in bios. 1st boot is USB.

(Edited the grub for vid, pid, sn, mac, timeout.)

The loader came up and I hit Install…..

Jun loaded files somewhere.

I found the nas no problem, I hit like install or something similar then there was a 9 minute countdown timer. I got impatient and just refreshed the webpage. then restarted the pc.

 

booted to Jun loader, hit install (top option), after pc was loaded to kernel…… (monitor attached).

 

keeps ending up saying that “no hard drives are connected to the DS3615xs”…….

 

dam, so close…

 

Seeing as I made it that far, would it be more worth my effort to install 7.1?

 

and THANK YOU so much for taking your time to help. 
 


 

Link to post
Share on other sites
4 hours ago, BigDabz said:

Seeing as I made it that far, would it be more worth my effort to install 7.1?

 

Hi Ed, for DSM 7.1 you need to use a different loader (RedPill). The procedure might be a bit different from Jun's Loader, maybe have a look at the tutorials IG-88 linked in his post how to install DSM 7.

Link to post
Share on other sites

Ok I tried again with the link provided for 7.0.1 baremetal.
There’s 9 steps. My notes on each. Yes I took notes.
Numbers refer to the step.

1) Downloaded the UEFI file
2) Burnt using Rufus
3) Booted to tinycore ok. Used ifconfig ok.
4) I did not use ssh, I had a monitor connected and used the terminal in tinycore.

Question 1: Do you have to SSH or is using the tinycore terminal ok?

*ran update now (OK)
*ran serialgen Ds3622xs+ (OK)
*ran identityusb now. Found 2 usb. Selected my usb. Listed my usb vid/pid and a second line that said “sorry, no usb disk could be identified”

Question 2: identifyusb found my usb stick, even with the error, was the vid/pid saved? I didn’t get a prompt to update the json file.

*ran satamap now (OK)

The rest of step 4 got me lost, about sataportmap and that stuff.

5) hot plug option? I’m lost

6) SSH? I had a monitor/keyboard/mouse on xpenology pc.
This is the roadblock!

*ran build broadwellnk-7.0.1-42218

Question 3: a question came up asking if I wanted to use the firmware files from /home/tc/cast…….. (locally I guess) Y/N
I hit N

Note: I ran the build command again but chose Y but ended in the same download error.

A bunch of stuff came up but ended when it failed to download ds3622xsp_42218.pat

Can not download the needed file it said.

Frustrating. As you can tell, I am putting a lot of effort in this. Why wasn’t I born rich or with generous friends ……f6a9fe54fd4cc19f4a8eeaad2ed4a07d.jpg







fce36ee3d64599166c7610a2587745fd.jpg
33626197cb142cc540ce5448a5dd5d4e.jpg
aaa1e50a11796d892467206cb937d305.jpg

Link to post
Share on other sites

Members have had success with DS3622xs+ on older hardware..

Give these commands a try:

 

./rploader.sh clean now

./rploader.sh update now

./rploader.sh fullupgrade now

./rploader.sh serialgen DS3622xs+

./rploader.sh identifyusb now

./rploader.sh satamap now

./rploader.sh build broadwellnk-7.0.1-42218 manual

./rploader.sh clean now

./rploader.sh build broadwellnk-7.1.0-42661 manual

Link to post
Share on other sites

Rojoone2 that helped. I still got the error using identifyusb.

(Im trying to see if xpenology will work with my pc)
For testing, I am using 1 usb stick & 1 random sata drive.

If I can get it to work, I’ll use the usb stick to boot & 2x 2TB WD Red. I think I saw some people had a drive for swap? If so, I’ll add it.

Here’s as far as I got…..
[mention]IG-88 [/mention] or [mention]rojoone2 [/mention]
I really appreciate your help.
I think I’m close to done??


27ac3fab7f935c8cd1b674136d8aae0b.jpg
3b2b5744d2b1a3814cee248544cee2f6.jpg

Link to post
Share on other sites
Posted (edited)

I’m still trying.
Fixed the “identifyusb” error by unplugging the sc card reader. Now updates in vip/pid.

It keeps timing out downloading the Ds3622 pat file.
I downloaded it manually and placed it the the cache folder.

When I tried to install jun’s, redpill, or [mention]rojoone2 [/mention] help, all just end up no drives found.

The same outcome trying usb stick/ 1 spare drive or usb stick and 2 WD Reds.

What am I doing wrong?
Is there any mandatory prerequisites on the hard drives?
Is there a procedure to plugging in the sata drives?

When I downloaded the redpill image, I used the UEFI version. Should I have used the legacy version for my old pc? [mention]IG-88 [/mention]

Using port SATA0 and SATA1.

 

edit: tried the LEGACY redpill img and still no drives detected.

Screenshot 2022-05-05 121133.png

IMG_5030.jpg

Edited by BigDabz
add photo
Link to post
Share on other sites

I tried 6.1 again after learning from redpill.
I have 6.1 working!!!

How can I safely update it to the highest one possible. 6.2 or 6.3?


Sent from my iPhone using Tapatalk

Link to post
Share on other sites
23 minutes ago, BigDabz said:

How can I safely update it to the highest one possible. 6.2 or 6.3?

use jun's loader 1.03b and make new usb for that (remember to match usb vid/pid), try if you can find the system with it in you network

if it does work the loader should detect the disks with 6.1 and offer to migrate to 6.2

if its not found in network its most likely about csm mode in uefi bios and the usb boot device (needs to be legacy instead of uefi usb device)

  • Like 1
Link to post
Share on other sites

I want to thank [mention]IG-88 [/mention] , [mention]rojoone2 [/mention] and [mention]gadreel [/mention] for taking your time to help.
I like the DSM OS/Packages vs xpenology, openmediavault or Amahi.

I liked the OS/DSM so much, I purchased a DS220+.

Thanks again….

giphy.gif

Link to post
Share on other sites
2 hours ago, BigDabz said:

I liked the OS/DSM so much, I purchased a DS220+.

Nice!!!  But now what will you do will all that "spare" time?  Congrats...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.