[SOLVED] HP Proliant N40L MicroServer native support


Recommended Posts

Thanks for your reply spiderben - I'll give that card a go :smile:

Incidentally - have you found anyway to stop the N54L filling with dust? I wouldn't say my house is THAT dusty but the N54L seems to be a great little vacuum cleaner and my drives and 'insides' are covered in fine dust, especially around the door area :sad:

Link to post
Share on other sites

That's quite an issue for me too. I try to use the vacuum cleaner at least once a week on the front door (without opening it) but it doesn't really prevent dust from piling on top of my hard drives...

I've seen people literally put the N54L into a stocking (yeah, the kind of one women wear) to act as an antidust filter, might be effective but I don't know about heat dissipation.

Link to post
Share on other sites
  • 3 weeks later...

Hi guys,

I own an Asustor 202te but I'm not very satisfied about its OS. So I'm evaluating an HP n54l to replace it.

I have only a question: what about power saving schedule? In Asustor console, I can schedule when the unit will shutdown and boot. Can I use this feature on n54l with DSM?

 

Thanks a lot

Link to post
Share on other sites
Hi guys,

I own an Asustor 202te but I'm not very satisfied about its OS. So I'm evaluating an HP n54l to replace it.

I have only a question: what about power saving schedule? In Asustor console, I can schedule when the unit will shutdown and boot. Can I use this feature on n54l with DSM?

 

Thanks a lot

 

Yes you can, it's under Hardware & Power/Power Schedule in Control Panel.

Link to post
Share on other sites
Just to report back, I installed it this morning, it works flawlessly out of the box (DSM 5.1-4528 on latest nanoboot, bare metal installation). I used the ODD molex cable to power it, not sure if it's really needed though.

 

Really? How did you get the "DSM 5.1-4528 on latest nanoboot, bare metal installation" going?

 

I thought that version was not running yet on XPEnology yet...

Link to post
Share on other sites
  • 4 weeks later...

Just wanted to drop everyone a quick note and say thanks for the effort and forum/community atmosphere.

 

Having no experience with Xpenology, I was able to search/read the guides and get the box up.

 

Although I still need to make it externally accessible and struggle to find guides on this given Synology QuickConnect is no longer an option.

Are there any guides that can be followed in this regard?

 

 

I'm now running the custom firmware (hot swap enabled) on HP N54L, native USB boot.

Have the stock disk setup as the download, app drive and 3 x WD Red WD60EFRX 6TB setup as the primary storage.

 

Anyway, thanks again to all who support the development and community!

Link to post
Share on other sites

just configured my new (used) N40L with nanoboot and 4528, 2x 3TB Barracudas, USB3 Nec pci-ex card, wifi backup dongle and everything is working great.

integration with sickrage and transmission is working flawless, and time machine backups are fine too :smile:

 

 

just a question, i'm reading back some pages but i didn't find yet a solution: is there a way to hide the system boot drive (usb key) completly from DSM? this is the last thing i need to fix :grin:

Link to post
Share on other sites
just configured my new (used) N40L with nanoboot and 4528, 2x 3TB Barracudas, USB3 Nec pci-ex card, wifi backup dongle and everything is working great.

integration with sickrage and transmission is working flawless, and time machine backups are fine too :smile:

 

 

just a question, i'm reading back some pages but i didn't find yet a solution: is there a way to hide the system boot drive (usb key) completly from DSM? this is the last thing i need to fix :grin:

 

http://xpenology.com/forum/viewtopic.php?f=2&t=3052&p=20337&hilit=PID#p20337

Link to post
Share on other sites
just configured my new (used) N40L with nanoboot and 4528, 2x 3TB Barracudas, USB3 Nec pci-ex card, wifi backup dongle and everything is working great.

integration with sickrage and transmission is working flawless, and time machine backups are fine too :smile:

 

 

just a question, i'm reading back some pages but i didn't find yet a solution: is there a way to hide the system boot drive (usb key) completly from DSM? this is the last thing i need to fix :grin:

 

http://xpenology.com/forum/viewtopic.php?f=2&t=3052&p=20337&hilit=PID#p20337

 

done :smile: that was easy, thank you!

Link to post
Share on other sites

Hi guys,

I own an HP N54l with DSM 5.0-4528 update 2. I'm very satisfied with it but I can't use the WOL feature. I've tried the guides found on forum but they are a little bit outdated.

Do you have any idea how to achieve it?

 

thx

Link to post
Share on other sites
  • 2 weeks later...

All the information is in this thread and is not out of date. You just need to be able to see through all the chaff.

If you are using nanoboot (which set the correct MAC addresses for the ethernet port) then,

 

ssh to your NAS box and edit /etc/synoinfo.conf

change the following:

 

wol_enabled_options=""

eth0_wol_options="g"

 

if you have more than one ethernet port (I have three), you can set eth1_wol_options="g", and the same for 2, 3 etc.

 

Save and reboot.

 

QED,

Link to post
Share on other sites
  • 3 weeks later...

Hello,

 

Thanks to this forum and this thread I managed to make my n54l full working DSM 5.0 machine :smile:

 

I have one question - does someone know is it possible to tweak fan speeds? I've checked "Quiet" mode in Power settings but it's still little noisy when it doesn't have to be. In idle - I have ~28*C on my drives so it's cool and fan RMP can be lowered as much as possible. I prefere to edit some magic config via SSH than physically replace fan (because of 4pin HP PWM connector which isn't standard one). But if there is no other way than hardwar then I assume that I'll have to play a little.

Link to post
Share on other sites
  • 2 months later...

Hi,

 

I'm getting kind of desparate so i hope anyone here can help me.

Xpenology (dsm 5.1) is running on my n40 since a week.

 

Now i'm trying to get my 5th disk to show but nothing is working....

I've edited the synoinfo.conf file (yes both...) but nothing changes, it seems like these changes have no impact.

 

At this moment the values are:

esataportcfg="0x10"

internalportcfg="0x2f"

 

When i boot from a different usb into ubuntu the disk is shown without any problem so there is no hardware problem.

 

Could someone help me out please?

 

Kr

Link to post
Share on other sites

Hi

 

Thanks for the quick response.

Yes i have tried editing the files numerous times without results....

 

These are my settings now

 

esataportcfg="0x10"

usbportcfg="0xfc0"

internalportcfg="0x2f"

Link to post
Share on other sites

Need some help with N40L + XPEnoboot + DSM 5.1 5022 U4. I'm sorry if there had been similar threads and if there already is, kindly please take me to it. Thanks!

 

I previously had 2x 2TB disks in an SHR volume (1.8TB usable) and it is almost full. I inserted a third 2TB disk and added it to the same volume. This "expanded" the volume to take up the extra drive. The process took over 24 hours but when the task completed, the total capacity remained at 1.8TB. The picture below clearly shows that all three 2TB disks has been added but the total capacity available is still 1.8TB when it should've been increased to 3.6TB.

 

a501104097432ec79851b1e3cf67b424_zpswpkxqt4h.jpg

 

Moving further, I decided to do a series of experiments. I backed up my date and deleted the volume. I recreated a new one using all three drives and it yielded 3.6TB, the correct capacity.

 

I then proceeded with the 2nd experiment. I deleted the volume again and simulated my original setup... which is just the two disks. Again, after creating a 2-disk SHR volume, I added the third disk and proceeded to expand the capacity. Long story short, I encountered the same exact problem as before. In this state, the N40L seems to crash when you issue a reboot or shutdown from within DSM and I had to power-cycle the box manually to get it back into a usable state. The box is currently headless in a remote part of my home. But I can take it to my shop if I have to.

 

Any ideas?

Link to post
Share on other sites
  • 1 month later...

Hello.

 

Just recently found this great site and OS.

 

Im having an issue and i have tried reading threw this thread but the references to everything is either about files that no longer exist or versions that are outdated.

 

Does anyone know how i can get XPEnology version XPEnoboot 5.1-5055.1 DS3615xs or version XPEnoboot 5.2-5565.1 DS3615xs to show my network card on my n40l.

 

Here is what i have done.

 

I wrote the img file using win32diskimager.exe to a USB drive and i put it in the usb inside the case and go to the install / update option. Is there something i have to do other then just this step.

 

I can get it to install using exsi 6 because i select a different network card to virtualise.

 

Any help or steps i need to do would be appreciated.

Link to post
Share on other sites

after test, the network card of N40L is not compatible with the firmware 5.2-5565.1 or 2 !!!

the probleme is resolve by add network card exemple : TP-LINK model TG-3468

 

if no one has problem with N40L?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.