[SOLVED] HP Proliant N40L MicroServer native support


Recommended Posts

I've got this running on my N40L and it works great other than a couple of issues.

 

  1. After installing Nighthawk's modules I lost the ability to see my USB printer that is connected to my N40L (worked fine before that).
  2. Installed Nighthawk's modules to get my USB UPS working, still can't see that.
  3. My SiL3132 PCIe eSATA card doesn't work

 

Otherwise, its working great. Flashed a hacked BIOS and I can use the 4 internal "hot swap" bays as well as a hot swap bay I have in the 5.25" bay. I still have 2 more HDDs I'd like to attach but I will be happy if I can get just one attached (they are in a Sans Digital PM eSATA tower).

 

try this: http://xpenology.com/forum/viewtopic.php?f=2&t=915#p4292

 

That worked, thanks. Now to see if my eSATA tower will work once I get home.

Link to post
Share on other sites

I hope someone can help with this.

 

I entered my DDNS in diskstation all ok. I can ping the DDNS address ok

but I can't access it via a web page! I do sometimes get "Sorry, the page you are looking for is not found"

 

I have opened ports 80 and 53 but as I can ping the ddns I don't think that's the problem.

I had my N54 new and synology was put on using these files https://drive.google.com/folderview?id= ... sp=sharing

 

Not knowing the original mac address would this stop it?

I will try anything

Thank you for reading.

 

Later edit:

Ok all sorted. I had to port forward 5000-5001 all good now. :smile:

Link to post
Share on other sites

I've got NFS working on mine. Found this on another forum (which links back to here!) and it worked after this. Having said that, I also upgraded to DS3612xs_4.2-3211_x64 and NFS worked out of the box. FWIW, I checked for nfsd running via the ps command rather than rpcinfo.

 

 

I noticed that the nfsd.ko module wasn't being loaded - hence NFS wasn't functional. A bit of googling took me to:

viewtopic...ilit=nfs#p2600

 

It seems that the module "auth_rpcgss.ko" is required by nfsd.ko and needs to be loaded if NFS is enabled... so you just need to add the following towards the end of the /etc/rc file

 

File: /etc/rc

------------------------------------------------------------

 

..

..##### Start Load module for NFS #####

 

Support=`/bin/get_key_value /etc.defaults/synoinfo.conf supportNFS`

 

if [ "$Support" = "yes" ]; then

insmod /lib/modules/auth_rpcgss.ko

fi

 

##### END Load module for NFS #####

 

 

SYNOTunnel

 

exit 0

Link to post
Share on other sites

You need to write it to the USB stick as per the original install. The IIRC synology assistant reports your DS as upgradeable. I didn't lose any data, but I have it all backed up anyway as I have just migrated my CS407e from 500GB disks to 1TB disks - just before finding out about xpenology and the HP54l. My initial (fresh to the microserver) install did blank my disks, but I just restored from the backups. The upgrade left everything intact, though I was very nervous doing it!

Link to post
Share on other sites

I haven't read anything about this so far and so I thought I might share this with you:

 

USB3.0 controller card based on NEC D720200 is working out of the box in my N40L. No driver installation required! ~100 MB/s without any issues. I tried this card as my DS1812+ also uses that chip for USB3.0.

 

Only drawback seems to be missing hybernation, probably because DSM is installed on USB stick and DSM activity seems to prevent hybernation for all USB devices.

Link to post
Share on other sites

Hello guys,

 

I have a N40L with Xpenology in 3202 since some years ago.

But i have a problem now with reboot after a powercut.

 

The Server reboot, but is not available on the network, any ping too....

 

The WOL works without problem (thanks to a topic found here)

But i didn't find an answer to have a working reboot after power cut.

Or any reboot, and i will start with WOL if it's not online.

 

On the web interface, if i enable the case, i received error 831....

 

Thanks you in advance

Link to post
Share on other sites
Hello guys,

 

I have a N40L with Xpenology in 3202 since some years ago.

But i have a problem now with reboot after a powercut.

 

Nice, you've got it before Synology have :smile:

 

Try to enable in the HP BIOS option to start after power loss to ON or Last State.

Link to post
Share on other sites

Ok I feel like a complete dumbass.

 

I have a new hp proliant n54l and Im trying to install DSM on it so i downloaded these files https://drive.google.com/folderview?id= ... sp=sharing

What do I have to do with that theBay thing?

I try to boot through usb but I cant, the console gets stucked not with the kernel message

I read that I have to change mac, flash bios blablabla...every place I look tells something different. My head is a mess.

 

Please anybody could help me??

Thanks :sad:

 

I get stucked in this

13.552788] sde: sde1 sde2

[ 13.559352] sd 4 :0 :0 :0 [sde] No Caching mode page present

[ 13.559418] sd 4 :0 :0 :0 [sde] Assuming drive cache : write through

[ 13.559476] sd 4 :0 :0 :0 [sde] Attached SCSI removable disk"

 

Actually one member of the forum got the same error but never solved...

Link to post
Share on other sites
The one posted by Gerbenz worked straight away on my n54l. Even USB works without any tweaking.

 

viewtopic.php?f=2&t=907

 

Well, I've updated to 4.2.3211, but still no NFS for me. I do not have a file named /etc/rc. There is a file named rc.local, is that the one I need to modify? Further, when I do this command I get the following output:

 

DiskStation> insmod /lib/modules/auth_rpcgss.ko
insmod: can't insert '/lib/modules/auth_rpcgss.ko': File exists

 

I ain't getting any further for now. Any help appreciated!

Link to post
Share on other sites
Have you enabled NFS in the DSM interface? You also need to set up NFS share permissions on your shared folders.

 

Yes, that's all settled and done. I can see the shares from the clients but cannot open them. The permissions are set correctly. What is your output of insmod /lib/modules/auth_rpcgss.ko?

Link to post
Share on other sites

Mine shows the same as yours, that the module already exists. What does your's show with the command "ps |grep nfsd"?

 

Here's what my /etc/exports looks like:

 

/volume1/Movies 192.168.0.*(rw,async,no_wdelay,root_squash,insecure_locks,anonuid=1024,anongid=100)
/volume2/tv     192.168.0.*(rw,async,no_wdelay,root_squash,insecure_locks,anonuid=1024,anongid=100)
/volume4/Music  192.168.0.*(rw,async,no_wdelay,root_squash,insecure_locks,anonuid=1024,anongid=100)
/volume4/Photos 192.168.0.*(rw,async,no_wdelay,root_squash,insecure_locks,anonuid=1024,anongid=100)
/volume3/Movies\0402    192.168.0.*(rw,async,no_wdelay,root_squash,insecure_locks,anonuid=1024,anongid=100)
/volume3/TV\0402        192.168.0.*(rw,async,no_wdelay,root_squash,insecure_locks,anonuid=1024,anongid=100)

Link to post
Share on other sites

DiskStation> cat /etc/exports

/volume1/music    *(rw,async,no_wdelay,no_root_squash,insecure,anonuid=0,anongid=0)
/volume1/photo    *(rw,async,no_wdelay,no_root_squash,insecure,anonuid=0,anongid=0)
/volume1/video    *(rw,async,no_wdelay,no_root_squash,insecure,anonuid=0,anongid=0)

 

You have "root_squash", I have "no_root_squash". You have "insecure_locks", I have "insecure". The latter one for me is on purpose otherwise it seems XBMC cannot access it (following this wiki).

 

Right now I have no access to my DS, will post the output of the command "ps |grep nfsd" later.

Link to post
Share on other sites

Interesting. Mine is working fine like that under OpenELEC, with the mySQL back-end hosted under DSM. I think your problem is the no_root_squash. I'm fairly sure that's the "Map to Admin" option under the DSM NFS privilege options.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.