tinycore redpill error: disk 'hd0, msdos3'


Recommended Posts

Hi guys

 

I'm trying to boot tinycore-redpill on my machine that has an msi z270 m7 motherboard. It's currently running juns loader 1.04 with DSM 6.2.3, I wanted to get tinypill-redcore booting to go to 6.2.4. I installed tinycore-redpill 0.4.5 on my test machine and it worked fine, booted in created loader without problem, my main pc will not boot from the usb stick I get :-

error: disk 'hd0, msdos3' not found you need to load the kernel first. 

 

I have tried both uefi and legacy images, the bios on the msi is set to legacy+uefi, can anyone help 

 

TIA

Link to post
Share on other sites

I have an issue related to this one. I got xpenology installed in my NUC using tinycore. Everything runs smoothly but if I plug in the USB external disk I use for backups and for whatever the reason I need to restart the system it does not boot. Everything goes back to normal after unpluging the disk and restart 

 

I'm not and expert with grub. How could I modify TC boot usb stick to allow the system to boot with the external USD sata connected? I men permanently. It's a headless server I'd rather not connect the display an keyboard each time I reboot

 

J.A

 

Pocopico thanks a LOT for what you are doing for all of us in your free time. Ignore me if you don't have the time or have more interesting things to do.

 

  • Like 1
Link to post
Share on other sites

GRUB in TCRP is in general build to use disk0 as the first disk. This works fine for LEGACY mode as this will always be the first one. If you are using EFI then the usb stick will be enumerated in the sequence GRUB finds them. You can try to switch ports between the USB disks ? Or edit GRUB to permanently point to the disk you want to boot from. 

 

While at GRUB , You can also press e and where it says hd0 you can change to hd1 or hd2 etc and then press F10 to boot 

 

Then once booted you can mount the synoboot1 disk in DSM

 

cd /dev

mount synoboot1 /mnt

vi /mnt/boot/grub/grub.cfg

 

edit the hd0 part to hdx that works in your case.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.