Recommended Posts

@Jedie

 

can you try closed source drivers?

 

try this ones from dvb-s section s closed source drivers on my dropbox

 

dvb-core.ko

rc-core.ko

stv090x.ko

tbs6982fe.ko

tbs6680fe.ko

tbs6923fe.ko

tbs6985se.ko

tbs6928se.ko

tbs6982se.ko

tbs6991fe.ko

tbs6618fe.ko

tbs6983fe.ko

tbs6922fe.ko

tbs6928fe.ko

tbs6991se.ko

tbs6290fe.ko

tbs6984fe.ko

saa716x_core.ko

saa716x_tbs-dvb.ko int_type=1

 

unload the old ones, copy this to a diferent location and insmod them.

from modinfo say you need all them to meet dependencies.

Link to post
Share on other sites
insmod /lib/modules/dvb_test/altera-stapl.ko

insmod /lib/modules/dvb_test/cx2341x.ko

insmod /lib/modules/dvb_test/cx23885.ko

insmod /lib/modules/dvb_test/dvb-core.ko

insmod /lib/modules/dvb_test/frame_vector.ko

insmod /lib/modules/dvb_test/ir-kbd-i2c.ko

insmod /lib/modules/dvb_test/m88ds3103.ko

insmod /lib/modules/dvb_test/media.ko

insmod /lib/modules/dvb_test/rc-core.ko

insmod /lib/modules/dvb_test/tda18271.ko

insmod /lib/modules/dvb_test/tveeprom.ko

insmod /lib/modules/dvb_test/v4l2-common.ko

insmod /lib/modules/dvb_test/videobuf2-core.ko

insmod /lib/modules/dvb_test/videobuf2-dma-sg.ko

insmod /lib/modules/dvb_test/videobuf2-dvb.ko

insmod /lib/modules/dvb_test/videobuf2-memops.ko

insmod /lib/modules/dvb_test/videobuf2-v4l2.ko

insmod /lib/modules/dvb_test/videobuf-dvb.ko

insmod /lib/modules/dvb_test/videodev.ko

insmod /lib/modules/dvb_test/xc5000.ko

 

edit to etc/rc.local

 

v4l_tbs_openSource_20160826_all

https://www.dropbox.com/sh/31nkgy8ybcj8 ... gpqCa?dl=0

 

media.ko

altera-ci.ko

videobuf2-dvb.ko

videobuf2-v4l2.ko

altera-stapl.ko

frame_vector.ko

 

download from your dropbox.

 

and add firmware.

 

http://www.tbsdtv.com/download/document ... .0.tar.bz2

and

http://www.dvbsky.net/download/linux/dv ... are.tar.gz

 

but, modules can't find run in lsmod and dmesg.

 

 

thank you for helping. you are very kind man. JMRR

Link to post
Share on other sites

Hi JMRR. I was search the working, stable TVHeadend version of my synology (bromolow). I found the syno.dierkse.nl 4.0.8-1 version, but it is not working. (acces denided problem). 

Could you help me?

Now I have the 4.1 custom version, but it isn't too good. It has a some bugs.

 

 

 

Posted via Xpenology.us

Link to post
Share on other sites

tvh 4.0.8.1 is a pain in the ass to make it work.

it has a problem with autentication, when you install it, the user it adds to dsm is not the same for tvh.

the simple way is to desactivate user autentication on tvh start up, and create an admin account, them activate login again.

 

Adding the "-C" to the tvh start_stop_status script like this

 

> start_daemon () {

> ${TVHEADEND} -C -f -u ${USER} -c ${INSTALL_DIR}/var -p ${PID_FILE} -l ${LOG_FILE}

> }

 

another way is reinstall tvh and when asks for username and password use someting diferent from your dsm login like:

 

user:tvh

pass:tvh.

 

think about using 4.1 its way beter. another thing 4.0.8.1 is outdated, the last tvh version stable is 4.0.9-12(not yet on syno repo).

i dont use this versions, i have debian chroot instaled and inside i install tvh the version i want(usually the last one).

Link to post
Share on other sites

Thanks for your help. I think I will wait for the 4.0.9 version.

I have 4.1 custom version now. The biggest problem with this, when I wach the any channel on TV (streaming) sometimes the streaming is frozen. The TVH write this: "can not decode...channel". If I push the stop button, and I start the channel again, it's ok. I use the OSCAM, but it worked fine latest to my wetek play. I think it's the TVH problem. Or not? Maybee driver problem?

 

 

Posted via Xpenology.us

Link to post
Share on other sites

Hi JMRR,

 

Just a quick follow up a week or 2 on.

 

The TBS card is working great with tvheadend 4.1.2190..

The Afatech usb has stopped working after a few days a couple of times, requiring either pulling out/reinserting or unloading modules and tvheadend etc.

I think that's down to the usb drivers though..

 

Many thanks again, considering getting a tbs quad dvb-t2 card to replace the 6821 as I've had the dreaded 'no cards free' message a few times :smile:

 

Your help has allowed me to shutdown my tv server box and only run my main synology box - actually saving me money (on electricity) for once besides being 'cool' lol

Link to post
Share on other sites

good to know its working well.

 

usb devices on syno have that problem, from time to time they disconect, i dont know why but i have that problem to.

in my case i use sn usb smartreader, and even reboot doesent bring him to live, i have to shutdown and start, or unplug it and plug it again.

if some one know why , please bring it on.

 

regardling tbs i have one 6281(dual dvb-c/t) and one 6205(quad dvb-c/t), its an exelent card.

i have only one thing to try out, is to use the 6205 dvbt and dvb-c at same time, this card has only on rf in, so does any electronig guro know how to divide inpput?

 

i can combine dvb-c and dvb-t on same cable with a diplexer, but it lost a lot of signal( but works), so its possible.

i would like to have 2 tunners on dvb-c and other tu tunners on dvb-t, and remove the 6281.

atm i have 6281 using dvb-t(dual), and 6205 using dvb-c(quad), the only way to do this is using open source drivers because tbs doesent allow this on closed source ones( dont know why).

 

the last option is to use um usb dvb-t card, does any one know a good one(preferebly dual, but single is good too).

Link to post
Share on other sites
  • 1 month later...

Thank for your script JMRR,

 

Do you think something similar can be done on DSM6?

This because I have recently updated my Xpe 5.2 to 6.0 and now my USB dongle is not anymore recognized (Elgato EyeTV DTT Deluxe).

Seems that the drivers are still in /lib/modules/backports_dvb/ but as I am a noob in Linux administration, a little help would be very very useful :grin:

 

* I have tried to load the module dvb-usb-dib0700.ko with insmod but the system tells me that some symbols are missing and modinfo command is not existing anymore on DSM6 :oops:

Link to post
Share on other sites

i didnt try dsm6, because only have one nas.

i think its possible , if modules are compiled against dsm source, ans tool chains.

give me a few days and lets see what happens.

the only think i dont know is if the loader has DVB enabled or not.

Link to post
Share on other sites
Usualy its a dependence, another module needs to be aloaded first.

What card and what module gives you that?

 

Tested with some drivers and the errors is with all tested .

I have not this error with the original drivers found in folder and compiled by Synology

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.