Powermanagment Redpill 7.0.1-42218


Recommended Posts

Hallo,

wie hier schon berichtet https://xpenology.com/forum/topic/56438-dsm-70-loader-mit-redpill/ , habe ich in der zwischenzeit mit dem Loader 7.0.1-42218 laufen. Leider habe ich nun ein Powermanagment Problem festgestellt. Folgende Probleme:

  • "Neustart" - Maschine fährt herunter. Festplatten schalten sich aus, jedoch leuchtet die POWER-LED weiter. Erst nach gedrückt halten des POWER Buttons, geht die LED aus
  • "Herunterfahren" - Bildschirm wird schwarz und Maschine fährt in so eine Art Ruhemodus.
  • "HDD Sleep-Modus" - Wenn ich einstelle, das die Festplatten nach 10min (oder sonst was) in den Sleep-Modus gehen sollen, tunsie das nicht und laufen daher 24/7
  • "USB Sleep Modus" - OK - Wenn ich einstell, das die USB HDDs nach 10min in den Sleep Modus sollen, tun sie das auch.

Ich hatte zuvor Jun's Loader 1.04b am laufen mit der Version DSM 6.2.3-25426 Update 3. Da hat alles einwandfrei funktioniert. Hatte dort sogar die Powerbutton.spk am laufen und funktionierte (https://xpenology.com/forum/topic/7195-power-button-package/page/4/)

Hat jemand eine Idee wo ich da einmal schauen kann bzw. etwas ändern kann?

Ciao

Link to post
Share on other sites
11 hours ago, Redjewel said:
  • "Neustart" - Maschine fährt herunter. Festplatten schalten sich aus, jedoch leuchtet die POWER-LED weiter. Erst nach gedrückt halten des POWER Buttons, geht die LED aus
  • "Herunterfahren" - Bildschirm wird schwarz und Maschine fährt in so eine Art Ruhemodus.

für das problem kann man in der grub.cfg dem kernel parameter mitgeben

hier wurde ein "quiet" entfernt

https://xpenology.com/forum/topic/12240-installing-xpenology-on-acer-aspire-h340/page/2/?tab=comments#comment-207377

aber es gibt jede menge parameter

http://redsymbol.net/linux-kernel-boot-parameters/4.4/

acpi=off und noapic fallen mir da ein

Link to post
Share on other sites

Hallo @IG-88

danke für die Links. Natürlich war ich die Zeit über nicht untätig :-). Habe in der Zwischenzeit einmal die grub.cfg von 6.2.3 und 7.0.1 verglichen. Genau dieses "quiet" ist mir da auch aufgefallen. In 6.2.3 vorhanden, bei 7.0.1 hat es gefehlt. Habe es einmal hinzugefügt bei 7.0.1, jedoch keine Besserung.

Werde nun einmal mit acpi=off etc. herumprobieren.

Ciao

Link to post
Share on other sites
Posted (edited)

Hallo

hat alles nichts gebracht.

Habe aber eine Lösung gefunden

  • "Neustart" - ✔

  • "Herunterfahren" - ✔

  • "HDD Sleep-Modus" - ✔

  • "USB Sleep Modus" - ✔

Über einen Link (den ich in einem Beitrag von IG-88 gefunden habe) https://linux-hardware.org/?view=computers&type=notebook&vendor=Medion&model=Akoya+E4214+MD99570 habe ich herausgefunden, das ACPI funktioniert.

Nach einer Google Suche "E4214 acpi" bin ich auf folgende Seite gestoßen.

https://bugzilla.kernel.org/show_bug.cgi?id=100691

 

Und hier fand sich die Lösung. Im BIOS umstellen auf UEFI.

 

Danke eurer Unterstützung.

 

Edited by Redjewel
Solution, Lösung
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.