Second Nic Not Seen - TinyCoreRedPill


Recommended Posts

I just loaded up tinycore redpill, ran my script, worked great, loaded up first try - but I only see one of my two onboard nic's. They are both realtek 8159. I added all the appropriate mac/vid/pid/serial in the user_config.json and verified it was added (mac1 and mac2) and still nothing. I even redid the usb and started all again, and still only sees 1 lan not 2.

 

Any idea how to troubleshoot this?

Link to post
Share on other sites

hey, I was in the same boat as you, and this issue seems to be the boogie man, because every time someone asks about, it gets completly ignore...

This is how I solved my problem... it was so simple but people complicate it so much I almost gave up.

 

in my case I upgraded my 6.2.4 to Redpill tinycore loader 7.0.1. Ended up loosing all my files, but good thing I have backups.

after that I started from Scratch. Burned a new USB drive. did all the Instructed procedures, just to end up with the reboot/restore loop. was trying to install DS3617xs.

Then I tried DS3615xs and kept getting the drives errors (3,4 disable bla bla bla). 

Finally decided to go with DS3622xs+ did all the instructed procedures. but.... and here is the simple thing....

when it was time to install the ext. the links I was trying was wrong.

In my case I need to install the r8125 ext for my NICGIGA NIC-2.5G.

if you (like me) follow the instruction, you are suppose to enter the command:

sudo ./rploader.sh ext broadwellnk-7.0.1-42218 auto 

or

sudo ./rploader.sh ext broadwellnk-7.0.1-42218 add (and the link of the ext)

 

but if you go to https://github.com/pocopico/rp-ext and try to copy the ext link from there, you will get errors.

in my case i was trying:

https://github.com/pocopico/rp-ext/tree/main/r8152

or 

https://github.com/pocopico/rp-ext/blob/main/r8152/rpext-index.json

or 

https://github.com/pocopico/4.4.180plus-broadwellnk/blob/main/r8125.ko

etc....

none of them worked, what finally worked for me was to open the file at https://github.com/pocopico/rp-ext/blob/main/r8125/rpext-index.json and get the link from inside the file. 

sudo ./rploader.sh ext broadwellnk-7.0.1-42218 add https://raw.githubusercontent.com/pocopico/rp-ext/master/r8125/rpext-index.json

image.thumb.png.41768072862fc223bdf35bfbee591ec3.png

 

after that I follow the rest of the instructions and it finally got all my NIC to work.

here is what I did from Start: 

Broadwellnk - DS3622xs+    Intel Xeon D-1531    Six Core    12    Yes    Broadwellnk    DDR4 ECC SODIMM 16 GB

sudo ./rploader.sh update now
sudo ./rploader.sh serialgen DS3622xs+ now
sudo ./rploader.sh satamap now
sudo ./rploader.sh identifyusb now
sudo ./rploader.sh ext broadwellnk-7.0.1-42218 auto 
sudo ./rploader.sh ext broadwellnk-7.0.1-42218 add https://raw.githubusercontent.com/pocopico/rp-ext/master/r8125/rpext-index.json
sudo ./rploader.sh build broadwellnk-7.0.1-42218
sudo ./rploader.sh backup now
sudo reboot

Update to latest DSM. at first reboot. boot into TC Loader and run:

sudo ./rploader.sh update now
sudo ./rploader.sh backuploader now
sudo ./rploader.sh download broadwellnk-7.0.1-42218
sudo ./rploader.sh ext broadwellnk-7.0.1-42218 add https://github.com/jumkey/redpill-load/raw/develop/redpill-misc/rpext-index.json
sudo ./rploader.sh postupdate broadwellnk-7.0.1-42218
sudo reboot

 

Hope this helps you and anyone else having this problem. if you need more help, let me know which driver you are trying to install and ill try to help.

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.