Jump to content
XPEnology Community

XPEnology doesn't restart


matt06
 Share

Recommended Posts

Hello everybody,

 

first of all, sorry for my english mistakes: i'm french.

 

Here is my hardaware: HP Proliant N54L

my software: I think it's DSM 5.2 5565

 

I'm using Plex to watch movies and recently this app asked me to restart my server. I did it and since, it's stucked.

The synology assistant doesn't see my server anymore.

So i plugged a screen and keyboard to my HP Proliant and:

When i start it, after a few seconds, i have a windows that give me the choice between:

- XPENolgy

- Debug XPENology

- Install / Upgrade XPENology

IMG_20160621_141613.jpg

Sorry for the shitty quality

 

If i click on "XPENology", i can see a quick message at the bottom left. Something like "installing the image..." then.... BLACK. Nothing.

I tried to click on "debug", it does the same.

 

I have no idea of what to do.

Could you help me please?

Thanks :wink:

Link to comment
Share on other sites

Better than my French :

There are guys on here who know much, much more than me

I think your USB stick with the bootloader on it may be the problem.

I would get another USB stick, install a new copy of XPEnoboot on it and try to boot my server with it.

Link to comment
Share on other sites

Hi, thank you for the answer

i don't really like to have to spend time to fix this problem so i'm thinking that if anyway, i have to work on this USB stick, maybe i shoulduse this time to upgrade my software.

what do you think?

what's the latest and best software to put on this usb stick to have DSM working on it?

Link to comment
Share on other sites

I would use the same version that you have now.

If we are fault finding then we should only change one thing at a time.

And, unless you plan to also upgrade DSM itself (a much longer job), you don't need a later version of the bootloader on USB.

One other thing. If you made any changes to the config files on the original USB, you need to make the same changes to the new stick.

Link to comment
Share on other sites

Thank you for your answer. i'm gonna follow your advice

 

well, i wanted to work on this but... i'm completly lost. It's been a while since i didn't change anything and since i "worked" on my NAS.

I even don't remember what kind of boot i have. I couldn't find any file on my computer about this or any saved linkse for internet :/

 

Does anyone has a link to an easy tutorial for me to put back the same configuration please? (i didn't make any changes to the config files on the original USB)

Link to comment
Share on other sites

You can follow the first few steps of this

https://xpenology.us/node/401

First download the correct version of xpenoboot from here https://xpenology.us/downloads/xpenoboot You need the one that matches the version displayed on your screenshot.

Then, as the tutorial says, use win2diskimager to create the new usb.

replace the old USB in the N54l with the new one and boot.

You want to select "normal" boot as you already have DSM installed on your disks.

Now either it all works :smile: or we find that unfortunately the problem is somewhere else.

Link to comment
Share on other sites

  • 3 weeks later...

Hi,

thanks for your help

i did everything in the same time:

I re-installed (on the same USB key for the moment) xpenoboot

and i installed the last DSM version (DSM 5.2-5644 Update 5)

 

I'm just a bit annoyed because it's the second time it happens and i have no idea why.

Why does the boot "brakes" when i just restart the NAS....? the USB Key looks fine.... is there any tool to check the fiability of a USB Key?

Link to comment
Share on other sites

Have you looked in DSM to see if your USB boot device is showing as a usb removable device? Check the logs to see if it says 'usb device not ejected properly'. Maybe your usb chip is getting corrupted?

you can stop the usb chip showing up in dsm by masking the vendor details at boot

http://xpenology.me/how-to-see-the-valu ... pid-stick/

https://xpenology.us/tutorials/miscella ... -usb-drive

Link to comment
Share on other sites

OK, so

to look in DSM to see if my USB boot device is showing as a usb removable device, i need to go to the "boot menu", is that right?

 

And, how to check the logs, please?

 

Thank you

 

edit: i was a bit worried but i tried to restart DSM. Everything is fine now. I didn't change the USB key but i re-install the boot on it and upgraded DSM. So i still don't know why the boot broke.... i hesitate to buy a new USB key.

What do you think?

Link to comment
Share on other sites

 Share

×
×
  • Create New...