oktisme

Working DSM 6

Recommended Posts

@hurlyhunk, you have to use ESXI 6.0 U2. It won't run on 6.0.... ask me how i know. Please review all posts as there is good usable info in this thread. I have it working in ESXI 6.0 U2. It would not operate until I upgraded from 6.0 to 6.0 U2.

Share this post


Link to post
Share on other sites

Hello everyone, when I use ESXI 6.0 U2 for DSM 6, I have no way to see my Disk info thru S.M.A.R.T. In other words, my Nas has no spin down (hibernation) at all.

For those who are using ESXI 6.0 U2, can you see it?

Thanks.

Share this post


Link to post
Share on other sites

Upgrade from DSM5 to 6 worked perfectly on my physical server, a few weeks later I forgot my Password unfourthly.

Since this no original DSM Hardware there is no Reset Button, anyone an Idea?

 

resetuser=admin dosent't work. I also tested installing DSM on a new Disk and then putting the old ones in, doesn't work either :sad:

Share this post


Link to post
Share on other sites
Hello everyone, when I use ESXI 6.0 U2 for DSM 6, I have no way to see my Disk info thru S.M.A.R.T. In other words, my Nas has no spin down (hibernation) at all.

For those who are using ESXI 6.0 U2, can you see it?

Thanks.

 

Depends on how your drives are passed through to DSM. If they're on a RAID card then you're SOL (majority of the time), if they're on an HBA that doesnt pass SMART data, you're SOL.

Share this post


Link to post
Share on other sites
Upgrade from DSM5 to 6 worked perfectly on my physical server, a few weeks later I forgot my Password unfourthly.

Since this no original DSM Hardware there is no Reset Button, anyone an Idea?

 

resetuser=admin dosent't work. I also tested installing DSM on a new Disk and then putting the old ones in, doesn't work either :sad:

 

 

Synology DSM has a default telnet password, and you can find generators online. It's unique each day per code that's part of the OS, so as long as you have telnet responding on the device, you can log in as root with the daily password.

 

Here's one such site, and there are many others.

 

https://wrgms.com/synologys-secret-telnet-password/

Share this post


Link to post
Share on other sites
Upgrade from DSM5 to 6 worked perfectly on my physical server, a few weeks later I forgot my Password unfourthly.

Since this no original DSM Hardware there is no Reset Button, anyone an Idea?

 

resetuser=admin dosent't work. I also tested installing DSM on a new Disk and then putting the old ones in, doesn't work either :sad:

 

 

Synology DSM has a default telnet password, and you can find generators online. It's unique each day per code that's part of the OS, so as long as you have telnet responding on the device, you can log in as root with the daily password.

 

Here's one such site, and there are many others.

 

https://wrgms.com/synologys-secret-telnet-password/

Sadly no Telnet active, anyone other ideas?

Share this post


Link to post
Share on other sites

One I built with DSM6 decided to lose its' mind on me last week and could not be reached on any service port. I followed this basic process though I performed a full install of Ubuntu onto a thumb drive and installed the requisite drivers and LVM etc.. and was able to copy all of my data off to an external drive. It loaded the raid partition as a single volume and let me "see" all directories and shares.

 

https://www.synology.com/en-us/knowledg ... using_a_PC

 

I don't know precisely what happened, but after enabling Jumbo Frames and changing DNS on the box, it said F to the U, and no longer wanted to play nicely. After my data was recovered I just flattened the drives and started from scratch. I did find within the logs via reading them with Ubuntu that a particular file refused to load, but it was in usr\lib and even with it mounted in Windows using Paragon Software's EXT piece I was unable to rename or replace the file with the previous version, so I threw in the towel and smoked it. You might be able to locate the proper password repository on the box if you are feeling frisky.

Share this post


Link to post
Share on other sites

I'm having a bit of problems in making this work under VirtualBox.

I managed to have the Install version up, being recognized by Synology Assistant and set up *apparently* without errors.

Unfortunately next boot I get a welcome screen stating they detected the disks were moved from a previous DS3615xs and so I need to install a newer DSM before proceeding (doing so just reiterate the loop).

 

Most likely I goofed somewhere (I'm not even sure I got sn/MAC right), but I have no clue where (I'm quite new to xpenology).

Can someone help me, please?

TiA

Share this post


Link to post
Share on other sites
HP N54L

Boot = in installation mode

Installation DSM6 = ok

Update via webgui = ok

Build volume = Can't

 

Has anyone had success with HP N54L and the AMD CPU? What error gives with build volume?

Share this post


Link to post
Share on other sites
HP N54L

Boot = in installation mode

Installation DSM6 = ok

Update via webgui = ok

Build volume = Can't

 

Has anyone had success with HP N54L and the AMD CPU? What error gives with build volume?

 

Are you trying to build the volume as EXT4 or BTRFS? I have not seen BTRFS work yet in either a VM or a physical using DSM6. EXT4 works fine.

Share this post


Link to post
Share on other sites
HP N54L

Boot = in installation mode

Installation DSM6 = ok

Update via webgui = ok

Build volume = Can't

 

Has anyone had success with HP N54L and the AMD CPU? What error gives with build volume?

 

Are you trying to build the volume as EXT4 or BTRFS? I have not seen BTRFS work yet in either a VM or a physical using DSM6. EXT4 works fine.

 

I did not try yet, I don't know about

, but I will do it in EXT4. Thanks :smile:

Share this post


Link to post
Share on other sites

Has anyone else experienced an issue getting the Serial to load and display? Mine works fine in a VM, but refuses to work in a physical box with DSM6. I have tried multiple Serials as well as different configurations in the syslinux.cfg but none result in the system displaying the serial in the Info Center. VID and PID values are correct in the config as well.

Share this post


Link to post
Share on other sites
HP N54L

Boot = in installation mode

Installation DSM6 = ok

Update via webgui = ok

Build volume = Can't

 

Has anyone had success with HP N54L and the AMD CPU? What error gives with build volume?

 

Are you trying to build the volume as EXT4 or BTRFS? I have not seen BTRFS work yet in either a VM or a physical using DSM6. EXT4 works fine.

 

Btrfs seems to work fine for me. I am running it inside vmware.

http://imgur.com/a/ep6Ru

Share this post


Link to post
Share on other sites

I'm successfully running a DSM 5 install on my Linux machine in VMWare (headless). Is it possible to upgrade it to 6? If yes, how?

I tried to copy over the Boot image from here and boot my DSM 5 VM to upgrade to 6, but it didn't even boot (stops after the kernel messages). I also added a serial interface but it didn't help.

Share this post


Link to post
Share on other sites

Been watching these forums for a while, and it looks like DSM 6 finaly is about to be working. Am I right?

Currently running ESXi 6 (build 4192238) @ HP ProLiant Microserver G8

 

Will this work with my setup? Any short guide going from DSM 5.2-5644 Update 5 to DSM 6 would be very handy (Y)

Share this post


Link to post
Share on other sites
Any short guide going from DSM 5.2-5644 Update 5 to DSM 6 would be very handy (Y)

 

Would appreciate this as well, I'm in the exact same position. I haven't been able to understand the process even after reading the thread.

Share this post


Link to post
Share on other sites
Any short guide going from DSM 5.2-5644 Update 5 to DSM 6 would be very handy (Y)

 

Would appreciate this as well, I'm in the exact same position. I haven't been able to understand the process even after reading the thread.

 

Burn Image to USB Stick, plug it in, goto find.synology.com and Migrate

Share this post


Link to post
Share on other sites

Will migrating from DSM 5 to DSM 6 cause to loose any data on SHR raid when upgrading?

 

Can you provide a link to the image file to use?

 

 

Thanks

Share this post


Link to post
Share on other sites

I would also like to know about this.

I installed DSM 5 onto my Microgen8 with XPEnoboot 5.2-5967.1 (17/07/2016) tutorial.

 

Any idea's on how to upgrade to DSM6.0, i don't want to just start installing whatever because i dont want to screw up my nas.

 

I doubt it's as easy ''Burn Image to USB Stick, plug it in, goto find.synology.com and Migrate''

 

The version must be cracked or something no?

Share this post


Link to post
Share on other sites

I migrated from the latest version of XPE 5.2 to 6 on SHR without any data loss. It's called a "migration" and DSM handles it perfectly.

 

@foster182, your doubt is pretty close to exactly what I did. The only difference is that when you burn the dsm6 loader to USB just make sure to enter your config for SN and MAC address.

Share this post


Link to post
Share on other sites
I migrated from the latest version of XPE 5.2 to 6 on SHR without any data loss. It's called a "migration" and DSM handles it perfectly.

 

@foster182, your doubt is pretty close to exactly what I did. The only difference is that when you burn the dsm6 loader to USB just make sure to enter your config for SN and MAC address.

 

That's great, can you tell me which version DSM 6 you upgraded to?

 

Also, if you have a link to loader you used that would be great.

I'd like to do the upgrade procedure as you did, cannot afford to screw up my nas :smile:

 

Thanks

Share this post


Link to post
Share on other sites

Hi, to all i just update to DSM 6.0.2-8451 Update 3 no problems so far :smile:

 

i have a hp microserver Gen 8

Share this post


Link to post
Share on other sites

To everyone wanting to migrate to DSM 6:

The Jun loader contains only part of the drivers of trantor's loader. So, part of your hardware might not be recognized. So far, there is no compatibility page, so I guess one should be made as soon as possible.

I don't know if the missing drivers is something that can be solved in a new version of Jun's loader, so all such problems will be solved.

Share this post


Link to post
Share on other sites

please I have a hp microserver gen 8 with dsm 5.2.5644, what is the best bootloader for upgrade??and what I have to do, install manually last version of dsm fron synology?

 

EDIT: follow this thread viewtopic.php?f=2&t=22100, it works for me updating from 5.2.5644, use jun's loader v1.1, find.synology.com, migrate, install manually last update from dsm, wait until reboot, find.synology.com again, and voila! update then to update 3 of dsm 6.0.2 directly from dsm no problem.

Share this post


Link to post
Share on other sites
EDIT: follow this thread viewtopic.php?f=2&t=22100, it works for me updating from 5.2.5644, use jun's loader v1.1, find.synology.com, migrate, install manually last update from dsm, wait until reboot, find.synology.com again, and voila! update then to update 3 of dsm 6.0.2 directly from dsm no problem.

 

 

 

Does this process work on ESXI 6u2 as well?? Since I use SSD to hold my VMs including DSM 5.2-5967, can I just load the necessary files on datastore SSD?

 

 

If you can please provide some instructions, that would be really helpful. I just don't want to loose all my stuff on the SHR volume.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.