oktisme

Working DSM 6

Recommended Posts

Thanks for your fast answers...

 

 

The disks appears in the storage admin, but can't create neither "Group of disks" nor "Volumes".

 

 

No SMART info available or Health Report from disks.

 

 

Any ideas?!

Share this post


Link to post
Share on other sites
I got DSM 6 working on a PC, not VM.

 

The only way I got it:

 

1. Restore default configuration, in a installed 5.2-5644 PC system.

2. Boot with Xpenoboot 5.2-5644 USB pendrive

3. Access web for first config, but not use "manual installation", I choose "install now".

4. After several minutes downloading from synology, the system reboots with actual DSM 6.0.1-7393.

 

I don't know if people can't update their systems or the problems about upgrading are VMs (VMware, ESXi) related.

For now, the only service that doesn't work is "Resource Monitor", if open a message about network error appears, and close automatically.

 

Thanks for the Xpenology community and developers!!!

I did a test here in VMWARE, No need to restore procedure, just do a clean install with DSM_DS3615xs_7393.pat version DSM 6.0.1-7393 and XPEnoboot_DS3615xs_5.2-5644.5 that you will be able to install, but is not recognizing installed HD, CPU, network, and most other things.

Share this post


Link to post
Share on other sites
Thanks for your fast answers...

 

 

The disks appears in the storage admin, but can't create neither "Group of disks" nor "Volumes".

 

 

No SMART info available or Health Report from disks.

 

 

Any ideas?!

If you checked other threads, you would find out that you didn't discover anything new :wink:

Share this post


Link to post
Share on other sites

Ok abced,

 

I only found problems with the VMs installations of Xpenology, but nothing about baremetal enviroments. Too fast (and excited) and surprised when the system boots with the new DSM.

 

Then I'll wait for the future Xpenology packages.

 

Thanks for your fast answers.

Share this post


Link to post
Share on other sites

@oktisme,

 

Can you list the files you pacthed on the VM ?

 

I want to try to install v6 and overwrite it with patched files.

 

Thanks

Share this post


Link to post
Share on other sites

I got it working the first day it was out. on bare metal. but like eveyone said can't crate volumes. this is the problem we are all facing when updating thru Synology control panel and no new xpenoboot.

 

 

I got DSM 6 working on a PC, not VM.

 

The only way I got it:

 

1. Restore default configuration, in a installed 5.2-5644 PC system.

2. Boot with Xpenoboot 5.2-5644 USB pendrive

3. Access web for first config, but not use "manual installation", I choose "install now".

4. After several minutes downloading from synology, the system reboots with actual DSM 6.0.1-7393.

 

I don't know if people can't update their systems or the problems about upgrading are VMs (VMware, ESXi) related.

For now, the only service that doesn't work is "Resource Monitor", if open a message about network error appears, and close automatically.

 

Thanks for the Xpenology community and developers!!!

Share this post


Link to post
Share on other sites

@koroziv @haydibe @otisme

 

Deployed the OVF you shared in ESXi 6U2 and everything worked plus updates and PCIe passthroughs. So I'm thinking of moving my 'production' disks over to DSM6. But I wanted to ask if I could start fresh, then modify the syslinux.cfg (is it the one in syslinux folder) in the VMDK-0 to use my real Synology DS mac id and serial number?

 

Thanks for the hard work effort and sharing your your finds with us....Much appreciated!

Share this post


Link to post
Share on other sites
Any idea when Xpe 6 can by relased? :ugeek:

Its source has not been released (yet), so only the current devs can work on it currently I guess.

Share this post


Link to post
Share on other sites
@koroziv @haydibe @otisme

 

Deployed the OVF you shared in ESXi 6U2 and everything worked plus updates and PCIe passthroughs. So I'm thinking of moving my 'production' disks over to DSM6. But I wanted to ask if I could start fresh, then modify the syslinux.cfg (is it the one in syslinux folder) in the VMDK-0 to use my real Synology DS mac id and serial number?

 

Thanks for the hard work effort and sharing your your finds with us....Much appreciated!

 

Edit what ever you want in the cfg, just test it before on a test vm; no point risking your data :smile:

Personally I still use the old version, can't setup dsm 6 the way I like it.

Tried to add a 1 Tb drive to the vm using RDM, not working. It says the drive is bigger than the availe space on a datastore (that contains the virtual disks created before).

rdm6.jpg

For some reason a few subnets that my internet provider is using can't access this forum; tried posting from xpenology.us but what I post from there doesn't appear here. So I have to use other ways to get here (proxy, vpn). I sent a pm to the forum admin but so far nothing.

Share this post


Link to post
Share on other sites

Just thought I would chip in with my experience.

 

I've just installed this on EMu/KVM on my QNAP server, more commonly known as Virtualization Station.

 

No problems what so ever. All I needed to do was the patch ISO file and used the PAT file to install the DSM OS.

 

I'm using and IDE ISO boot and normal SATA HD emulation for the Harddisk.

 

On the NIC side of thing its the Intel e1000 adapater. and networking is working fine.

 

Everything has worked great. I've created a 40GB volume I then use with NFS boot mounting to mount my QNAP shares to the DSM6 OS. :grin:

 

The only thing that isn't working yet is the quickconnect, but I'm pretty sure that is down to some other settings (time sync or double NAT, I've already got a valid mac/sn pair) and will get that sorted when I have time.

Share this post


Link to post
Share on other sites

Hi,

 

I use the OVF you shared in ESXi 6U2.

Where can I find and edit the syslinux.cfg?

 

Thanks in advance

omega

Share this post


Link to post
Share on other sites

Hi all,

 

For your information RDM on a SATA controller in ESXi does not work very well (no sleep at all). Only read & write instructions are transferred, no power management. So it's better to wait a new kernel with SCSI drivers included to get RDM fully working.

Share this post


Link to post
Share on other sites
I also had the same issue, fixed it by installing an updated version of the webUI.

 

Download it from here: https://labs.vmware.com/flings/esxi-emb ... ost-client

 

Filename is esxui-signed-3976049.vib.

 

For me it works perfectly, I can edit the vm from the webui.

I allready have the latest version, and I can edit settings just fine, only in this case I have issues with RDM.

 

@ omega

syslinux.cfg should be on the boot disk, but I can't be sure, I didn't make it; until now it was there (dsm 4-5)

@ koalala

Thanks for the RDM information.

Share this post


Link to post
Share on other sites

I’ve found it in disk-0.vmdk - thanks

 

My solution:

set disk-0.vmdk to independent-persistent

export disk-0.vmdk to Win

use ImDisk Virtual Disk Driver to mount the vmdk

edit syslinux.cfg

ImDisk Virtual Disk Driver (as Administrator!!!) – remove mounted disk

Import vmdk files to ESXi

set disk-0.vmdk to independent-non persistent

Share this post


Link to post
Share on other sites

Hi Would like to thank oktisme other forum members for all the hard work and time providing support to make it possible to run DSM6 on VM/ESXi

 

I just wanted to share my experience with VMware Fusion and ESXi6u2

1. DSM 6 VM (any version 12, 11 and 10) works perfectly fine with VMware Fusion 8.1 on my Mac.

2. Tried to export DSM 6 VM to OVA format but failed, used v2v convertor for the vmdk image files and after that I can successfully export to ova format

3. Tried to import to ESXi6u2 imported successfully but failed to boot the disk.

4. Tried to install DSM 6 using the provided ISO and PAT file on VMware Fusion 8.1 as Version 12. First booted with Install option and installed the dsm 6 using the provided patched pat file. on first reboot, selected option RUN but dsm is in Migration state (failed)

5. Imported the provided ova file with 16GB of disk image to ESXi6u2. It booted successfully as hardware version ESXi5.5. configuration done. Created Disk Group and volume with BTRFS. Everything super smooth. (OVA imported and worked successfully)

6. from step 5 I upgrade the VM hardware version to ESXi6 and on boot DSM status in in Migration mode. (failed with hardware version ESXi6)

7.same as step 4 I tried to manually install using ISO and PAT file on ESXi6 but failed. As on first boot use Install and after installing DSM on second boot used RUN but DSM is in migrations state. (failed)

8. As in Step 5 I noticed that when I imported the ova file it is ESXi version 5.5. So I manually created a virtual machine in ESXi6u2 with Hardware version ESXi5.5 with the first boot disk as IDE (independat/non-presistent) and second disk SATA (independent/persistent). I booted from the ISO file and selected install. After installing DSM 6 with the provided PAT file system rebooted , this time system used boot HDD and RUN option. DSM 6 is ready (Manual Install Successful)

 

Conclusion:

1. Anyone want to install manually on ESXi6u2, create a new VM with hardware version ESXi5.5, follow other guide lines for disk and it works perfectly. While creating vm on ESXi you can choose the disks to be thin provisioned. It works perfectly fine.

2. Similarly if anyone want to install of VMWare Workstation/Fusion I suggest to use HardwareVersion 10 which is compatible with ESXi5.5 don't forget to change the ethernet to e1000e in .vmx file manually.

 

Questions:

a. Why DSM 6 does not work with ESXi hardware version ESXi6 ?

--> At the moment I am not experienced with ESXi. anyone experienced might be able to guide or point to the right direction

 

b. How can I install the vmware tools? is there any added advantage for DSM?

 

c. To oktisme, can you guide me or direct me to the some wiki , how can I setup and patch DSM 6 myself?

Share this post


Link to post
Share on other sites
I’ve found it in disk-0.vmdk - thanks

 

My solution:

set disk-0.vmdk to independent-persistent

export disk-0.vmdk to Win

use ImDisk Virtual Disk Driver to mount the vmdk

edit syslinux.cfg

ImDisk Virtual Disk Driver (as Administrator!!!) – remove mounted disk

Import vmdk files to ESXi

set disk-0.vmdk to independent-non persistent

VMware Workstation can mount the vmdk itself for editing, right?

Share this post


Link to post
Share on other sites
I’ve found it in disk-0.vmdk - thanks

 

My solution:

set disk-0.vmdk to independent-persistent

export disk-0.vmdk to Win

use ImDisk Virtual Disk Driver to mount the vmdk

edit syslinux.cfg

ImDisk Virtual Disk Driver (as Administrator!!!) – remove mounted disk

Import vmdk files to ESXi

set disk-0.vmdk to independent-non persistent

 

I'm able to download the existing VMDK and map it to a drive in windows using VMWare Workstation without having to convert. So I could edit the syslinux.cfg directly and then save, disconnect and re-upload to the datastore. The DSM then assumed the mac-id and serial number of my existing Synology box. However, I'm still getting a system error whenever I try to setup the QuickConnect to login to Synology. In the prior version, I was able to use QuickConnect, but it seems DSM 6 probably requires flashing the network adapter to change the mac-id.

Share this post


Link to post
Share on other sites
Just thought I would chip in with my experience.

 

I've just installed this on EMu/KVM on my QNAP server, more commonly known as Virtualization Station.

 

No problems what so ever. All I needed to do was the patch ISO file and used the PAT file to install the DSM OS.

 

I'm using and IDE ISO boot and normal SATA HD emulation for the Harddisk.

 

On the NIC side of thing its the Intel e1000 adapater. and networking is working fine.

 

Everything has worked great. I've created a 40GB volume I then use with NFS boot mounting to mount my QNAP shares to the DSM6 OS. :grin:

 

The only thing that isn't working yet is the quickconnect, but I'm pretty sure that is down to some other settings (time sync or double NAT, I've already got a valid mac/sn pair) and will get that sorted when I have time.

 

Hi! I use: DSM_DS3615xs_7393.iso for booting in my KVM virtual machine. Last thing what i did before some time ago i just update my DSM to vers 6.

 

But if i boot then i dont found my virtual dsm in network.

 

And log screen stays like this:

 

Booting kernel...

 

I read somewhere here before it is ok and run behind etc.

 

I have there mounted disks in raw and IDE mode.

 

As i do everything correctly or what i must chek to get it work back?

 

Sorry about my english! :smile:

 

Thnx!

Share this post


Link to post
Share on other sites

Ok,

 

I didn't get it to run on the run option, only the install option. So I modified the linux boot cfg to boot the install option as default. It does take ages to boot so leave it for 30mins have a cup of coffee and come back to it. Then use the synology finder to setup with the pat file.

 

I've tried getting quickconnect to function but not luck. Anyone else got it to work on DSM6 and Xpenology?

Share this post


Link to post
Share on other sites

Still trying to get QuickConnect working.

I've tried changing DNS servers

Disabling IPv6

Disabling Firewall

 

But still get the same error.

 

Is it possible that this has been blocked from inside DSM somehow?

Share this post


Link to post
Share on other sites
I also had the same issue, fixed it by installing an updated version of the webUI.

 

Download it from here: https://labs.vmware.com/flings/esxi-emb ... ost-client

 

Filename is esxui-signed-3976049.vib.

 

For me it works perfectly, I can edit the vm from the webui.

I allready have the latest version, and I can edit settings just fine, only in this case I have issues with RDM.

 

@ omega

syslinux.cfg should be on the boot disk, but I can't be sure, I didn't make it; until now it was there (dsm 4-5)

@ koalala

Thanks for the RDM information.

 

 

You are right, it doesn't work when you want to add RDM disks. But you can use vcenter to add RDM disks. If you don't have a vcenter setup you can deploy the VCSA, once you add the disks you can delete the appliance if you don't plan to use it since it's a trial version.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.