Jump to content
XPEnology Community

Wake-On-LAN for unicast packet


TomS.
 Share

Recommended Posts

Greetings all,

 

For those with working Wake-On-LAN (WOL), has anyone configured their NAS to wake on a unicast packet instead of the default magic packet?

ethtool -s eth0 wol u 

The above command returns to the prompt with no feedback for my nForce 430. A look at the adapter status shows that wol is unchanged at Ma"g"ic Packet.

 

nas-ftw> ethtool eth0
Settings for eth0:

       Supports Wake-on: g
       Wake-on: g
       Link detected: yes

I suspect other wake modes have not been implemented in forcedeth, Nvidia's nForce 4 driver for Linux because of the "Supports.. line. Other OS, same NIC, will wake up on unicast. e.g. Windows | Device Manager | nforce nic | Wake on Lan | Allow this device to wake the computer, and _not_ checking only allow a magic packet to wake.

I'd appreciate any reports of the output from below for other NIC hardware.

ethtool

&

ethtool -i

for NIC standard information and driver version.

 

This is a home system. My goal is to let it sleep after some inactivity, ACPI S3 suspend to RAM, wake up within 30sec when any client attempts a transaction (media, file, print), then fall back asleep. For longer periods of inactivity, it already hibernates properly.

Thank you in advance.

Link to comment
Share on other sites

Here is output from my Intel SS4200 (NIC is a Intel 82573E):

 

DiskStation> ethtool eth0
Settings for eth0:
       Supported ports: [ TP ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Full
       Advertised pause frame use: No
       Advertised auto-negotiation: Yes
       Speed: 1000Mb/s
       Duplex: Full
       Port: Twisted Pair
       PHYAD: 1
       Transceiver: internal
       Auto-negotiation: on
       MDI-X: off (auto)
       Supports Wake-on: pumbg
       Wake-on: g
       Current message level: 0x00000007 (7)
                              drv probe link
       Link detected: yes
DiskStation> ethtool -i eth0
driver: e1000e
version: 3.3.3-NAPI
firmware-version: 3.1-1
bus-info: 0000:01:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no

Link to comment
Share on other sites

@holybabel, Thank you. Perfect information. Big difference in your Supports Wake-on: results: Supports Wake-on: pumbg

 

I'm curious to see reports from Realtek and Broadcomm Nic's now. Look's like a NIC upgrade is in the future.

Link to comment
Share on other sites

 Share

×
×
  • Create New...