• 0

Can't access server


Question

My server has been running perfect for a couple of years now emulating DS918. I don't leave it on as I only use it as a movie server so not used that often. I have over 1500 movies on it. Today when I turned it on I can't connect to it and I don't think it's booting up. All lights are on but don't really see activity like I normally would and not showing up in my router. In the middle of the night we lost power and today when I tried to use it I have the problem. As I said it wasn't on at the time but wonder if somehow it caused it. All my other computers are working find and I don't know where to start hoping to get it to work and still have my movies. I do an hp n54l that is sitting in a box that I have used for Xpenology before and thought about just putting the drives in there and seeing but just need more of an experts opinion on what to do. Thanks in advance.

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
16 hours ago, rickym said:

My server has been running perfect for a couple of years now emulating DS918. I don't leave it on as I only use it as a movie server so not used that often. I have over 1500 movies on it. Today when I turned it on I can't connect to it and I don't think it's booting up. All lights are on but don't really see activity like I normally would and not showing up in my router. In the middle of the night we lost power and today when I tried to use it I have the problem. As I said it wasn't on at the time but wonder if somehow it caused it. All my other computers are working find and I don't know where to start hoping to get it to work and still have my movies. I do an hp n54l that is sitting in a box that I have used for Xpenology before and thought about just putting the drives in there and seeing but just need more of an experts opinion on what to do. Thanks in advance.

 

most simple solution might be that the cmos battery is down and when the power was lost also the cmos values where reset (usually you get a message about that when booting up after that)

N54L is a AMD system and needs C1E disabled in bios, if that is on again it will prevent the loader from starting the DSM system

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

"...

Note: Jun's loader supports Intel CPUs. For AMD CPUs Jun has stated that the loader needs some work but it has been reported by many users using HP machines that it actually works. The C1E function in the bios (in some HP machines) needs to be deactivated. I am unsure for other motherboards brands therefore if you have an AMD machine that is not an HP you might be out of luck. Try looking in the bios configuration and play around.

..."

 

anyway, dont worry about your data, even if the loader is not working (like usb flash driver damaged, that is easy to repair) when dsm comes up and you see that the raid is damaged/offline that would be more of a concern

 

even if you cant get DSM up and runnning and want access to your data you can prepare a media (disk/usb) with OMV and boot from that media, its still my fallback

https://xpenology.com/forum/topic/42793-hp-gen8-dsm-623-25426-update-3-failed/?do=findComment&comment=200475

 

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 0

Well I am still confused on what to do. I guess I am in over my head. My server had been emulating a ds918. From what I understand if I try to get the N54l working that runs on 3615 system. I guess even after reading post I have no idea what to do. On my old server thought it comes on it's not booting. Checked the cmos battery and it's fine. It's a headless server so that makes it even more confusing. Oh well. it is what it is. I think I am screwed and not in a good way.

Link to post
Share on other sites
  • 0

Let's simplify. If it won't boot, it's because of one of the following:

  1. USB key corruption/damage
  2. DSM boot partition unavailable
  3. Hardware failure

You say your device is headless.  Does that mean it doesn't have a keyboard and video port?  If it has them, connect them and see if your hardware is even powering up

 

If the hardware is working, launch Synology Assistant or find.synology.com and see whether it is booting to a damaged state.  If so, report back.

 

If no boot is occurring at all, you probably have a failure of the USB. Burn a new, clean loader USB with DS918+ configured exactly as you have now (updating VID/PID if necessary).  Synology Assistant should find it and offer to Recover and you should be back up and running.

Link to post
Share on other sites
  • 0
3 hours ago, rickym said:

Checked the cmos battery and it's fine. It's a headless server so that makes it even more confusing.

if its the casen then its not the battery thats prevents booting, it might be the bios setting about C1E, thats the thing to check

 

3 hours ago, rickym said:

Well I am still confused on what to do. I guess I am in over my head. My server had been emulating a ds918. From what I understand if I try to get the N54l working that runs on 3615 system.

well, your information is confusing too to me, N54L cant handle loader 1.04b for 918+, do you talk about two different systems?

you can check the usb flash drive on you desktop computer if needed, there should be two partitions grub.cfg is on the first, at the end of the file there is the text of the boot menu, it it says 3615 the you have 3615

on the 2nd partition is zImage and rd.gz, these are the kernel files for the DSM System that are used for booting, post size and date of the files

maybe post rd.gz, if that is unpacked with 7ip there would be /etc/VERSION and in that file we would see the installed DSM version and type

 

if you cant handle problems there is also the option to buy a original synology unit and insert the disks, you would be able to "migrate" to the hardware you bought and could access your files (and would be spared of further complicated problems - at least for a few years)

Link to post
Share on other sites
  • 0

Yes the system that is down was made myself with a mini-itx motherboard. It does have a video port but unfortunately it's just a vga so I may try to see if someone has an old monitor I could us so I could better see what is happening. I took a break for a few hours and will start in again in a bit. Going to make a new usb key and start from scratch. I am very encouraged that most likely all of my movies are still in tact. I will post after I try a few more things. Thanks for everyone's help.

Link to post
Share on other sites
  • 0

Forgot to ask it has been emulating a ds918 as I mentioned with my homebrew server. If I setup my Hp server again as a 3615 will it be a problem recognizing my moves on my 4 hard drives?

Link to post
Share on other sites
  • 0

Ok, seems there has been some confusion. Your non working system is emulating a DS918, your old N54 can only run as a DS3615. If you put the disks from the non working system into the N54 you will need to create a new boot stick using jun’s 1.03b loader, there will be a message saying your disks have come from a DS918 & that you can migrate to DS3615. At the moment DSM 6.2.3 is is the latest version you can run ok.

 

All of your existing data should be ok however it always advisable to have backups of anything vital.

Link to post
Share on other sites
  • 0

Happy days are here again. I had been working on this way too long. Needed to take a break and now I am up and running. As far as problem my onboard nic was the problem with my home brew nas. I was able to migrate to my HP N54L and all is good. I did have a backup of my movies but it was a few months ago. Learned my lesson. Back to my normal weekly updates on my servers. Also going to get a battery backup system for my has as power where I live is not very good and often get power outages. Thanks so much guys for all you help and suggestions.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.