Jump to content
XPEnology Community

Windows 10 - unable to access shares


freebsdrules
 Share

Recommended Posts

Hello-

 

I now have synology up and running on my own hardware thanks to XPEnology! Unfortunately, I am having problems accessing any of the shares from one of my PCs. I have a laptop using a wireless connection and a PC using a wired connection. Both machines are running Windows 10 with the latest (and same) build/update. The laptop (wireless) can browse the shares using \\192.168.1.X\sharename but the PC (wired) cannot. I just get an error, 'Windows cannot access \\192.168.1.X\sharename'. Both computers have the same local username/password which has been given full access to the synology shares.

 

I've tried just about anything but cannot figure this out. Does anybody have any thoughts?

 

Thanks in advance!

Link to comment
Share on other sites

I mean, if you go to "Network" (Network Places in old Windows) in Explorer, does it show up? Or, if you try to access it using diskstation name (\\Diskstation\home)?

 

Btw, are both computers connected to the same router? Do you have any Vlan set, etc?

Link to comment
Share on other sites

Sorry, I should have been more clear.

 

If I go to 'Network' I see the machine (diskstation name) but when I try to access/browse a share in explorer using the name or the IP address, no luck. All computers and the NAS are connected to the same switch (which is also connected to the router). No vlans, etc.

Link to comment
Share on other sites

try testing the laptop on a wired connection (turn off the wifi), see what happens. Also, swap cables (unlikely I know but if its a gig cable and bad connections etc). delete and re-add the nic in windows device manager and let it readd the drivers. check the nic dhcp settings to make sure they are ok. disable ipv6 protocols. give your nas the same network name as the pcs

Link to comment
Share on other sites

it's a known issue with Windows10 and network shares based on Samba, there are many Microsoft Knowledge base on how to disabled or make Windows10 compatible.

 

Basically add a login account in your Windows10 security credentials in control panel, or disable some windows security from the command line.

Link to comment
Share on other sites

Valid comments. In my setup I have a user account on the NAS with same password as Windows 10 and all shares work fine (samba workgroup). Strange that one device connects and the other does not, but that could be because it has 'cached credentials' to the NAS.

A way to prove one way or another is to create a new user in DSM and Windows with matching details and see what happens

Link to comment
Share on other sites

So I just tried with the Laptop plugged in (using the same network cable the PC is normally plugged into) and it still works. Both the PC and Laptop have the same username/password which is also setup on the NAS. This is maddening! Any other suggestions?

Link to comment
Share on other sites

is your laptop also running windows 10? or is that windows 7?

 

compare the windows account settings differences in both machines.

did you link your desktop PC account with Windows Live account? i recall reading some problem after doing so as well.

 

i use local account, i don't use the live account for windows 10

 

did you read this known issue i mentioned earlier? https://techjourney.net/cannot-connect- ... indows-10/

Link to comment
Share on other sites

Thanks all.

 

AllGamer - my laptop is also running Windows 10 and the windows accounts (local on both) are exactly the same. I even tried creating a new user on the PC and a corresponding account on the NAS but that did not work either. The article you link to is referring to allowing guest access without passwords which is not what I'm trying to do.

 

abced - what do you mean? the username/password is a local account (lets say freebsdrules) on my PC and that same username and the same password I use is on the NAS.

 

rpmurph8411 - you should not need to do any port forwarding for smb shares. i have turned off the windows firewall for troubleshooting (along with my antivirus).

Link to comment
Share on other sites

Wow, I finally figured it out. I have been trying just about everything I can from web searches and this finally worked. I had to change a registry entry as detailed below. Unlike the example given in the article, I didn't have the two blank spaces in my entry but it was different. I verified it should be as indicated below by checking my laptop and sure enough, it was. I updated it on my PC, rebooted, and instantly fixed!

 

http://www.megaleecher.net/Fix_Windows_ ... z491ly2FPY

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order, now edit and fix the ProviderOrder entry to correct value of RDPNP,LanmanWorkstation,webclient

Link to comment
Share on other sites

http://www.megaleecher.net/Fix_Windows_ ... z491ly2FPY

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order, now edit and fix the ProviderOrder entry to correct value of RDPNP,LanmanWorkstation,webclient

 

I learned :idea: something new today, Thanks to you :grin:

 

I've never had this problem before, but it's good to know this elusive bug can happen;

now I'm better prepared in the future if this ever happens to my machines.

Link to comment
Share on other sites

I learned :idea: something new today, Thanks to you :grin:

 

I've never had this problem before, but it's good to know this elusive bug can happen;

now I'm better prepared in the future if this ever happens to my machines.

 

You are welcome, I'm hoping it helps somebody down the road. It was a seriously frustrating pain in the rear! I literally spent DAYS trying to figure it out.

Link to comment
Share on other sites

Wow, I finally figured it out. I have been trying just about everything I can from web searches and this finally worked. I had to change a registry entry as detailed below. Unlike the example given in the article, I didn't have the two blank spaces in my entry but it was different. I verified it should be as indicated below by checking my laptop and sure enough, it was. I updated it on my PC, rebooted, and instantly fixed!

 

http://www.megaleecher.net/Fix_Windows_ ... z491ly2FPY

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order, now edit and fix the ProviderOrder entry to correct value of RDPNP,LanmanWorkstation,webclient

I was having the same problems on my windows 10 pc. I will try this tonight and check back to confirm if this worked for me. I made a workaround by creating a new batchfile which deleted the excisting mapping, creating a new one and starting Explorer.exe with arguments to open the drivemapping.

Link to comment
Share on other sites

Wow, I finally figured it out. I have been trying just about everything I can from web searches and this finally worked. I had to change a registry entry as detailed below. Unlike the example given in the article, I didn't have the two blank spaces in my entry but it was different. I verified it should be as indicated below by checking my laptop and sure enough, it was. I updated it on my PC, rebooted, and instantly fixed!

 

http://www.megaleecher.net/Fix_Windows_ ... z491ly2FPY

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order, now edit and fix the ProviderOrder entry to correct value of RDPNP,LanmanWorkstation,webclient

I was having the same problems on my windows 10 pc. I will try this tonight and check back to confirm if this worked for me. I made a workaround by creating a new batchfile which deleted the excisting mapping, creating a new one and starting Explorer.exe with arguments to open the drivemapping.

Ok, so it turns out that I had a different problem. But that is solved as well.

I needed to put in my username and password everytime I wanted to connect to share after a reboot. Turns out that if i use the hostname as the domain "Servername"\"Username" it works better then just "username". I create a mapping and select that I want to use a different username to connect to the mapping.

Link to comment
Share on other sites

 Share

×
×
  • Create New...