Sign in to follow this  
codepal

dsm 5.2 사용하시는분계신가요? https 비활성화가 안됩니다.

Recommended Posts

안녕하세요.

DSM 5.2 5592 update 4 에서 https 를 활성화 해서 잘 사용하다가 사정이 생겨서 https 를 비활성화 했더니...

http 로 접속해도 프로토콜이 계속 https 로 변경되는데 어떻게 해결을 해야 할까요...

제어판 > 네트워크 > DSM 설정에서 리디렉션및 모든걸 꺼봐도 무조건 https 로 변경이 되는데 죽겠습니다. ㅠㅠ

Share this post


Link to post
Share on other sites

브라우저의 캐시(임시파일)을 삭제해 보시길 바랍니다.

그래도 안되시면 설정파일을 수동으로 수정해야할꺼 같네요.

Share this post


Link to post
Share on other sites

Control Panel -> Network -> DSM Setting 탭 에서 Enable HTTPS connection 을 끄기 전에,

 

바로 그 아래 있는 Automatically redirect HTTP connections to HTTPS 옵션을 비활성화 하시고 적용을 먼저 하신 다음에 Enable HTTPS connectiond 옵션을 끄고 적용하세요.

 

그리고 같은 화면에서 HTTP용 기본 포트 5000번을 다른 포트로 변경 해 보세요. (예를 들면 5555)

 

포트 변경후 http://주소:5555 식으로 바뀐 포트를 지정해서 접속 해보세요.

 

 

만약 위 방법으로 해결이 안되면,

혹시 모르니 제어판->웹 서비스 에서 Enable Web Station(웹 스테이션 활성화)를 해제 해 주시고요, 다시 DSM Setting 탭에서 HTTPS를 활성화 했다가 위 절차로 비활성화 해보시고...

 

 

그래도 안되면 설정 파일이 꼬인 것이니...

 

/usr/syno/synoman/redirect.cgi 파일 원본을 다른 xpenology 에서 구해서 overwrite 하시고

/etc/httpd/conf/httpd.conf-sys 파일 원본을 다른 xpenology 에서 구해서 overwrite 하시길 바랍니다. 그리고 한번 재시작 해 주시고요...

 

혹시 .htaccess 파일 같은것 만들어 두신 것 있으면 찾아서 지우시고요... 그 안에 redirect 301 https://주소:5001 등으로 돼 있을수도 있으니까요.

 

도움이 되었기를...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this