Jump to content
XPEnology Community

[Tuto] DSM 7.0.1 | DSM 7.1


Sabrina

Recommended Posts

Il n'y a pas de configuration à partager.

 

La commande "./rploader.sh satamap now" te donnera la valeur exact à renseigner.

En fonction de ton bios (modifié ou non) et des réglages associés, le résultat peut être différent.

 

Dans mon cas j'ai SataPortMap=6 DiskIdxMap=00

 

Mais il ne faut PAS copier ces valeurs bêtement... la seule vérité en baremetal avec le N54L, c'est la commande ci-dessus.

Si elle ne donne pas un résultat comme le mien, c'est que soit le bios n'est pas "modifié" soit les réglages bios ne sont pas paramétrés pour avoir ce résultat.

Ce n'est pas pour autant que ça ne fonctionnera pas. Le mieux est de tester.

Link to comment
Share on other sites

Bonjour,

 

Je viens de réussir migrer mon HP N54L (gen7) sur DSM 7.0.1 :) !!! 

Je confirme qu'il n'est pas nécessaire d'avoir une carte réseau Intel, le NIC embarqué est bien géré par le loader. Le seul truc qui ne marche pas c'est l'onduleur sur USB qui n'est pas vu par DSM certainement dû au controleur USB non inclus dans le loader.

 

Bref, pour y parvenir :

Il suffit de lire le §

Le 15/01/2022 à 23:44, Sabrina a dit :

 Pour l'installation Baremetal :

seulement voilà, la commande

./rploader.sh satamap now

./rploader.sh satamap now

qui semble retourner des valeurs cohérentes (42 => 4ports SATA sur le controleur 1 et 2 ports SATA sur le controleur 2) mais ne fonctionnent pas !

 

Pour y parvenir j'ai manuellement (via vi) supprimer les balises correspondantes afin d'obtenir ceci dans le fichier user_config.json 

{
	"extra_cmdline": {
		"pid": "0x####",
		"vid": "0x####",
		"sn": "############",
		"mac1": "############"
	},
	"synoinfo": {
		"internalportcfg": "0xffff",
		"maxdisks": "16",
		"support_bde_internal_10g": "no",
		"support_disk_compatibility": "no",
		"support_memory_compatibility": "no"
	},
	"ramdisk_copy": {}
}

 

Suivi d'une recompilation du loader via

./rploader.sh build bromolow-7.0.1-42218

 

et hop !

 

 

Note : suite à plusieurs essais je me suis retrouvé à devoir reconfigurer intégralement DSM... mais bon les données étaient là et c'est le principal. 

Link to comment
Share on other sites

Bonjour,

je rencontre un souci m'empêchant d' poursuivre l'installation, concernant SataPortMap & DiskIdxMap
J'ai beau mettre toutes les valeurs possibles, mais rien ne fonctionne, l'installateur de DSM (page web 192.168.0.XX) ne reconnaît pas mes disques.
Ma carte mère est une ASUS H81M-E, avec 2 ports SATA jaunes et 2 ports SATA noirs.

 

Dans le BIOS, j'ai les informations suivantes :

Citation

SATA6G_1 (Yellow) Vide
SATA6G_2 (Yellow) Mon SSD
SATA3G_1 (Black) Vide
SATA3G_2 (Black) Vide

 

Je suppose donc que j'ai 2 contrôleurs SATA :

  1. Yellow avec 2 ports
  2. Black avec 2 ports

Dans SataPortMap j'ai donc mis 22, mais pour DiskIdxMap je ne sais pas quoi mettre.

 

Quant à la commande 

./rploader.sh satamap now

Elle retourne dans le fichier user_config.json les valeurs suivantes, qui ne fonctionnent pas non plus :

  • SataPortMap : 58
  • DiskIdxMap : 0A00

 

Si vous avez des idées, je serai preneur :)

Bien à vous.

Edited by adrien80080
Informations added
Link to comment
Share on other sites

Hello

j'ai preparé la clé de boot pour mon HP micro serveur Gen 8

Néanmoins avant de migrer j'ai remarqué que la commande "./rploader.sh satamap now" m'a donné SataPortMap=6 DiskIdxMap=00


A ma connaissance le Gen 8 n'a que 5 port SATA, est ce plus sur d'editer le fichier et modifier le nombre ou puis laisser comme cela ?

Link to comment
Share on other sites

Il y a 17 heures, fabbe a dit :

A ma connaissance le Gen 8 n'a que 5 port SATA, est ce plus sur d'editer le fichier et modifier le nombre ou puis laisser comme cela ?

En toute honnêteté je n'arrive pas à comprendre le principe de calcul de DiskIdxMap. Essaie de t'inspirer de la section anglaise pour trouver qqn qui aurait indiqué ce paramètre pour un gen8.

Link to comment
Share on other sites

On 3/18/2022 at 3:38 PM, nicoueron said:

En toute honnêteté je n'arrive pas à comprendre le principe de calcul de DiskIdxMap. Essaie de t'inspirer de la section anglaise pour trouver qqn qui aurait indiqué ce paramètre pour un gen8.

premier test en branchant 5 disques avec les paramètres par defaut SataPortMap=6 DiskIdxMap=00

j'ai une erreur me disant que le fichier PAT est probablement corrompu

Edited by fabbe
Link to comment
Share on other sites

Le 17/03/2022 à 16:09, adrien80080 a dit :

Bonjour,

je rencontre un souci m'empêchant d' poursuivre l'installation, concernant SataPortMap & DiskIdxMap
J'ai beau mettre toutes les valeurs possibles, mais rien ne fonctionne, l'installateur de DSM (page web 192.168.0.XX) ne reconnaît pas mes disques.
Ma carte mère est une ASUS H81M-E, avec 2 ports SATA jaunes et 2 ports SATA noirs.

 

Dans le BIOS, j'ai les informations suivantes :

 

Je suppose donc que j'ai 2 contrôleurs SATA :

  1. Yellow avec 2 ports
  2. Black avec 2 ports

Dans SataPortMap j'ai donc mis 22, mais pour DiskIdxMap je ne sais pas quoi mettre.

 

Quant à la commande 


./rploader.sh satamap now

Elle retourne dans le fichier user_config.json les valeurs suivantes, qui ne fonctionnent pas non plus :

  • SataPortMap : 58
  • DiskIdxMap : 0A00

 

Si vous avez des idées, je serai preneur :)

Bien à vous.

Quelqu'un aurait une idée ?
J'aimerais pouvoir profiter de DSM 7 (déjà en utilisation sur mon DS115J) avec la puissance de mon ordinateur dédié.

Link to comment
Share on other sites

3 hours ago, fabbe said:

premier test en branchant 5 disques avec les paramètres par defaut SataPortMap=6 DiskIdxMap=00

j'ai une erreur me disant que le fichier PAT est probablement corrompu

Bonjour

j'ai réussi une instal from scratch sur un seul disque mais a partir d'un image de DS3615xs

en cherchant sur le forum anglais je suis tombé sur le post Zahni qui a semble avoir trouvé une info disant que pour le moment il y avait des problèmes avec l'image DS3617xs

 

Prochaine étape une instal sur 5 Disques et ensuite je ferais une migration de mon système en 6.2

 

Edit -> migration d'une ancienne instal 6.2 provenant DS416 ca passe sans problème, rendez vous dans 15mn je migre mon instal de prod

 

Edit 2 -> La migration a pris plus de temps que prévue (environ 45mn)
j'ai vérifié rapidement le fonctionnement des paquets que j'utilise

 

FileStation -> OK

Plex -> Réparer ->apres avoir effectué un changement de permission sur le dossier plex j'ai finalement le massage d'erreur suivant -> ERROR: Unable to migrate existing ... (je verrais plus tard)

Virtual Machine Manager -> Réparer -> OK
Docker x 8 -> OK

Synology drive Sync share -> OK

Cloud Sync -> OK

Hyper BackUP -> j'attend cette nuit il y aura tous mes backups

Synology Photos -> Mise à jour de la base de donnée -> 

 

 

Edited by fabbe
Link to comment
Share on other sites

 

Plex -> Réparer ->apres avoir effectué un changement de permission sur le dossier plex j'ai finalement le massage d'erreur suivant -> ERROR: Unable to migrate existing ... (je verrais plus tard)

bon c'etait pas grand chose, j'ai fait comme expliqué sur cette vidéo

encore un probleme, plex se lance mais les film ne sont pas accessibles, peut être un problème de droits encore

 

Edit ->c'est réglé, j'ai rajouté les droits en lecture de la même manière qu'expliqué dans la vidéo mais sur le répertoire contenant mes films

 

Edited by fabbe
Link to comment
Share on other sites

Il y a 8 heures, fabbe a dit :

Bonjour

j'ai réussi une instal from scratch sur un seul disque mais a partir d'un image de DS3615xs

en cherchant sur le forum anglais je suis tombé sur le post Zahni qui a semble avoir trouvé une info disant que pour le moment il y avait des problèmes avec l'image DS3617xs

 

Prochaine étape une instal sur 5 Disques et ensuite je ferais une migration de mon système en 6.2

 

Edit -> migration d'une ancienne instal 6.2 provenant DS416 ca passe sans problème, rendez vous dans 15mn je migre mon instal de prod

 

Edit 2 -> La migration a pris plus de temps que prévue (environ 45mn)
j'ai vérifié rapidement le fonctionnement des paquets que j'utilise

 

FileStation -> OK

Plex -> Réparer ->apres avoir effectué un changement de permission sur le dossier plex j'ai finalement le massage d'erreur suivant -> ERROR: Unable to migrate existing ... (je verrais plus tard)

Virtual Machine Manager -> Réparer -> OK
Docker x 8 -> OK

Synology drive Sync share -> OK

Cloud Sync -> OK

Hyper BackUP -> j'attend cette nuit il y aura tous mes backups

Synology Photos -> Mise à jour de la base de donnée -> 

 

 

Pourrais-tu indiquer la marche à suivre ? J'ai beau suivre le tutoriel de base, rien n'y fait 😕

Link to comment
Share on other sites

Le 17/03/2022 à 16:09, adrien80080 a dit :

Bonjour,

je rencontre un souci m'empêchant d' poursuivre l'installation, concernant SataPortMap & DiskIdxMap
J'ai beau mettre toutes les valeurs possibles, mais rien ne fonctionne, l'installateur de DSM (page web 192.168.0.XX) ne reconnaît pas mes disques.
Ma carte mère est une ASUS H81M-E, avec 2 ports SATA jaunes et 2 ports SATA noirs.

 

Dans le BIOS, j'ai les informations suivantes :

 

Je suppose donc que j'ai 2 contrôleurs SATA :

  1. Yellow avec 2 ports
  2. Black avec 2 ports

Dans SataPortMap j'ai donc mis 22, mais pour DiskIdxMap je ne sais pas quoi mettre.

 

Quant à la commande 




./rploader.sh satamap now

Elle retourne dans le fichier user_config.json les valeurs suivantes, qui ne fonctionnent pas non plus :

  • SataPortMap : 58
  • DiskIdxMap : 0A00

 

Si vous avez des idées, je serai preneur :)

Bien à vous.

Voilà ma config, j'ai tout essayé, même supprimer les lignes sataportmap et diskidxmap, rien n'y fait.

 

Quant au processeur, c'est un Intel 4460s

J'ai 16gb de ram

Link to comment
Share on other sites

Hello

je rencontre un souci

apres un arret le serveur une fois sur 2 voir sur 3 
quand il boot pas rien d'anormal sur l'écran (rien de different que lorsqu'il boot)
Decrompressing Linux ... Parsing ELF... done.

Booting the Kernel 

en revanche je ne vois pas d'activité sur les disques dur (voyant éteint)

Link to comment
Share on other sites

Il y a 2 heures, fabbe a dit :

Hello

je rencontre un souci

apres un arret le serveur une fois sur 2 voir sur 3 
quand il boot pas rien d'anormal sur l'écran (rien de different que lorsqu'il boot)
Decrompressing Linux ... Parsing ELF... done.

Booting the Kernel 

en revanche je ne vois pas d'activité sur les disques dur (voyant éteint)

Hum, bizarre effectivement 🤨

sur de ta config du loader? As tu essayer avec un autre type (3615, 3617, 918. Etc)?

Link to comment
Share on other sites

  • nicoueron changed the title to [Tuto] DSM 7
  • nicoueron changed the title to [Tuto] DSM 7.0.1 | DSM 7.1

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...