Jump to content
XPEnology Community

[Tuto] DSM 7.0.1 | DSM 7.1


Sabrina

Recommended Posts

Il y a 1 heure, Gastonzz a dit :

Oui je peux faire le test, je vais le faire et je te tiens au courant

Voilà Orphée, j'ai fait le branchement du disque de 10To sur le SATA de la carte mère et cela fonctionne parfaitement, je suis en cours de sauvegarde, les débits sont parfait. C'est donc bien un problème de compatibilité de ma seconde carte contrôleur. Mais ce type de branchement ne me pose pas de problème, carte les deux premiers ports SATA de ma carte mère sont des 6Gb, donc aucune perte de vitesse.

Merci d'y avoir pensé et encore merci de ton aide.

Gastonzz

  • Like 1
Link to comment
Share on other sites

Hello ! J'ai un soucis complètement incompréhensible... Pour une installation sur Baremetal

 

Je boot sur la clé usb, tinycore-redpill.v0.4.5 se lance... par contre impossible de joindre le serveur en ssh pour exécuter les commandes. Que ce soit sous Putty, powershell, ou l'invite de commande...

 

EDIT: Ok c'était la clé USB qui avait foirée et ca me lançait pas tinycore en intégralité... 

 

 

Edited by insolegeek
Link to comment
Share on other sites

Le 17/02/2022 à 20:05, Tibag a dit :

Hey tout le monde! Ptite question, j'ai un DSM 6 avec Synoboot et jme demande si je peux upgrade sur DSM 7 avec Redpill? Ou alors vaut mieux partir de zero? 

 

Je viens de procéder à la mise à jour. Oui tu peux, ca retrouve ton ancien "NAS" et migre toutes les données. Après je te conseille quand même de faire une installation sur un HDD vierge et en déconnectant tes éventuels HDD présents, histoire de voir si tout fonctionne sur ta config. Si tout est ok, tu rebranche tout et tu procède à la maj. Fin c'est ce que j'ai fait et ça c'est bien passé ;)

Edited by insolegeek
Link to comment
Share on other sites

bonjour, je viens de me refaire un NAS avec un processeur i7 3770k

j'ai bien choisi cette commande pour les numeros de serie ./rploader.sh serialgen DS3617xs et le fichier pat généré est nommé" ds3615xs_42218.pat"

mais mon NAS affiche DS3615xs

 

YaxiMP5.png

 

j'ai un i7 4 coeurs et pas un I3-4130

 

merci de votre eclairage ?

Link to comment
Share on other sites

31 minutes ago, duncanmac said:

bonjour, je viens de me refaire un NAS avec un processeur i7 3770k

j'ai bien choisi cette commande pour les numeros de serie ./rploader.sh serialgen DS3617xs et le fichier pat généré est nommé" ds3615xs_42218.pat"

mais mon NAS affiche DS3615xs

 

YaxiMP5.png

 

j'ai un i7 4 coeurs et pas un I3-4130

 

merci de votre eclairage ?

Salut,

 

L'information du processeur dans le DSM c'est normale car il affiche le véritable processeur du Device DS3615xs et non le tient et cela vaut pour tous les autres Devices et il y a juste au niveau de la mémoire que tu verras un changement réel

 

Si tu as entré le numéro de série DS3617xs mais que tu as compilé avec la commande du DS3615xs, ton loader sera un DS3615xs et non un DS3617xs.

 

entre

./rploader.sh build broadwell-7.0.1-42218

 

 

 

Voici la liste des Devices:

 

apollolake-6.2.4-25556
apollolake-7.0-41890
apollolake-7.0.1-42218
broadwell-7.0.1-42218
broadwellnk-7.0.1-42218
bromolow-6.2.4-25556
bromolow-7.0-41222
bromolow-7.0.1-42218

 

Apollolake = DS918+

Bromolow = DS3615xs

Broadwell = DS3617xs

Broadwellnk = DS3622xs+

 

Edited by Sabrina
Link to comment
Share on other sites

il y a 11 minutes, Sabrina a dit :

entre



./rploader.sh build broadwell-7.0.1-42218

 

 

je vais refaire la manip car j'ai lancé cette commande

 

./rploader.sh build bromolow-7.0.1-42218

 

je reviens pour vous informer

 

Edited by duncanmac
Link to comment
Share on other sites

bon j'ai tenter de refaire la manip c'est pire, plus rien ne fonctionne

image.png.35962709c4d19dac8d8ed26a29c88b3f.png

 

 

image.thumb.png.979a62c9ce4ee30cc81f5cdf1e3a4f27.png

 

alors que ça marche très bien en 3615

pour info la commande  ./rploader.sh satamap now me détecte 6 ports alors que j'en ai que 4 (j'avais la meme erreur en 3615 donc je modifie le user_config.json avec "SataPortMap": "4", au lieu de "SataPortMap": "6",

 

j'ai tenté avec une autre clé USB c'est pareil

j'ai tenté de faire un sudo fdisk /dev/sda,b,c pour supprimer toutes les partitions mais rien a faire

 

Link to comment
Share on other sites

8 minutes ago, duncanmac said:

bon j'ai tenter de refaire la manip c'est pire, plus rien ne fonctionne

image.png.35962709c4d19dac8d8ed26a29c88b3f.png

 

 

image.thumb.png.979a62c9ce4ee30cc81f5cdf1e3a4f27.png

 

alors que ça marche très bien en 3615

pour info la commande  ./rploader.sh satamap now me détecte 6 ports alors que j'en ai que 4 (j'avais la meme erreur en 3615 donc je modifie le user_config.json avec "SataPortMap": "4", au lieu de "SataPortMap": "6",

 

j'ai tenté avec une autre clé USB c'est pareil

j'ai tenté de faire un sudo fdisk /dev/sda,b,c pour supprimer toutes les partitions mais rien a faire

 

 

Si cela fonctionne sur DS3615, faut rester dessus !!!

LE DS3617xs est en version beta pour le moment et d'après les retours il n'est pas stable, pour l'installation il faut le couper d'internet si non l'installation échouera.

Pour le DS3622xs en beta aussi.

 

A ce jour le DS918+ et DS3615xs sont les plus stables.

 

Link to comment
Share on other sites

  • 2 weeks later...
Posted (edited)

Salut,

 

Merci pour votre travail !

 

Installation sur un QNAP TS253A, tout fonctionne parfaitement :)

 

J'ai eu tout de même quelques soucis à la mise en place.

Pour commencer j'ai du déconnecter le module USB interne sinon impossible de faire fonctionner DSM 7.

Avec le module présent, impossible de compiler (déconnexion du SSH et freeze de la machine) et même après la compilation sans le module USB interne, si je venais à le rebrancher le démarrage du NAS ne fonctionnait plus.

 

De plus, j'avais l'erreur "Failed in waitforx", je n'arrivai donc pas sur l'interface graphique, mais j'ai tapé la commande "ifconfig" directement dans la console après l'erreur pour avoir l'IP.

 

Par contre très bizarre, j'ai pu compiler sans problème toute la journée durant mes tests, mais à la fin plus possible alors que rien n'avait changé. J'avais exactement ce souci

https://github.com/pocopico/tinycore-redpill/issues/5

J'ai donc dans un premier temps configuré mon fichier user_config.json par rapport à mon NAS et j'ai fait la compilation sur un autre PC.

 

Au final tout est Ok, l'installation semble bien stable, mais la mise en place fut un peu compliqué.

 

 

Edited by Musyanon
Link to comment
Share on other sites

Update sur mon HP N54L 

 

Sur une cle USB fraichement formatee et apres avoir suivi le tuto a la lettre, a l'etape ./rploader.sh build bromolow-7.0.1-42218 il demande si on veut installer un nouveau script, ce que j'ai fait. Ensuite on re-rentre ./rploader.sh build bromolow-7.0.1-42218 et la compilation se poursuit normalement (sans l'erreur ci-dessus).

 

Ensuite important :  avant de rebooter Tinycore j'ai recupere avec WinSCP le ds3615xs_42218.pat qui se trouvait dans /home/tc/redpill-load/cache/ 

 

Apres reboot, je trouve bien le NAS avec http://find.synology.com/. De la j'ai installe le .pat mentionne juste avant, et c'est bon, tout marche !!

 

 

Nas1.png

Nas2.png

Nas3.png

Nas4.png

Nas6.png

Link to comment
Share on other sites

Bonjour,

Equipé d'un HP N54L, j'ai fait la migration sur DSM 7 mais je ne vois pas mon 5ème disque qui est branché sur le port sata qui est normalement prévu pour le lecteur CD.

Cela fonctionnait bien en 6.2.3 avec JUN. la config sata détecté par RedPill Tinycore loader 0.4.5 est 42. J'ai essayé 108 comme préconisé dans le forum mais sans succès.

Quelqu'un à réussi à voir tous les disques dans cette configuration ?

Merci pour votre retour.

 

Link to comment
Share on other sites

Hello,

 

je ne comprends pas très bien malgré la lecture de diffèrent post comment se passe une update depuis une installation en 6.x.x avec le loader de Jun 🤔

J'utilise KVM de mon coté.

 

Faut-il que je modifie temporairement mon image de boot de ma VM en DSM6 par l'image de Redpill ?
Ou il faut que je crée une nouvelle VM temporaire pour lancer TinyCore et recuperer le loader / et le fichier d'instalaltion Synology ?
 

En vous remerciant.

 

Link to comment
Share on other sites

Il y a 1 heure, Orphée a dit :

Si tu configures correctement ton bios, il devrait te proposer SataPortMap=6

Je ne me souviens plus exactement des réglages, mais ça a déjà été evoqué à plusieurs reprises pour le N54L.

Merci pour cette info, j'ai essayé mais sans succès, si tu as les infos pour la modif du bios je suis preneur.

Link to comment
Share on other sites

Posted (edited)

Hello! 

 

Je suis en train de tester une install de test avant migration de mon DSM6. Je suis sous ESXI et je n'arrive  pas a boot apres la compilation, ca bloque toujours sur:

image.png.1a7278ac8003bc10527143224f21718f.png

 

J'ai essaye different mapping, version de build, etc mais rien n'y fait. Ca vous est deja arrive? Vous savez si je peux acceder a des logs?

 

EDIT: okay c'est normal en fait, je vois DSM sur le network :)

 

 

Edited by Tibag
Link to comment
Share on other sites

  • nicoueron changed the title to [Tuto] DSM 7
  • nicoueron changed the title to [Tuto] DSM 7.0.1 | DSM 7.1

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...