Jump to content
XPEnology Community

RedPill Tinycore loader


pocopico

Recommended Posts

18 minutes ago, AmiroGarry said:

i am not an expert. Can I switch from 6.2.3 to DSM7 for a productive system or does that make no sense?

at this stage no, loader still in Alpha stage and it's not a good idea update on production system

 

Edited by Aigor
Link to comment
Share on other sites

2 hours ago, pocopico said:

@g4sho Can you please send me the output of lspci -nnq 

@pocopico lspci -nnq command is not available, I looked in bin and sbin for it, not there. here is the output. This is in relation to tiny pill diskstation

I left off the q in -nnq this time, but I typed it several times and it was not available.

 

20220114_045710[1].jpg

Edited by g4sho
Clarification
Link to comment
Share on other sites

1 hour ago, loderunner said:

After booting tc 0.4.4 on VmWare Workstation I've got only this (

Annotation 2022-01-14 145718.png

 

I posted my vmware machine config above and the boot drive is setup for me like.  Not sure if your on windows or linux but i found it best to put the vmdk provided by pocopico into the same vmware folder as the other vm machine files, saves issues with write permissions.  I also had some issues with certain programs when unpacking the archive so maybe try another program.  On linux gunzip has worked reliably for me.

 

image.thumb.png.19b26342ff06c1deaab598b735d7f9ab.png

Link to comment
Share on other sites

12 минуты назад, chickey сказал:

 

I posted my vmware machine config above and the boot drive is setup for me like.  Not sure if your on windows or linux but i found it best to put the vmdk provided by pocopico into the same vmware folder as the other vm machine files, saves issues with write permissions.  I also had some issues with certain programs when unpacking the archive so maybe try another program.  On linux gunzip has worked reliably for me.

 

image.thumb.png.19b26342ff06c1deaab598b735d7f9ab.png

gunzip vmdk on ubuntu linux, copy it to windows with workstation and get th same result

Link to comment
Share on other sites

Just now, loderunner said:

gunzip vmdk on ubuntu linux, copy it to windows with workstation and get th same result

you you looked at the console output for any errors by piping the a serial port out to a file?

 

What version of workstation are you running?

Link to comment
Share on other sites

7 минут назад, chickey сказал:

you you looked at the console output for any errors by piping the a serial port out to a file?

 

What version of workstation are you running?

It is VMware® Workstation 15 Pro 15.5.6

all what I get in serial

Annotation 2022-01-14 164042.png

Edited by loderunner
Link to comment
Share on other sites

5 minutes ago, loderunner said:

It is VMware® Workstation 15 Pro 15.5.6

how to pipe serial out at workstation?

I popped it in an earlier post but add a serial port and set the output to be a file and i found it best to place the file inside the vm dir.  The second time you run it it'll ask if you wish to append or overwrite which is normal.

 

image.png.0f87ae42b877a7e4993786a5296be8a7.png

Link to comment
Share on other sites

7 минут назад, chickey сказал:

I popped it in an earlier post but add a serial port and set the output to be a file and i found it best to place the file inside the vm dir.  The second time you run it it'll ask if you wish to append or overwrite which is normal.

 

image.png.0f87ae42b877a7e4993786a5296be8a7.png

boot steps is:

Annotation 2022-01-14 164944.png

Annotation 2022-01-14 164958.png

Link to comment
Share on other sites

Hello,

First i apologize if it has already been asked but i didn't found my answers.


I'm trying to update my HP MicroServer GEN8 from 6.2.3 DS3617XS on 7.0.1 on DS3615XS.

I got a few questions :

 

- What is the default password of the "tc" user ? (tried empty one without success)

- When i build i got an error about tools not installed (didn't see how to install that).

 

Thank you by advance :)

Link to comment
Share on other sites

Только что, ozef сказал:

Hello,

First i apologize if it has already been asked but i didn't found my answers.


I'm trying to update my HP MicroServer GEN8 from 6.2.3 DS3617XS on 7.0.1 on DS3615XS.

I got a few questions :

 

- What is the default password of the "tc" user ? (tried empty one without success)

- When i build i got an error about tools not installed (didn't see how to install that).

 

Thank you by advance :)

maybe

User: tc
Password: P@ssw0rd

like here https://xpenology.club/install-dsm-7-on-baremetal-or-vm/

  • Like 1
Link to comment
Share on other sites

il y a une heure, loderunner a dit :

maybe

User: tc
Password: P@ssw0rd

like here https://xpenology.club/install-dsm-7-on-baremetal-or-vm/

Thanks a lot !

 

I had to comment the line #[dpkg]="dpkg --version" # extract flashupdate in redpill-load/include/runtime.sh 

 

FYI : i had to modify the custom_user.json to add my additional HP ethernet macadress.

 

But still got an error on installing the pat file.

 

UPDATE :

I had to format all my disks and revert to JUn's loader and on 6.2.3 :(
 

Edited by ozef
Link to comment
Share on other sites

1 hour ago, g4sho said:

@pocopico lspci -nnq command is not available, I looked in bin and sbin for it, not there. here is the output. This is in relation to tiny pill diskstation

I left off the q in -nnq this time, but I typed it several times and it was not available.

 

20220114_045710[1].jpg

you can run the lspci -nnq once you are inside tinycore instead.

Link to comment
Share on other sites

 

@ POCOPICO !

 

Thanks Pocopico for your excellent work!

 

Now running 7.0.1 on hp prodesk 400 G2 mini with a SSD 860

 

... ==> bought a new NVMe M.2 (SSD 980) and added it to the MB.

The ssd disk will not be found .. .any drivers available an how to add them ( on grub?) ?

 

best Keasee

 

Bildschirmfoto 2022-01-14 um 19.17.56.png

Edited by keasee
Link to comment
Share on other sites

@pocopico is there any requirement to run this system?

 

I have an Asrock J5005-itx, and in bios there arent many options to use. 

i folowed all steps but cant boot this distro.

All 3 partitions show on bios but any one i choose to boot it flashs a screen fo a 1ms and returns to bios.

 

I tried to burn image several times with Rufus and Win32diskImager and select 3 partition as active.

Tested on all usb ports of mainboard, but it doesent boot.

 

Is there any way to boot this distro?

 

 

Link to comment
Share on other sites

6 минут назад, JMRR сказал:

@pocopico is there any requirement to run this system?

 

I have an Asrock J5005-itx, and in bios there arent many options to use. 

i folowed all steps but cant boot this distro.

All 3 partitions show on bios but any one i choose to boot it flashs a screen fo a 1ms and returns to bios.

 

I tried to burn image several times with Rufus and Win32diskImager and select 3 partition as active.

Tested on all usb ports of mainboard, but it doesent boot.

 

Is there any way to boot this distro?

 

 

Try enabling legacy on the flash drive

Advanced ->USB Configuration->Legacy USB Support

Enable Legacy USB Support. AUTO option disables legacy support if no USB devices are connected. DISABLE option will keep USB devices available only for EFI applications.

Link to comment
Share on other sites

12 minutes ago, JMRR said:

@pocopico is there any requirement to run this system?

 

I have an Asrock J5005-itx, and in bios there arent many options to use. 

i folowed all steps but cant boot this distro.

All 3 partitions show on bios but any one i choose to boot it flashs a screen fo a 1ms and returns to bios.

 

I tried to burn image several times with Rufus and Win32diskImager and select 3 partition as active.

Tested on all usb ports of mainboard, but it doesent boot.

 

Is there any way to boot this distro?

 

 

That board has UEFI only boot capabilities. 

 

I will tell you I've been able to boot that board fine with the older TTG 7.0.1 boot images I have built. I have not tried with the tinycore stuff yet

Link to comment
Share on other sites

5 hours ago, pocopico said:

 

@g4sho And everybody that is interested, the MPT3SAS driver has been updated to 22.00.00.00, please retry to create your loader with the new module.

 

 

@pocopicoWE WiN! Thank you so much, that did the trick. You are one helluva programmer and troubleshooter. The community is blessed to have you. Keep it moving forward.

20220114_165115[2].jpg

Edited by g4sho
Clarification
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...